Accessories: Fixing Accessories to Display Properly with the Pets EP (or later)
44 users say thanks for this. (Who?)
Tiggerypum writes:
Accessories with the Pets EP and apparently Seasons display with odd bleed-throughs, in game only. They will display perfectly in bodyshop, CAS, and the accessory selection window - but when your sim wears them, especially in daylight, you can see display problems - little glitches (or sometimes big) where the accessories bleed through.

You can see this thread and this thread for more info and screenshots.

Windkeeper writes:
I spent several hours comparing my custom accessories, those that worked with those that didn't, and I think I finally found one setting that fixed the problem with my bunny ears. See how the non-updated ears overlap in the picture while updated yellow ears don't.

In Material Definition under cMaterialDefinition tab change the Type from StandardMaterial to SimStandardMaterial.

This still needs to be tested, I would appreciate any input on that.

Wind

Tigggerypum adds:
This usually does work, but on further testing, some accessories display with damaged uvmaps with this change. (potentially those made by using OBJ export, the reasons why are not certain). At any rate, this does seem to work for most accessory meshes, just be sure that you test your mesh _in game_ to verify the fix did what it should. In my testing I changed every one of the Material Definitions, some of my accessories had 18 of them!

Also Note: This does not change or solve the random flashing blue accessory problem, only the display-bleedthrough problem

Screenshots
Reply With Quote

Click here to view comments, or to add your own.