Home | Help | Download | Community | Site Map | New Posts | Sign in
MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Carpool Not Showing Up - FIX

by Erzengel Posted 23rd Jul 2005 at 11:17 PM - Updated 16th Dec 2008 at 1:20 PM by -Maylin-
66 Comments / replies (Who?) - 24 Feedback Posts
Everywhere I've looked has claimed this problem is well reported yet unsolved, so I took a few minutes out to solve it.

This fixes the carpool, bus, taxi, and service vehicles "not showing up." What actually happens is one or more to the car portals has been deleted, probably through no fault of your own.

This collection includes all four vehicular portals, and instructions upon how to determine which you need and where to place them. Please make sure that you keep those instructions with the collection so you will know what to do the next time your carpool takes a vacation.

Please note that this is a manual solution that mends a broken component. To prevent the breaking of the component, check this thread. It should make it less likely to lose the portals. If you still lose the portals, or lost them before installing Crammyboy's fix, this will still help.
Style: Not Applicable
Room: Outdoor
Maxis Flags: Not Applicable

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

TS2 Original Game

You need to be a Registered Member to be able to download from MTS. Registration allows you to thank and leave comments for the creators, see your download history, participate in the discussions and much more!

Basic Download and Install Instructions:

1. Download: Click the download link to save the .rar or .zip file(s) to your computer.

2. Extract: Use WinRAR (Windows) or Stuffit (Mac) to extract the .package file(s) from the .rar or .zip file(s).

3. Place in Downloads Folder: Cut and paste the .package file(s) into your Downloads folder:
  • Windows XP: Documents and Settings\(Current User Account)\My Documents\EA Games\The Sims 2\Downloads\
  • Windows Vista: Users\(Current User Account)\Documents\EA Games\The Sims 2\Downloads\
  • Mac: Users\(Current User Account)\Documents\EA Games\The Sims 2\Downloads\


Need more information?
 
Page 1 of 3
66 Comments / Replies (Who?) - 64 Feedback Posts
Lab Assistant
#2 Old 24th Jul 2005 at 12:05 AM
How Cool Of You To Come Up With This..... Thanx Bunches, I will Try It Out. I was confused on how some of my lots the carpool would show up and on others, It didn't seem to work or if it did it was random... Strange Indeed.


GREAT JOB :clap:
TickleYu (Teresa)
Test Subject
#3 Old 24th Jul 2005 at 12:24 AM
I don't understand maybe its because I don't have that problem hmph.. I don't know
Test Subject
#4 Old 24th Jul 2005 at 12:38 AM
Thank you for taking the time to do this! I am sure you've just helped a whole lot of people!!!

THANK YOU!
Instructor
#5 Old 24th Jul 2005 at 2:06 AM
I had to delete so many custom made careers of because this problem. Halfway through the job there were no more cars coming to pick you up. Strange that it only happens with those jobs and not Maxis. I will try this one out. Thanks you for taking the time to help.
Inventor
#6 Old 24th Jul 2005 at 3:37 AM
Thank you! I never even thought of this! Great work!
Test Subject
#7 Old 24th Jul 2005 at 3:43 AM
Will this help for the problem with NPC's not being able to arrive. My sims are tired of putting out their own cooking fires, cleaning house, gardening etc.
Test Subject
Original Poster
#8 Old 24th Jul 2005 at 3:56 AM
I would need to see the log files from such a problem to determine if it can be fixed through a similar method. This fix probably won't, but if the problem is the same, then I can fix it just as easily. Turn on "boolprop testingcheatsenabled true" and call an NPC over. If an error message pops up, make note of the log file and PM it to me.
Test Subject
#9 Old 24th Jul 2005 at 2:18 PM Last edited by SIMplyLisa : 24th Jul 2005 at 2:22 PM.
Default NPC Portal busted
Erzengel,
Here is a log file. Let me know if this isn't what you wanted. It would be so great to finally see a solution to this one other than nuke the lot!
Download - please read all instructions before downloading any files!
File Type: rar ObjectError_N005_t3120281.rar (9.0 KB, 45 downloads)
Test Subject
Original Poster
#10 Old 24th Jul 2005 at 11:23 PM
I have uploaded a revised version with additional instructions. You should now be able to solve both service and regular cars. Please read the provided instructions to diagnose and repair the problem. (Sorry, I don't know enough about BHAVs yet to make a more user friendly repair)
Test Subject
#11 Old 25th Jul 2005 at 12:06 AM
Erzengel, You are a genius! Your fix worked like a charm! This has been bugging us for months, We knew the portal was broken but not how to fix it! Thanks you, thank you!!

I did have one problem, I didn't point the arrow on the object in the right direction the first time and ended up with the car sideways on the street! Might want to add this to the directions! (for other stupid people like me). Point arrow in the direction of travel!

So is there any way to figure out where the other invisible portals are to maybe move them to suit? Just curious.

I noticed on my log file the ports where numbered a little different than your directions, I wonder why?
Object Name : Portal - Pedestrian id : 6
Object Name : Portal - Pedestrian id : 5
Object Name : Portal - Car - Stop id : 4
Object Name : Portal - Car - Start id : 3
Object Name : Portal - Car - Service Stop id : 2
Test Subject
Original Poster
#12 Old 25th Jul 2005 at 3:58 AM Last edited by Erzengel : 25th Jul 2005 at 4:00 AM.
Hmm, it seems that the IDs can be different between houses.

Also, thank you for informing me that the direction is relevant, I didn't test it on the house that wasn't working and didn't have any more to test it on. I've updated that bit of the instructions. Otherwise no changes.

I have been unable to pick up the portals once they have been placed, and I've certainly tried. I'll look into seeing if I can temporarilly add a model to them so that you can find them and pick them up.
Field Researcher
#13 Old 25th Jul 2005 at 6:03 AM
This is a excellent thing to have handy. I had something similiar to this for Sims1 and I used it very often. Also I've noticed a little problem like this with the mail box, mail just stopped being delivered and then I happen to see a dL here of several oddities and a mailbox happen to be included along with the CAS setup, etc and just put up another mailbox and all fixed. So imagine this kind a works the same. Great idea thanks a bunch
Test Subject
#14 Old 26th Jul 2005 at 1:45 PM Last edited by Sealion : 27th Jul 2005 at 2:28 PM. Reason: Update with testing results.
I just downloaded so I'll say thanks in advance. I have this problem with one of my sims with the whore career. After her first promotion, all I get is the 'carpool will arrive in one hour' message and then nothing. If this does not work I will edit this message. Again, thanks a bunch - I hope this works.



Well, this is a neat idea, but did not solve my problem. I either have a bad lot or a hack thats 'hacked' up my car pool!


This will remain the land of the free only so long as it is the home of the brave.
Elmer Davis - 1890-1958
Test Subject
Original Poster
#15 Old 28th Jul 2005 at 12:20 AM
If it's only happening with a sim in a particular career, but the taxi & schoolbus come, then you can't fix it with this. It sounds like a problem with that particular career, not the lot. Sorry I can't help with that problem.
Test Subject
#16 Old 31st Jul 2005 at 4:09 PM
i don't undestand
Field Researcher
#17 Old 6th Aug 2005 at 4:47 PM
Well, it's either do this or move out the affected family and bulldoze the lot. Those are your two choices. Sure wish I knew what caused these portals to disappear in the first place.
Guest
#18 Old 11th Aug 2005 at 1:02 AM
Hi Erzengel,

I just tried this fix and unfortunately it didn't work for me. What happens to me is this (this happened with *and* without the fix):

- I have a Sim call a taxi;
- The dialog pops up "Are you sure blah blah";
- I click OK and the popup pops up again, and again, and again, and again.. Untill I click "No", then the popup disappears again. So, "Yes" puts the dialog in an endless loop.
- In the meantime, no taxi arrives and my Sims are stuck at the lot.

The same thing happens with school buses and carpools, nothing arrives. Wherever I place the portal (I have tried MANY locations and directions), nothing works.

Hope this helps you creating a new version of the fix (if you were planning one). In the meantime, I have moved my family to another lot.. *sigh*
Test Subject
Original Poster
#19 Old 13th Aug 2005 at 7:33 PM
To truly help me diagnose a problem, you must "boolProp debugTestingCheatsEnabled true" and then reproduce the error. If a pop up appears with the buttons "ignore", "reset", and "delete", then make note of the .txt file. Find it in your My Documents\EA Games\The Sims 2\Logs and PM it to me. I'll look it over and see if I can figure it out. I've never seen the "are you sure?" dialog box repeat itself, so I don't know what may or may not be wrong.
Test Subject
#20 Old 14th Aug 2005 at 2:17 AM Last edited by BlackAngel : 14th Aug 2005 at 2:22 AM.
Hmm.. Have I got this right..? This fixes allready existing/prevents future stuck NPC bugs..?

EDIT: Is this for Uni only or does this work with TS2 w/o Uni too?
Test Subject
Original Poster
#21 Old 14th Aug 2005 at 4:24 PM Last edited by Erzengel : 14th Aug 2005 at 4:32 PM.
It allows you to manually fix vehicles that stop appearing or appear for a frame before disappearing. I'm working on a more... automatic solution.

It should work with TS2, TS2U, and I'd bet that, unless they change how collections function in later XPacks, it will continue to work for all future expansions.

For a more preventive solution, so that it is less apt to happen, check this thread.
Test Subject
#22 Old 15th Aug 2005 at 1:10 AM
Excellent, thank you very much for this....
Mad Poster
#23 Old 16th Aug 2005 at 3:40 AM Last edited by niol : 16th Aug 2005 at 3:54 AM. Reason: mor 2 +
Don't mean to increase your work load...
But, I wonder what will happen when I add more than one and/or even on a normal lot?

As for "I have been unable to pick up the portals once they have been placed, and I've certainly tried. I'll look into seeing if I can temporarilly add a model to them so that you can find them and pick them up."
Presently, one may wanna place some objects like the post box or something to mark its location and remember how far it's from the pedestrian in a constant manner or tile differently (with the cheat "moveobjects on") to mark its exact location to ease the fixing.

It may have a similar pick-up problem like an edge-column... But, I believe sorting it around the base area of the grid it's located should be the best bet. However, the pick-up location can be at the very edge of the grid. Besides, the cursor may not be precise enough to show where it's exactly pointing at, so test the effective area out with objects easier to pick up

Hope this may help.
Field Researcher
DELETED POST
17th Aug 2005 at 6:19 PM
This message has been deleted by Ancient Sim. Reason: Problem sorted. For some reason, the missing delivery start portal was stopping TAXIS turning-up to take graduates back to t
Test Subject
#24 Old 18th Aug 2005 at 1:32 AM
It worked!!! My old, abandoned Legacy lot is now usable again! This is a real miracle!

Just one question -- are you sure the position for 'service-start' (which was my missing portal) is exactly right? Or I should ask -- by '2 squares in' do you mean 'on the 2nd square' or do you mean 'on the 3rd square, so that there are 2 empty squares in between'?

Because I did the first... on the second square in... and it works brilliantly but the vehicles come in half on the sidewalk! It's kind of funny, so no big deal, I'm just glad it WORKS! But... is it that the instructions are wrong, or that they are unclear and I did it wrong?
Test Subject
#25 Old 18th Aug 2005 at 5:40 AM Last edited by Htksos : 18th Aug 2005 at 5:43 AM.
Thanks, My wife has had several lots destroyed by this and it has been annoying us, and the only fix I found was to move the family out bulldoze the house and start again. it worked for me, but it kept returning on my wife. I looked at the logs and figured out it was a missing portal, but couldn't figure out how to replace it.

I've been able to move the maxis portals with moveobjects, the pickup point is in the dead center of the tile. I don't know about yours, I assume you made the portal object "buyable".
Page 1 of 3