Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 4 (Who?), Viewed: 4228 times.
Theorist
Original Poster
#1 Old 28th Apr 2012 at 1:46 PM
Default Same mesh, new GUID?
Hi there, I was wondering if it's possible to clone an item - say a photo frame - and then recolour the picture part and have it exist as a singular new object? I'm a stickler for having things organised, and if it's a new set of photos in a batch as a new object [still harnessing the maxis mesh] it'd be really cool. I think I did this accidentally years ago, but I'm stuck now. I thought you needed to clone the object, create a new package file, assign a new GUID and add in the recolours? Am I right or is there another step or is this just impossible without major tweaking?
Cheers!


BodyShopped /// ShoofleedSims
♦ // Jack.exe // ♦
/
Advertisement
Abdicator of Madness
staff: super moderator
#2 Old 28th Apr 2012 at 3:01 PM
Tick the box for referencing original mesh. This way your basically/kinda/sorta just recoloring the original. I think this is what you want? A new clone that shows up separately in the catalog but your not changing the mesh? If in this - say photo frame - you want your new clone to reference the picture from the original, then you will need to repository link the photo part, leaving just your frame recolorable in your new clone.
Theorist
Original Poster
#3 Old 28th Apr 2012 at 3:23 PM
Brilliant, thanks Lunie, Hopefully it'll work now!


BodyShopped /// ShoofleedSims
♦ // Jack.exe // ♦
/
Field Researcher
#4 Old 28th Apr 2012 at 3:57 PM
I tried this, and gave the object a new GUID (I'm working on that pineapple poster from Nightlife.) The second version, the one I've changed the name and description of, shows up in my catalogue and I can place it fine (and it doesn't share the recolours from the original, which is perfect) but then when I went to place the original version, it wouldn't let me place the object (it didn't appear.. the game registered my click but the cursor just remained the cursor, not a hand holding the object!)

Any idea why? Could it be something to do with Scenegraph Rename Wizard? I'm not too sure how that works...
Abdicator of Madness
staff: super moderator
#5 Old 22nd May 2012 at 11:05 PM
So this one popped back up for me today, no idea why. Have you solved this?

Here is what I did, and it appears to work as (I think) what you want. An identical object showing in the catalog, is recolorable on it's own, but the package does not contain the mesh.

In SimPE select clone, and choose your EA object (I chose Red vs. Blue), click the Set Defaults in SimPE, then in the boxes additionally check the Reference Original Mesh box, and Finish. The Scenegraph wizard MUST contain a name that is unique, to EA objects as well as yours/others. You should be able to keep the default string that pops up as it hashes your ID and some numbers, etc, etc. Assign new GUID, tick box to update MMATs and Update.
Back to top

Section jump