Home | Help | Download | Community | Site Map | New Posts | Sign in
Replies: 1 (Who?), Viewed: 6136 times.
Test Subject
Original Poster
#1 Old 27th Aug 2009 at 10:50 AM
Default Disc Authorization Failure?
Alright guys, I'm having a bit of trouble running my [legit] copy of The Sims 3 for Mac. Prior to any of the updates (i.e. Fresh out of the box) I was able to run any sort of CC (hair, awesomemod, makeup, etc); However, post updating, my game has been crapping all over me. I know exactly where my problems root from, it's the damn CC.

See, the particular problem is this:

Everything is in the right place, Resource.cfg, mod folder, package folder. (I know this, because prior to updating EVERYTHING worked fine) However, now, whenever I try to load the game with anything pertaining to CC, the game craps out on me and gives me the Disc Auth Failure message. I've run several tests to see which item is causing this problem, and it seems like both are the culprits. The .cfg file and the mods folder. I've tried it with both in the root folder, just the .cfg in the root folder, and just the mods in the root folder. Every single time, I get the disc auth failure. Now, if I remove the mods folder and the .cfg file totally, the game will run fine. No bumps, hiccups, nothing. I put it back in, it fails to load. I've also tried to single out which particular CC is the culprit, and every single THREE of them have failed to load on me.

Now, is this just the product of a horrible update or are one of my files corrupting the game itself.

Like I've mentioned previously before, I know everything is in the right place. Everything has worked prior to updating.
Advertisement
Pettifogging Legalist!
staff: retired moderator
#2 Old 27th Aug 2009 at 2:53 PM
Do you know that in order to properly remove custom content, you also have to remove your cache files?

The only connection that I can make between disc authorisation and custom content is that there are mods that will bypass the authorisation (without you being aware of it), and if you didn't remove your cache, the game may still think that such a mod is present, and then when it tries to load the mods that you actually have in /Mods right now, they clash and somehow make the authorisation fail even though you have the disc in the drive.

See this FAQ for how to remove your cache files: http://www.modthesims.info/wiki.php...Loading_Crashes

Try that, and then starting the game without any CC (neither the resource.cfg nor the actual packages), and let us know what happens.

Also, be aware that some mods may not be compatible with the patch you have now. For testing purposes, always try with something "harmless", like one pattern.

Also, try cleaning your disc.

Newbie Road/Wee Barnoid: Starter houses | Backdoor Lane: Urban lots | Baskerville | Middleground | Elsewhere

I'm gone for now. Boats > Sims. Thanks for everything it was a great time!
 
Back to top

Section jump