Home | Help | Download | Community | Site Map | New Posts | Sign in
Replies: 3 (Who?), Viewed: 3808 times.
Test Subject
Original Poster
#1 Old 20th Oct 2011 at 2:34 AM
Default Sims 3 Pets Crashes After Launcher
Hello!

This is one of my first posts... ever on MTS, so bear with me.

I purchased TS3: Pets today and attempted installation after installing all game patches, etc. Everything worked smoothly until I attempted to launch the game from the launcher. The loading screen with the plum bob (I think that's what they're called) will flash for a moment, and then nothing. It's very disheartening.

I've read through the MTS help docs and have checked and double checked installed content, caches, user info, etc. I've removed it all and attempted to launch the game each time. Nothing seems to work!

I'm currently on an iMac running OSX 10.7.1. My graphics card is an AMD Raedon HD 6770M, with a 2.7 processor and plenty of memory. Any idea where I could be going wrong? At this point, I'm not too attached to my saved games (I've only had this computer for a few weeks, couldn't do too much trouble in that amount of time) - I'd just like the game to work.

Thanks!
Advertisement
In the Arena
staff: senior moderator
#2 Old 20th Oct 2011 at 4:23 PM
Thread moved to Mac Help...

So this is a cc-free, vanilla game on one of the default worlds that is crashing?
Test if it crash when you don't use Launcher to start the game. Game Help:TS3 Bypassing the Launcher#OS_Xwiki

Have you done these steps when the crashing keep returning?
  1. delete preferences
    • /Users/<Username>/Library/Preferences/The Sims 3 Preferences folder
  2. delete caches:
    • <diskname>/Library/Caches/<anything with Sims 3 in it>
    • /Users/<Username>/Library/Caches/<anything with Sims 3 in it>
  3. repair permissions
    • /Applications/Utilities/Disk Utility, "Repair Permissions"
Test Subject
#3 Old 3rd Nov 2011 at 1:47 AM
Quote:
Originally Posted by ellacharm3d
Thread moved to Mac Help...

So this is a cc-free, vanilla game on one of the default worlds that is crashing?
Test if it crash when you don't use Launcher to start the game. Game Help:TS3 Bypassing the Launcher#OS_Xwiki

Have you done these steps when the crashing keep returning?
  1. delete preferences
    • /Users/<Username>/Library/Preferences/The Sims 3 Preferences folder
  2. delete caches:
    • <diskname>/Library/Caches/<anything with Sims 3 in it>
    • /Users/<Username>/Library/Caches/<anything with Sims 3 in it>
  3. repair permissions
    • /Applications/Utilities/Disk Utility, "Repair Permissions"


I'm having the same problem as the user above, I've done all of the above, I've uninstalled the whole game and reinstalled, updated and patched, followed everything you've listed.

Do you know if Sims 3 is having issues with Pets and Mac users?
Test Subject
#4 Old 12th Dec 2011 at 6:18 AM Last edited by creativebystander : 12th Dec 2011 at 6:25 PM.
I know these posts are rather old, but I'm having the exact same issue. This is the only thread I've found that applies. I downloaded the game from Amazon today, and I have since uninstalled, redownloaded, and reinstalled. (I can not do a full uninstall as I'm at university and don't have all my game disks.) The came is currently clean of all CC, saves, and caches. I followed the steps recommended above. I have even switched back and forth between bypassing the launcher, just for the heck of it. However, the issue persists. Are there any other suggestions or solutions out there?

(I should note that I'm running the game on Snow Leopard, and when I remove Pets, Generations runs just fine.)

EDIT: I've contacted EA for the heck of it. They recommended turning off all background processes with activity monitor. I'm not surprised that it didn't solve the problem.
 
Back to top

Section jump