Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Creator Theme: Space! - posted on 8th Jul 2018 at 6:02 PM
Locked thread | Replies: 1398 (Who?), Viewed: 157116 times. | Locked by: Numenor Reason: Please refer to the ACTIVE THREAD ([url]http://www.modthesims2.com/showthread.php?t=104795)[/url]. This is only an archive of old posts.
Page 4 of 56
Mesh Maestro
Original Poster
#76 Old 8th May 2005 at 10:30 PM
He is right(Numenor)... "Stand Alone" must be checked here is the package with that theory applied...

Reading is the key to all knowledge, math is the key to everything.
Test Subject
#77 Old 8th May 2005 at 10:44 PM
Thank you, thank you!!! I can't tell you how grateful I am for your help, this has been driving me insane for the best part of a week. I was convinced that if I saw a picture in Simpe's list rather than a blue shape it was a real Maxi's object.

And the PSP8 plug-in has cured the horizontal lines in the textures, too - now I can make something at last!

Again, thank you so much.
Lab Assistant
#78 Old 9th May 2005 at 2:18 AM
When I get to the Object Wizzard part I get: Runtime Error 9 Script out of range. I am using wings and when I open the object up in UV mapper it says, the model you have loaded contains out of range UV coordinate. DO you want to correct this?

What does all this mean? What am I doing wrong?
Mesh Maestro
Original Poster
#79 Old 9th May 2005 at 2:46 AM
As far as the runtime error goes that could be a few things... First try choosing yes to correct the out of range coordinates... Always choose this option when you run into it.... Large mesh's are capable of producing runtime errors, that would be my first guess...
Lab Assistant
#80 Old 10th May 2005 at 2:44 AM
I always choose yes and that is why I think there is a problem. If I choose no then it does not load anything. Prehaps Wings does something to .obj's. It is a small boombox just like in your tut.
Mesh Maestro
Original Poster
#81 Old 10th May 2005 at 2:59 AM
If you want to upload it I can get an idea of what is happening... I will check back in a bit...
The ModFather
staff: retired moderator
#82 Old 10th May 2005 at 2:54 PM
Cold_Ethyl, I use Wings, too, and I always have that problem. The way Wings saves the .obj files is different from what the MeshTool expects.
I use 2 alternative solutions: edit manually the .obj file (that is a text file, after all; I've created a Macro in Word to perform tha task automatically), or importing the object in UV mapper and then exporting it (UV mapper outputs a file suitable for the MeshTool and fixes the out-of-range UV coordinates set by Wings).

If you are interested in manually editing the .obj file, you have to use the "Replace" function of your text editor, and perform the following replacement (the square brackets are only to show the text to replace: don't copy them):

[mtllib] -> [# mtllib]
[g ] -> [#g ] (notice the space after the g)
[o ] -> [g ] (again, notice the spaces)
[usemtl] -> [# usemtl]

Basically, Wings saves the different meshes as "groups", while the MeshTool treats them as "objects" (that's why I replace the [g ] with the [o ]); moreover, the MeshTool doesn't use the Material Libraries (mtllib), so, I comment out any reference to them. Maybe this solution is a bit "rough", but it worked for me, until I begun using UV Mapper.

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Lab Assistant
#83 Old 12th May 2005 at 3:39 AM
Ill try and figure that out in the text editor. I don't have Word just Abiword. Ill mess around with it.

I have used the mapper export and Ive tried having it fix the problem and then clicking no for it to leave it alone. I will try to figure out that manual editing of the file. Thanks for the help.
Lab Assistant
#84 Old 12th May 2005 at 3:55 AM
Ok I went and did the replace ment, that worked, but then I tried to get it into SimPE and I get this:


Message:
Error while trying to open C:\Documents and Settings\Shawna\My Documents\Temp Boom Box folder\AILFirstmeshboomcrapbox.simpe SimPE Version:
0.35.1930.21496.

Exception Stack:
System.OutOfMemoryException: Exception of type System.OutOfMemoryException was thrown.
Mesh Maestro
Original Poster
#85 Old 12th May 2005 at 3:57 AM
Once you save it as an object file from UVMapper it should have done the same as if you edited it as a text document... As I mentioned you are welcome to upload it and I can better resolve your issue... . I do not share peoples mesh's or give detail to anyone but the person who "owns" the package. I also do my best to remove packages as soon as the user downloads them to prevent anyone else from downloading them...

If you elect not to upload it that is ok as well... I have a hunch what is wrong already but sometimes like cases like this that we can not see physically it can inly be a "hunch"... Here's my hunch... I am going to guess the poly count is enormous... I say this because I have seen a similar problem before... Like I said just a hunch...
Mesh Maestro
Original Poster
#86 Old 12th May 2005 at 4:04 AM
Hmm... I use the same version of SimPE... I have seen that error as well... Now that I see your new post it's nothing to do with poly count therefore my "hunch" was wrong... I am going to try and remember that error... I want to say I saw it either when I had the game running or if I had the same file in SimPE open twice but I am not sure off the top of my head... I'll check back in a bit...
Lab Assistant
#87 Old 12th May 2005 at 4:15 AM
Alrighty thanks. Its just a box so I was sure it wasnt the polys. Here is the package file. I don't know what goood it would do though :confused:


*I added the obj file to
Mesh Maestro
Original Poster
#88 Old 12th May 2005 at 5:06 AM
OK ready? Do not get discouraged as you have gotten almost all the way home...

I have you first package "boomcrapbox" imported in simpe... I noticed that you have several shapes(forgot to "group" them together)... It did load into SimPE with no error though...

The obj. file is "grouped" though it needs to be scaled down and you also left the old "boombox" you cloned in the object....

My suggestion is to go through the tutorial again... I have followed a great many tutorials and have had to do everyone a couple times before I really got the hang of it and didn't forget a step or two...

I am not sure of the error you describe because I did not get it with your package... I would check in your SimPE folder in "program files" and be sure you have the rcol plug-in. I believe SimPE installs it for you though...
Lab Assistant
#89 Old 12th May 2005 at 5:11 AM
No no that was the wrong obj mesh lol. Before I took out the box. I have so many of the saved from trying to fix it I dont know which is which, Ill look for the actual mesh.

As for it not being grouped, hm. I was going by your Milkshape version of it and just guessed with wings. Ill look around on it. I dont know why it didnt give you an error because I have everything where I am suposed to have it and I have all the plug ins. Dont get it.
Lab Assistant
#90 Old 12th May 2005 at 5:15 AM
Here is the obj.

Im getting fustraited with this lol
Mesh Maestro
Original Poster
#91 Old 12th May 2005 at 5:21 AM
Here is both files back fixed The obj and the SimPE file to "replace" in the GMDC... I did it exactly the way I explained so if you can not replace the file with the one I re-did then it is a SimPE problem as far as the error message...
Post back your results as I am now curious...

Reading is the key to all knowledge, math is the key to everything.
Lab Assistant
#92 Old 12th May 2005 at 5:29 AM
Yeah its SimPE. Dang it. I guess I dont have everything. Where can I get that plug in you mentioned?
Mesh Maestro
Original Poster
#93 Old 12th May 2005 at 5:40 AM
Ok, first thing go to the SimPE site and click downloads...

Then loof at the requirements..

Make sure you have net framework and direct x 9c installed as directed... then redownload SimPE I created a temp. URL(will remove after you use it) to be sure you have correct version...

After installing if you still have the same error maybe you could open your SimPE folder and take a screen shot and post it... I will compare files with it here...
Lab Assistant
#94 Old 12th May 2005 at 5:55 AM
I have the direct x that came with TS2. I am downloading off the MS site right now just to cover all bases. I will re-download SimPE as well. It's getting late (here anyway) so dont let me keep you up, this will most likely take awhile since I am on dialup. Thank you for your help and I will get back with you later
Lab Assistant
#95 Old 12th May 2005 at 6:24 AM
Ok I updated DX9, downloaded the SimPE on your link (you can take it down now), rebooted, and I still get the error when opening the package you sent back so I have included screenshots of my SimPE folder plus the plugins folder.

I also wanted to ask if the fact I have to click all files when trying to open the file has anything to do with it?
Screenshots
Mesh Maestro
Original Poster
#96 Old 12th May 2005 at 8:08 PM
Quote "I also wanted to ask if the fact I have to click all files when trying to open the file has anything to do with it?"

your comment above' can you be a bit more specific? which files do you mean when you say you have to click all? That sounds like it may play a role here...

Your files are in order as far as I can see...
Lab Assistant
#97 Old 13th May 2005 at 4:58 AM
Well when I click open the package file does not automatically show up, I have to click the *all files* option. *See thumbs*

It's most likely something very simple and Im missing it. I have luck like that lol.
Screenshots
Mesh Maestro
Original Poster
#98 Old 13th May 2005 at 5:30 AM
Try double clicking the actual package you are working on to open it... Sims 2 package is the file type... I think running over to the SimPE site and posting your error in there forum may bring you faster resolution than I am giving you... I hate to see you go on when as you said it is most likely something simple... You may want to take a look in your options/settings in SimPE and go through them and see if they look o.k. too.
Lab Assistant
#99 Old 13th May 2005 at 7:01 PM
Well when I double click to open it it gives me that error.

Quick question, I looked in the options/folders and am I suposed to have the Invidia DSS tool folder when I have an ATI card or is that used for something else?
Mesh Maestro
Original Poster
#100 Old 13th May 2005 at 8:08 PM
The NVidia DDS tools are ok... They are just that, tools and have nothibg to do with your graphics card... I use the ATI 9800 xt pro and also have the DDS tools and I use DDS format textures... No problems there... I reccomend You post in the SimPE forum as your problem is rare to me... I am sorry I haven't found a sollution...
Closed Thread
Page 4 of 56
Back to top