Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Nysha's New Creators for July - posted on 1st Aug 2018 at 9:00 AM
Replies: 3 (Who?), Viewed: 3275 times.
Field Researcher
Original Poster
#1 Old 22nd Mar 2018 at 1:27 PM
Default Add a texture image when there is only a TXMT?
I've done it the other way around - delete the texture image of a subset, and just "bucket-fill" the whole thing by picking a color for the stdMatDiffCoef property. To get that to work, I replaced the TXMT with one from an object that never had a texture image and pasted the old filename back in. (Means: I could never quite figure out what I really need to look out for. I just copy-pasted, so to say.)

Does that work the other way around? Create a texture image for a subset that never had one and point it to that? I tried the TXMT-replacing to accomplish that, but never got it to work. Any ideas?
Advertisement
Dancing Flamingo
staff: administrator
#2 Old 22nd Mar 2018 at 9:17 PM
Yes you can. The easiest thing to do is extract a txtr from another package, import into yours, change the resource name to match your package, do a Fix TGI (not Fix Integrity). Edit the txmt to add stdMatBaseTextureEnabled with a value of true, and add stdMatBaseTextureName with the name of the txtr with the preceding ##0x1C050000!.
Field Researcher
#3 Old 23rd Mar 2018 at 2:08 PM
Make sure you remember to update the name in the Description field in the cMaterialDefinition tab, it needs to be the same the name of the TXMT minus the _txmt extension and include the ##0x1C050000! prefix (if the group is 0x1C050000). Without that the texture will work fine in SimPE and can be viewed in the GMDC but the game will probably fail to find it.
Field Researcher
Original Poster
#4 Old 26th Mar 2018 at 11:07 PM
Great, it's that easy. Thanks!
Back to top