Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Speed-Building Challenge - posted on 17th Oct 2018 at 7:25 PM
Replies: 329 (Who?), Viewed: 532050 times.
Page 2 of 14
Alchemist
Original Poster
#26 Old 16th Jan 2007 at 9:32 PM
Quote:
Originally Posted by cultjam
Nope, didnt work. I even re-installed everything - program, plug-ins.


Well, sorry. If I knew what was wrong I'd fix it, but it works well here, and on almost every other user's computer. I have never tested it on anything other than Windows XP, nor do I have the facilities to do so.
Alchemist
Original Poster
#27 Old 16th Jan 2007 at 9:38 PM
Quote:
Originally Posted by DogLover258
Hey, i'm sorta new to this site, actually, i'm really new to this site, i just signed up yesterday and i've been trying to download the Unimesh, but everytime i click on the download, it goes to the 'page cannot be displayed' thing, i tried it on all the other computers too, but they all show the same thing, does anybody think they can help me? Please, because i really want to learn meshing and i can't do it, so... yeah, thanks!


When you posted your message, and when I posted this reply, there was a notice at the top of the page in BIG RED LETTERS that said:

Downloads are OFFLINE for a fileserver upgrade. They will be back when this message disappears.

I would suspect that it is at least related to the problem you are having. Be patient, things will be fixed sooner rather than later and you can get going then.

<* Wes *>
Instructor
#28 Old 16th Jan 2007 at 11:12 PM
Hey Wes-- just popping in to let you know, the new plugins work PERFECTLY! I've used them extensively this past week and created a whole pile of multi-part meshes with reflective layers and alphas and the works, and not a glitch or hiccup to be found. Thanks again!

Be sure to stop by Warlokk's Tower Workshop to see my latest creations!
Need help with the Bodyshape Sets? Bodyshape How-To Tutorial updated 11-18-06
Alchemist
Original Poster
#29 Old 17th Jan 2007 at 12:33 AM
I'm glad they work well there... I know you are a demanding user and a perfectionist.

Since you build pretty large packages due to the high number of meshes, there is a new keyword you can put in the group comments for morph base groups "NoMorphNorms:". It prevents a set of normal deltas from being generated on morphs. Lots of the EP meshes originally had no normal deltas in the morphs. The new importer will add the keyword if the original mesh lacks normal deltas.

This could shrink your final mesh file sizes around 8% to 10% or so (depending on number of morphs). The base game had no trouble with the omissions in my testing, and I have seen no detectable shading effects from leaving the normals out.

<* Wes *>
Field Researcher
#30 Old 17th Jan 2007 at 1:48 AM
thank you thank you thank you thank you <3

maybe i'll finally re-attempt hair-meshing...

~ h e l a e n e ~
100% free custom content for the Sims 4 at simhelaene.tumblr.com
Test Subject
#31 Old 18th Jan 2007 at 12:10 AM
Quote:
Originally Posted by wes_h
When you posted your message, and when I posted this reply, there was a notice at the top of the page in BIG RED LETTERS that said:

Downloads are OFFLINE for a fileserver upgrade. They will be back when this message disappears.

I would suspect that it is at least related to the problem you are having. Be patient, things will be fixed sooner rather than later and you can get going then.

<* Wes *>


Thanks, i'll try that again. And thank you again!
Alchemist
Original Poster
#32 Old 18th Jan 2007 at 2:47 AM
I like dogs, too.

Anyway, we (while I wrote the plugins, there are some talented people that hangout here) have gotten quite a few people started meshing via this forum and the tutorials here at MTS2 (there were over 600 prior messages in this thread that were put in an archive). Some of the people that got started here are featured creators on MTS2, and elsewhere (and some turned paysite pro on us).

While I can't promise you instant success (or much more than blood, sweat and tears), this is as much art as science and if you want to learn it badly enough you will succeed.

<* Wes *>
Field Researcher
#33 Old 18th Jan 2007 at 9:11 PM
Now what the **** am I doing wrong? When I try to export my mesh from Milkshape I end up with a 0 kb useless file? I didn't do any advanced editing on that mesh, didn't delete or add anything, didn't fiddle with anything but moving vertices about, really...

I'm using a mesh from the base game, the longer nightgown mesh with one morph. I have MS 1.7.8, SimPE 0.60 and of course the plugins + exporter from this thread (I allowed them to overwrite the present ones in my Milkshape directory.

Thank you very much for helping and for your hard, great work!

- Berg

P.S. I have the manual of course, but most of the content is far too advanced for me to really grasp...

ETA: OK, it's defenitely something I did, if I only knew what...... I tried to export a totally different project and everything went fine. I guess I messed things up somewhere so perhaps I should just start all over...

My 100% free site Carnaby Sims
Alchemist
Original Poster
#34 Old 18th Jan 2007 at 10:31 PM
Berg:

Well, I am mystified, as you are. But if it isn't a repeatable error, then who knows... sometimes the little gremplins insid ethe PC run amok.

If you do have an issue that crops up repeatedly, when you post about it please use the name it has in the game, such as "amBodyScrubs". It isn't normally necessary to specify the "_tslocator_gmdc" part of the name. It takes me a lot less time to find them by name than it does to run the game or BodyShop, look through the pictures of clothes and try to discern which one you mean (especially with all the expansion pack items available).

<* Wes *>
Lab Assistant
#35 Old 19th Jan 2007 at 7:20 AM
wes_h - Thank you so much for this update!! With out your user friendly tools I would not have been able to mesh... Again, Thanks!!

**No Requests**
Test Subject
#36 Old 19th Jan 2007 at 11:26 AM
Thanks so much for this much needed update *smoochies*

Just a pondering as at the moment work is really hectic and i dont have the time to play around with the plugins...about the enabled bumpmapping, does the plugin automatically enable them when you export your mesh back out of milkshape or do we need to go through some other process?

Come and visit my Sims2 site: MANKY SIMS

~Questions regarding my removed trekkie content, feel free to contact me~
Alchemist
Original Poster
#37 Old 19th Jan 2007 at 11:27 PM
For a bumpmapped object, you have to have a mesh that has the "bumpmap normals" in it. The plugin will generate a set of these for each base group that has the group comment "HasTangentArray:" (without the quotes).

The comment will get included automatically on any mesh that had one when it was imported. If you want to add bumpmapping, you start by adding the comment and then exporting the mesh.

No mesh that has bumpmap normals will have bumpmapping appear unless the texture material (TXMT) and texture image (TXTR) are set up correctly. And when that is done, graphically underpowered machines will not display the bumpmapping.

But don't let that intimidate you. It's not all that hard when you follow the list. There are only four lines or so to add to the TXMT and, of course, a bumpmap texture needs to be made (similar to an alpha layer, this is a grey-scale image where the bumps are created by altering the brightness from neutral grey (127,127127).

I don't have links handy for these last two items, but Search here should turn them up readily. There is an object, called Semloh's bumpmap tester, that will readily show if bumpmapping works on any machine the game is running on.

I think a lot more information on this will likely be in the Skinning section here at MTS2.

<* Wes *>
Test Subject
#38 Old 19th Jan 2007 at 11:45 PM
*Does happy dance* Awww Wes thats so great to know, ive been editing a few maxis meshes that have the normal map but of course due to unimesh lost its bumpiness Whee, now i can get them back :D

Thanks so much for your hard work Wes *Chases Wes down and smothers him with hugs and kisses* :D

Come and visit my Sims2 site: MANKY SIMS

~Questions regarding my removed trekkie content, feel free to contact me~
Scholar
#39 Old 21st Jan 2007 at 9:47 PM
Hey Wes!

Assiging animations with the new plugins makes the mesh pull back the hair assigned to the hairbones back into the head.
I only used to have this problem with Pets installed, but I don't have that anymore.

I only have the expansions up untill Open For Bussiness, no stuff packs, your new plugins, Milkshape 1.7.8, and the newest simpe. Before I had no trouble.
Importing and exporting with the .smd exporter/importer has no effect.

(Are the older plugins still available somewehere? )

I will try the older plugins again, and make one mesh with that one (working, probably) and make the same mesh with the new plugins, and send it to you. If you want
Screenshots

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Alchemist
Original Poster
#40 Old 21st Jan 2007 at 10:49 PM
Quote:
Originally Posted by Nouk
(Are the older plugins still available somewehere? )

I will try the older plugins again, and make one mesh with that one (working, probably) and make the same mesh with the new plugins, and send it to you. If you want


I pulled the old package, because I don't want new users downloading the wrong package. If you don't have the older package, PM me you email address and I will email them to you. What you have suggested would make analyzing the problem easier.

I remember your posts about the Pets issue. However, if the old SMD export/import made no difference, then the problem may not lie in the exporter at all (or even in Pets). You may be able to tell by rebuilding with the older plugins.

I would be interested in helping to figure out what is wrong with this, even if it isn't the exporter.

<* Wes *>
Test Subject
#41 Old 21st Jan 2007 at 11:40 PM
i need to get the unimesh.zip files at the top of the page but the llink comes up with the 503 error and doesnt load after 20 x refresh.. help
Admin of Randomness
retired moderator
#42 Old 22nd Jan 2007 at 6:36 AM Last edited by tiggerypum : 18th Feb 2007 at 5:54 PM.
ukch1ckk, the file server for downloads is often overloaded, particularly on weekends in the middle of the day (US time) Try again at off hours. The system news says such, and a new sever is one the way to help with the downloading load.



--- gets in line for the Wes worshipping and offers to marry him ----

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Alchemist
Original Poster
#43 Old 24th Jan 2007 at 12:29 AM
Quote:
Originally Posted by Nouk
Assiging animations with the new plugins makes the mesh pull back the hair assigned to the hairbones back into the head.
I only used to have this problem with Pets installed, but I don't have that anymore.


I have been messaging back and forth with Nouk over this issue.
Nouk fixed this herself, all I have left to tell you is what was wrong, so that
maybe someone else will recognize if this happens to them.

Everyone should know by now that the UniMesh importer stores some stuff in the group and bone comments. Of particular interest for this message is the bone comment that starts ImpQuatDat: followed by seven decimal numbers.
These numbers are needed for the exporter to put the bones back in exactly the same place they were when it was imported. I put them in as comments because there is no 'hidden' binary sort of place available in MilkShape for me to retain these values.

These are normally saved as part of a .ms3d file, which is what Nouk uses while working.

What was wrong was that the values in the last three bone comments had become changed. Whether this was a bad save, a bad load, an erroneous select and move, or what is unknown.

Nouk made her fix by exporting the mesh as a .obj file, loading in a new mesh, deleting all the mesh except the skeleton and bringing her mesh back in. This could have been fixed by tediously copying and pasting the joint coments, too.

<* Wes *>
Test Subject
#44 Old 24th Jan 2007 at 1:29 PM
Okie for some reason my milkshape seems to crash everytime i try and pull up the bone tool. I get the message:

'ms3d.exe has encountered a problem and needs to close..sorry for inconvience etc..Please tell Microsoft about this problem'

Im following this tutorial here:
http://www.modthesims2.com/showthread.php?t=179177 and someone in that thread reported the kind of error i am having and Tig says something about make sure you have up to date unimesh plugins etc, and i think i have since i downloaded the newest ones from this thread.

So where do i go from here? Is is just me? Thanks for any help

Edited to add: Hmm just tested the bone tool on all my older saved msd files and the bone tool seems to come up fine so doesnt seem to be plugin problem. im confussled.

Come and visit my Sims2 site: MANKY SIMS

~Questions regarding my removed trekkie content, feel free to contact me~
Admin of Randomness
retired moderator
#45 Old 24th Jan 2007 at 2:47 PM
MankyUK, hmm. Did you check the Open GL stuff on the milkshape site, maybe your system needs that to work better.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Test Subject
#46 Old 24th Jan 2007 at 5:16 PM
Sorry to be completely clueless, Tig but whats open GL stuff? I dont see anything on the milkshape site about GL stuff.

Come and visit my Sims2 site: MANKY SIMS

~Questions regarding my removed trekkie content, feel free to contact me~
Test Subject
#47 Old 24th Jan 2007 at 6:52 PM Last edited by Numenor : 24th Jan 2007 at 9:44 PM. Reason: Please edit previous post instead of double posting.. ;)
Wes had posted it in a reply to my problem that is the same as yours. It didnt work for me. But I hope we figure it out, what we are doing wrong or whats up.


EDIT:
Where is the link to the older version of milkshape??
I am still having issues with my newer version.

Thanks


EDIT AGAIN:
I found out my problem. But I have another problem. Probably doing something wrong.

Anyway, when I save my meshes in the ms3d file, then open it and use the unimesh bone tool, the program crashes.

But, when I make adjustments to my mesh, then export it, and open the mesh up i exported, in milkshape, I recieve this error: Err: too many p4 block a data items.

Any ideas as to what I am doing wrong?
Alchemist
Original Poster
#48 Old 24th Jan 2007 at 8:36 PM
The message probably needs changed to something more descriptive. It has said the same thing since the earliest plugins I wrote (about two years ago).

P4 Block A is where the bone definitions are kept. If you're working on a body mesh, there should be 65 bones. Almost without fail, this message crops up when a second mesh is imported overtop of another, and the user chooses not to exclude the bones. You end up with two sets of bones (130 total) and the importer is currently set up to reject that many as a corrupt file.

Also, much of the crashing problems people have with MilkShape is caused by outdated OpenGL drivers. Get the latest by going to http://chumbalum.swissquake.ch/ms3d/download.html
and download the "Mesa 6.4.1 Software OpenGL Drivers" package and then install it. This is what has fixed issues with the bone tool and other inexplicable crashes when opening files up.

The bone tool, or any of the plugins, will not operate correctly until MilkShape and the OpenGL drivers are stable themselves, since they work as an extension of MilkShape.

<* Wes *>
As the mesh crumbles....
staff: moderator
#49 Old 24th Jan 2007 at 11:15 PM
Hi Wes. I created an entry for the Unimesh plugin on the wiki. Please take a look at it and modify as you see fit. It points to this thread. Thanks!

http://www.sims2wiki.info/wiki.php?...n_for_Milkshape
Alchemist
Original Poster
#50 Old 25th Jan 2007 at 12:17 AM
You know, I just saw that.
Thank you.

We need more people like you that take the time to organize all the little factoids that pop up in the threads and get them onto the wiki. I know some of the things that have happened to you in your meshing happened to others, and were discussed and are now buried in the old threads, or the BodyChop (UniMesh's parents) thread or the V2.17 plugins (UniMesh's grandparents) thread or whatever I called the first plugin I released, that I made my BioHazard sculpture with (which, by odd coincidence is about the same orange color as the one I made my demo Dog Collar with).

<* Wes *>
Page 2 of 14
Back to top