Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 Calendar Contest Winners - posted on 10th Jan 2018 at 5:38 PM
Replies: 329 (Who?), Viewed: 521537 times.
Page 4 of 14
Alchemist
Original Poster
#76 Old 18th Feb 2007 at 2:39 AM
I will look at it, and reply soon. Curious looking problem.
Thank you for the report.
<* Wes *>
Alchemist
Original Poster
#77 Old 18th Feb 2007 at 9:19 AM
Quote:
Originally Posted by Warlokk
Strangely, it only seems to be affecting the Fat morph too.

I've attached some screenshots to illustrate what I'm seeing, this is my new PowerGirl mesh, which I've already released over at InSIM. Since I can just save and reload .ms3d files I can work around the problem, but I wanted to let you know.


OK. I have this one nailed, although like most jello it will fall off the tree soon. You remember when we used to make meshes with ~00MORPHMOD.1 and ~00MORPHMOD.2?

To try to capture more compatibility with object meshes and Nightlife meshes I had to expand the range of allowable last digits (the target index value) to include zero as a valid value.

Some MorphMaps use zeroes for a no change flag. So now, which zero is a morph and which is a non-morph? Well, the answer is supposed to be in the Morph Vertex Deltas, where offsets of 0.0,0.0,0.0 would indicate no change and other values would indicate a change (morph delta).

I think what has happened is we were mixing old morph deltas with new flag values.

What I did with your file was to change ~00MORPHMOD.0 to ~00MORPHMOD.1 and the old ~00MORPHMOD.1 to ~00MORPHMOD.2. I did this in the .ms3d file, saved, exported to a testfile, did a file/new, reimported my test and it's perfect (and yes, the problem happened here, too).

If you don't mind, I will keep that file here a while and see if I can determine a way to make that change more transparent, either at import or export. Until then, I think the morph name changes will stabilize you work.

<* Wes *>
Alchemist
Original Poster
#78 Old 19th Feb 2007 at 5:42 AM
I wanted y'all to know that I will be offline for some undetermined number of days starting tonight.

I am moving and I will have to get my satelite internet dish relocated. It took me quite a while to get it instaled last year, so if they are equally as inept at arriving for appointments as then, it could be a couple weeks even.

The good thing is I will still be able to play with all the ideas I have while I am offline. I know that Dr. Pixel and Tiggerypum can help answer most of the questions that come up anyway.

<* Wes *>
Test Subject
DELETED POST
22nd Feb 2007 at 7:52 PM
This message has been deleted by bigbry_2442.
Test Subject
#79 Old 25th Feb 2007 at 11:47 AM
I just wan't to say this is a great plug in. Well done and thanks for uploading it.
Field Researcher
#80 Old 27th Feb 2007 at 5:16 PM
Default Bone Assignments
hi!!!

i have a problem using this plugin!!!


when i check bone asignments a few times in a row eventually milkshape will close on its own without giving me a chance to save or anything!!!!

also....when checking bone asignments, if i click to view one vertice or the next the prog will close immediately!!!!

am i the only one with this problem???

what can i do....if anything???


thanks

DOEreoh
Admin of Randomness
staff: retired moderator
#81 Old 27th Feb 2007 at 5:38 PM
Go to the milkshape site and look for the open gl or whatever it is they have there for you if your milkshape tends to crash. Install that also.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Lab Assistant
DELETED POST
28th Feb 2007 at 5:32 PM
This message has been deleted by cwurts00. Reason: wrong post quoted
Lab Assistant
#82 Old 28th Feb 2007 at 5:34 PM
Quote:
Originally Posted by wes_h
OK. I have this one nailed, although like most jello it will fall off the tree soon. You remember when we used to make meshes with ~00MORPHMOD.1 and ~00MORPHMOD.2?

To try to capture more compatibility with object meshes and Nightlife meshes I had to expand the range of allowable last digits (the target index value) to include zero as a valid value.

Some MorphMaps use zeroes for a no change flag. So now, which zero is a morph and which is a non-morph? Well, the answer is supposed to be in the Morph Vertex Deltas, where offsets of 0.0,0.0,0.0 would indicate no change and other values would indicate a change (morph delta).

I think what has happened is we were mixing old morph deltas with new flag values.

What I did with your file was to change ~00MORPHMOD.0 to ~00MORPHMOD.1 and the old ~00MORPHMOD.1 to ~00MORPHMOD.2. I did this in the .ms3d file, saved, exported to a testfile, did a file/new, reimported my test and it's perfect (and yes, the problem happened here, too).

If you don't mind, I will keep that file here a while and see if I can determine a way to make that change more transparent, either at import or export. Until then, I think the morph name changes will stabilize you work.

<* Wes *>


I find this information interesting. I notice in SimPE that the flags for body flags values for fat and pregnant correspond to the MORPHMOD values in Milkshape. Do you know if there's a way to add a MORPH.4 in Milkshape to represent the fit state at body flag 4? I tried this and it didn't work.
Test Subject
#83 Old 3rd Mar 2007 at 12:03 AM
many thanks...
Test Subject
#84 Old 5th Mar 2007 at 2:53 AM
I can download both files...HOWEVER...when I try to open them I'm getting an error, like DogLover is also. Did the files expire?
Test Subject
#85 Old 5th Mar 2007 at 3:00 AM
"The archive is either in unknown format or damaged"

I use winrar. So I tried opening in compressed zip, and still get a very similar message.

I hope you can help me out, but I do understand that you may be busy as well. I hope to hear from you soon.

- Rachel
Test Subject
#86 Old 5th Mar 2007 at 3:11 AM
AH! I was able to repair the zip file. There were problems with it though, so you might want to check that out??
Admin of Randomness
staff: retired moderator
#87 Old 5th Mar 2007 at 3:19 AM
JunLover, you should have simply downloaded again. When the site load is high sometimes downloads still get damaged during the _download_ process. I downloaded and installed these very files without any errors whatsoever.

Also, use the EDIT button, do not post 3 times in a row about the same topic.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Lab Assistant
#88 Old 5th Mar 2007 at 3:42 AM
Quote:
Originally Posted by DOEreoh
hi!!!

i have a problem using this plugin!!!


when i check bone asignments a few times in a row eventually milkshape will close on its own without giving me a chance to save or anything!!!!

also....when checking bone asignments, if i click to view one vertice or the next the prog will close immediately!!!!

am i the only one with this problem???

what can i do....if anything???


thanks



I am having the same problem with milkshape currently after trying to install it on two new systems I've not had it on before, I have downloaded and installed 1.7 10 mulitple times , after each install updated all the plugins I use, wes's and demon's, put the mesa 641 dlls in milkshapes directory and check to make sure the systems have the latest version of direct x, and the video cards have updated drivers on top of that, and still they are both crashing at random when accessing the file manager to export or import or to apply textures. Anyone have any other ideas? This is becoming very frustrating. it seems like an open gl issue but the mesa files aren't correcting it for some reason and I'm not sure what else to do.

Come visit me at insimenator.net For never before seen hair, accessory and clothing meshes!
I never knew, I never knew that everything was falling through, that everyone I knew was waiting on a cue to turn and run when all I needed was the truth...
Admin of Randomness
staff: retired moderator
#89 Old 5th Mar 2007 at 5:07 AM
I just did a marathon session with 7 meshes, I used extended edit more often than the bone tool (are your results any different with that tool?) and I didn't have crashing at all. Just installed the new milkshape and new plugins. I am not sure if I'm using the mesa dlls. I am using win XP.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Lab Assistant
#90 Old 6th Mar 2007 at 3:34 AM
Quote:
Originally Posted by tiggerypum
I just did a marathon session with 7 meshes, I used extended edit more often than the bone tool (are your results any different with that tool?) and I didn't have crashing at all. Just installed the new milkshape and new plugins. I am not sure if I'm using the mesa dlls. I am using win XP.


for me it is less about what tools I am using and more a random action on the file manager, sometimes loading a texture, often when trying to save, export or import, sometimes while using the bone tool, align normals and extended edit. there is no one combination that does it.. its just a random happening with the file manager, I have since tried 1.7 9 and 1.7 8 with different settings, with and without the mesa dlls, and the results are the same, like something about the systems I am trying to use them on is configured wrong but the direct x is updated so I'm not sure what else would be the issue, both the systems I'm running it on are also running windows xp.

I'm not sure what else could be wrong.

Come visit me at insimenator.net For never before seen hair, accessory and clothing meshes!
I never knew, I never knew that everything was falling through, that everyone I knew was waiting on a cue to turn and run when all I needed was the truth...
Scholar
#91 Old 6th Mar 2007 at 2:36 PM
When I import a certain hairmesh I made, I get this error:


I need to import that hair and edit it for different ages, all assignments intact, or it will take me ages to assign everything seperately. I always do this for age conversions.

Any way to fix this, or should I just forget about it?

Thanks,

xxx Nouk
Screenshots

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Scholar
#92 Old 7th Mar 2007 at 10:17 AM
Sorry for double posting, but is the last message visible for everyone? I'm wondering because from the forum view, Kavar made the last post...

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Instructor
#93 Old 7th Mar 2007 at 11:19 AM
Nouk,Ive never had that error,but by what you say (edit it for other ages) , how do you do it?
I export my adult.gmdc as obj, then import my basemesh for teen,then rename the groups to like hairalpha55/33/etc....then when Im done with teen,i export for child as obj,and so on...a bit tedious,but thats the only way I know,lol!

DONT ASK ME FOR A REQUEST ^-^
New Policy,applies to all my meshes ^-^
Im not meshing/Simming now,details in my Policy thing
Admin of Randomness
staff: retired moderator
#94 Old 7th Mar 2007 at 3:34 PM Last edited by tiggerypum : 7th Mar 2007 at 5:13 PM.
Obj would lose all the bone assignments, and I never do it that way. I'll look Nouk to see if I can track down any tidbits about that error.

I give up for now.. Maybe someone else can find it or remember more about it. Wes hasn't been on site since he let us know he's moving, hopefully he'll be back soon, that was 2 weeks ago I think.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Instructor
#95 Old 7th Mar 2007 at 10:39 PM
But losing assignments isnt all that bad, just open up your mesh (adult,or 1st one for example)in another Milkshape and look where your assignments & weights/%s are.....its not that bad...

DONT ASK ME FOR A REQUEST ^-^
New Policy,applies to all my meshes ^-^
Im not meshing/Simming now,details in my Policy thing
Lab Assistant
#96 Old 8th Mar 2007 at 9:58 AM
Quote:
Originally Posted by Nouk
When I import a certain hairmesh I made, I get this error:


I need to import that hair and edit it for different ages, all assignments intact, or it will take me ages to assign everything seperately. I always do this for age conversions.

Any way to fix this, or should I just forget about it?

Thanks,

xxx Nouk



The importer will notify you when your mesh that you import have to many subsets (may be 7 and above, you might try by your self for the exact value), to solve the problem is by deleting some subsets in SimPE (never save, just commit and extract) and import in Milkshape step by step.

Wes,
I know you're limiting the feature for some reasons, but it is quite annoying when it is in working process... In my suggestion U prompt to import or just cancel.
Alchemist
Original Poster
#97 Old 9th Mar 2007 at 12:42 AM
Quote:
Originally Posted by cwurts00
I find this information interesting. I notice in SimPE that the flags for body flags values for fat and pregnant correspond to the MORPHMOD values in Milkshape. Do you know if there's a way to add a MORPH.4 in Milkshape to represent the fit state at body flag 4? I tried this and it didn't work.


The game does use the morph names (in the comment section) to locate the morph. The numbering is usually the same across meshes because the same people created them.

It would be possible to make a new and addtitional morph. The plugins will allow four per group (the game allows four per vertex, but I have no place to save per-vertex data). The issue as I know it would be in getting the game to change the state to your new one.

I spent some time working on this, and then got sidetracked, but the state change happens within an animation. But there may also be something else that needs done. At any rate, I have made meshes with new custom morphs, as opposed to mdoified existing ones, but have not yet made them work in game. I believe what you are trying to do is feasible, but I don't think anyone has succeeded in doing this yet.

<* Wes *>
Alchemist
Original Poster
#98 Old 9th Mar 2007 at 12:55 AM
Quote:
Originally Posted by cevic
The importer will notify you when your mesh that you import have to many subsets (may be 7 and above, you might try by your self for the exact value), to solve the problem is by deleting some subsets in SimPE (never save, just commit and extract) and import in Milkshape step by step.

Wes,
I know you're limiting the feature for some reasons, but it is quite annoying when it is in working process... In my suggestion U prompt to import or just cancel.


I'll try to answer all these comments at once.

The P1 is the basic data holding block in the mesh format. There is one for each vertex, normal, UV, bone assignment, sking weight, morphmod, etc. times the number of groups in the mesh (plus about a dozen extra).

The limit (currently 128) is mainly there because of memory usage purposes (pointer array size), and I was unaware that any game meshes actually used more than that many mesh parts. It is also possible the file is corrupt or there is a format difference I have never seen. I would like to see what is actually in this mesh, and I will make an update if needed that will handle it.

So either a name, instance or PM me for my email so I can look at the offending mesh, please.

<* Wes *>
Field Researcher
#99 Old 9th Mar 2007 at 9:44 PM
hi i'm sorry to bother lol but i'm having problems with the unimesh bone tool i was doing the tut on bodymeshing p.3 and i selected some vertices and it crashed it just thought it was a coincidence and then it crashed again i wasn't having problems before though
i think it's the same probl Kavar's having i am running XP as well

Want free quality downloads? then visit my site!!
www.toxiccharm.net
Admin of Randomness
staff: retired moderator
#100 Old 9th Mar 2007 at 10:37 PM
play_girl - did you try getting and installing the open gl stuff from milkshape's site, it has helped some folks stop crashing. (instructions for installation are in the infocenter)
Also if the unimesh bone tool crashes, but extended edit does NOT, use extended edit. It has a bone mode. Just make sure your assignments add up to 100%

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Page 4 of 14
Back to top