Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Summer Movie Night - posted on 13th Jun 2018 at 9:07 PM
Replies: 4 (Who?), Viewed: 8547 times.
Test Subject
Original Poster
#1 Old 24th Apr 2011 at 9:30 AM
Default Prelude to a Plague Quest - Second Peasant?
I've been playing the Prelude to a Plague quest, and I'm getting quite frustrated with the next step in the quest. My physician is supposed to examine the symptoms of the second ailing peasant, but I can't seem to do so. There are two peasants in my kingdom with the title of "the ailing" after their names; one, which I've already examined and cured (MULTIPLE times) hangs out around the clinic, and the other hangs out around the merchant's home. I've tried going to both and using every available option on them - diagnosing, administering cures, treating their sickness on the operating table - but NOTHING has progressed the quest any further! They're both now in completely perfect health, while the rest of my kingdom continues to be infected by the plague. I assume that one of the "ailing" peasants are who I'm supposed to be paying attention to, as I haven't seen any yellow quest markers show up to point out anybody else.

Somebody please help! This is getting to be very tedious and annoying, and I don't want to give up on this quest after I've gone so far.
Mad Poster
#2 Old 24th Apr 2011 at 6:09 PM
No help but my patient who was doomed to die in the quest was cured by my physician and in perfect health, but still died. There's some goof up in that whole "curing" business.
Test Subject
#3 Old 24th Apr 2011 at 10:49 PM
I had that problem too. I restarted the quest, I think it has a bug.
Top Secret Researcher
#4 Old 25th Apr 2011 at 2:03 AM
You need to do things in the order of the quest, just because you can cure them doesn't mean you should cure them!

I got stuck because I cured an ailing sim before the quest had told me to do so. He lost his map marker and the interactions I needed to finish the quest weren't there.

I went back to a save just before I cured him and everything worked normally when I followed the quest instructions.
Test Subject
Original Poster
#5 Old 25th Apr 2011 at 5:48 AM
Well, I think I'm going to go ahead and restart the quest. I've got my physician and merchant up to level 10 during the time that it took me to try finishing this quest, so I guess I can't say it was all for nothing. However if anyone knows a fix for it, please do tell. I'm compiling a list of problems that I've encountered and fixes for them so that I might post a bug/glitch tutorial for TSM somewhere.
Back to top