Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 MTS Calendar Contest - posted on 12th Nov 2017 at 8:48 PM
Replies: 9 (Who?), Viewed: 4575 times.
Test Subject
Original Poster
#1 Old 16th Dec 2010 at 4:03 AM
Default 2x1 glass top table - sims will not eat at table
Hi everyone. I have hit a wall with my latest project. I am working in TSRW 2.0.10 (though I am close to installing 2.0.11).

I have created a 2x1 glass top table. It was cloned on the original glass top dining table of 3x1. I have copied the footprint and slot settings from a 2x1 table and have cloned the table three times now with the same problem - they sit at the table fine, you can put decor at each place setting no problem. If they sit at the table to eat, they hold the plate. I tried placing a laptop on the table and it simply would not place. I have not checked the decorative marker for the place settings - functional, small, medium, and full rotation - just like an EA 2x1 table. Where this has been cloned a number of times now, I cannot even begin to count how many times I have checked against screen shots of the 2x1 settings.

The 2x1 table appears to be unique by comparison to the 1x1 and 3x1 tables in regards to the footprint. On those tables the values and entries match - on the 2x1 table, they are different. I mention this as my first clone I had overlooked this factor and believed that perhaps the footprint was the trouble.

I have renamed (and re-renamed) the slots and marked the bone hash with 0x00000000 a number of times believing that I had possibly overlooked one of the settings or missed a zero somewhere.

I have even cloned (though problematic) onto one of the store 2x1 tables with glass and although there was success on the placement of usable items on the table, the glass, name, and description were wonky. I know it is not advised to clone in this manner, but I wanted to see if it was something wrong with the mesh (yes, stupid, I know).

I fear I am missing something and as many times as I have gone through these files, I cannot find a field that would alter this setting. I have seen 2x1 glass top tables, so it's clearly possible. I am happy to send the workshop file to anyone who might have an inkling of what is happening.

I really appreciate any help offered. Really - after three different attempts I am at a complete loss.
Advertisement
Alchemist
#2 Old 16th Dec 2010 at 1:56 PM
Hi Baufive I don't use TSRW so I'm not sure what you mean when you say, "I have not checked the decorative marker for the place settings - functional, small, medium, and full rotation - just like an EA 2x1 table."

But when I look at an EA 2x1 dining table in s3pe, the container SlotPlacementFlags for the slotted parts that allow placement of things on the table have Functional and Decorative marked as True.

The results you're getting sound like you need to change the container's slot placement flags for the slots that allow placement of things on your table's surface.
Dancing Flamingo
staff: administrator
#3 Old 16th Dec 2010 at 3:51 PM
The 3x1 and 2x1 RLST resources are not very different, other than one has more entries to allow for more slots and more chairs. You shouldn't need to change the flags for the slots, just the locations since the place that chairs slide in are different on a 2x1 table (as are the deco locations) and then delete the extras. There are three different types of slots, one for chair, one for deco & functional and one for deco. Do the chairs snap into the table? I would guess that the chair slot placement allows this, not sure if that also controls placing the plate on the table or if that one is the deco & functional flags.

The quickest and easiest way to do this is to use s3oc/s3pe because then you only have to replace resources without editing them. Clone a 2x1 table, extract the RLST and FTPT. Clone the 3x1 table, and replace the RLST and FTPT from the 2x1 you extracted. Then import this into TSRW and finish. You should now have proper routes/slots and footprint. TSRW does allow you to choose a standard 2x1 footprint so you don't necessarily need to export that. I'm surprised they don't use standard RLST resources since all tables use the same one(for there size).
Lab Assistant
#4 Old 16th Dec 2010 at 4:20 PM
baufive,
Along with the advice others have given you, you have to make sure and use the bone names that are in the rig file
for the container slots used for eating.
Bone names are very important to the game and tell it what each slot is for, the names in the rig file are not hashed and are
abbreviations in English, so it should be easy to tell which ones are for eating, which are for decoration and which are for serving and routing.

You'll need Atavera's Rig Helper for S3PE, which can be found here ,
Remember to read the instructions at the bottom of the page, they tell you where to get the granny2.dll required by the helper.
Alchemist
#5 Old 16th Dec 2010 at 9:36 PM
If it helps, I used the EA 3x1 long Victorian glass top dining table as the clone for my one tile Bistro Tables that I posted here at MTS.

I used the method HL describes above but I also exported a one tile dining table _rig and renamed that to the name of my exported long Victorian glass top dining table _rig. If you do it that way you shouldn't need an external _rig editor to get a two top table that functions correctly.

HL decribed the process in her tutorial on changing an object's footprint which is in the tutorials section and I basically followed that tutorial for my tables. Maybe it would help you also.
Test Subject
Original Poster
#6 Old 17th Dec 2010 at 3:51 AM
Wow - lot's of answers, so thank you.

Orange Mittens - in the slots area of TSRW, there are markers for what the slot can do - decorative is one of the options and this is not activated for place settings - just the three center areas of the table, so it is confusing that the table seems to only allow for decorative items no matter what area of the table. It is odd that I can place a pillow (for instance) at all nine slots on the top of the table, but a laptop at none of them. You have mentioned that SlotPlacementFlag should be set to TRUE for functional and decorative, but my understanding of S3PE is sadly limited. Where should I be looking for this? I have looked in the RLST area and in the OBJD areas?

HugeLunatic - TSRW does have preset 2x1 footprint however a table is a curious thing and I learned this with my first 1x1 glass top table. You cannot just select a 1x1 from the drop down menu or have it calculate based on the mesh - it needs to be exactly the same as an EA table or they won't sit at the table correctly - the numbers are slightly smaller than a 1x1 or what is calculates. I believed this to be for how they pull their chair into the table, but it was only a guess. It would be helpful to be able to export the table settings and import them into a new table (within TSRW) so I will attempt the method you have suggested. I did not even know you could do that.
Also - to answer your question, the chairs do move with the table - I learned a hard lesson with a different table (the aforementioned one) and made a bit of a fool of myself on the TSR forum all at the same time by proclaiming I had followed Murano's slot tutorial 'to the letter' and realized that no, I was entering the 0x000's into the incorrect field. Since, it seems hard for me to get an answer on that forum.

Raven Shadow - thank you for that link - I will certainly follow the instructions - I will confess that S3PE has often left me scratching my head as I am a very visual person - even my RL job is pure visual.

I hope no one minds - I would like to upload this file in package format and see if anything comes across as strange or odd. I would be happy to upload the Workshop file too if someone might do better with that file. This is to be part of a salvaged items set - a door table.
I clearly need to further learn more about S3PE and S3OC as I started with them for simple clones of pictures many many months ago but abandoned them when I started mesh creation due to TSRW being visual. As I grow stronger in the area of the visual I want for the meshes I am creating, I really want to understand the inner workings of objects that are interacted with. I will be looking at the tutorials and add-on's mentioned to further my personal tutelage. Thank you all again - you have really been kind to offer assistance.
Download - please read all instructions before downloading any files!
File Type: zip baufive problem 2x1 door table.zip (342.7 KB, 10 downloads) - View custom content
Description: cranky 2x1 glass top table - allows decor at all nine slots on the table - no functional items.
Test Subject
Original Poster
#7 Old 18th Dec 2010 at 7:33 PM
I have taken what information was provided here and attempted a hybrid solution using TSRW and the S3PE plug in. I felt this would be the same result while working in the confines of a program that already is really cranky with clones. Please tell me if this is incorrect in thinking. I followed the steps on the S3PE plug in page.

I opened the file and edited the FTPT and RSLT via the plug in. Right click - edit, it opens in S3PE, I replaced the file with the already exported version from an EA 2x1 table, saved and closed which is supposed to then import that saved bit into the package file. Followed the same steps for each.

I saved, exported and converted to package and tried in game and the results were strange. The chairs would stay with the table in three slots, in the wrong location, but oddly enough - I could get the laptop to sit at a slot near to the table where I suppose a place setting was displaced.

Where the chairs would basically half move with the table (a sign that the bones were unassigned), I felt that I needed to follow the steps in Murano's Slot Tutorial - give a new name to the hash - something entirely new (SlotA and so on) and replace the bone hash info with 0x00000000. Saved again and got it back into the game and I am back at square one. Nothing functional will work on the table and sims eat at the table holding a plate.

I am taking baby steps with this to see if I can understand where it is failing. To me there is something key about it sort of working and then breaking with futzing around with the slots manually again. I had checked against my screen shots and the information that had been imported via the plug in did not change the integers in slot or footprint, but it had changed the 0's in the bone hash so something happened.

Where TSRW is really very cranky when working with Imported items, I am not sure what my next step should be with this program other than to flip it off and grab a vodka tonic. I can certainly follow the steps of replacing these two bits of data into a 3x1 table, but then when I go to work with it in TSRW, it exports a wonky file or crashes while I work with it (this statement is based on previous attempts at cloning a clone).

Currently, I see my options as follows: Change the design of the table to a 3x1 if I want to keep the glass top, simply remove the glass top from the table which would be strange looking in game due to the uneven door surface, design this entirely in S3PE following the tutorials and NOT have a Sim3pack for those who desperately cling to that format with a death rattle grip.

I am attaching the image from the first attempt where the chairs would not align properly to the table. I keep feeling like there are signs I am not versed enough to recognize and someone will see it and say 'silly boy - that means it's this'

This is sort of an aside - I don't work with sim3packs often unless it is a countertop which has historically presented a problem when attempting to CASt - could it be possible that dining tables now need to be installed at a sim3pack? It's not a format I like and they are hard to get rid of when they are installed (finding it among the store items).

Sorry, my mind jumps around a lot - I also have one other idea. Where I was able to successfully clone a clone of a store table (with glitches, but it technically worked) are there things I can copy from that file so I may clone right onto a 2x1 table - screw the 3x1. What part of the file from S3PE has the group information. Where I am attempting to keep the glass top, it's a group_* issue. I can add a group with TSRW but it ends up blurring the patterns terribly (it's just experimental at the moment). Could that possibly solve the problem?

Thanks for any assistance. I am steps closer to just abandoning TSRW for this project - I have not had so much trouble with it in the past - this could easily be user error too - I'm willing to admit that - but my past attempts were so easily corrected when I understood what I was doing wrong. This simply will not fix. If needed, I can upload the newest clone, or recreate the clone with the imported RSLT and FTPT.
Screenshots
Dancing Flamingo
staff: administrator
#8 Old 18th Dec 2010 at 8:56 PM
I'd guess the plugin for TSRW may not work well for replacing resources. I replaced the RLST, RIG and FTPT in this table with the standard one as finding an issue in the existing ones is like finding a needle in a haystack. And when all 2x1 tables use the exact same resources, it's much quicker (and saner!) to just replace with unedited ones.

Chairs snap into place and move with the table, I could place a couple of laptops in slots (the same as an EA table), and my test Sim ate 6 helpings of Grilled Cheese to test each slot (all work).

Because you can't edit packages in S3PE after being made in TSRW I had to open the file in s3pe, export all resources, create new package, then import all the resources, save.
Download - please read all instructions before downloading any files!
File Type: rar FIXED_baufive_surfaces_salvage_door_dining_table.rar (334.2 KB, 9 downloads) - View custom content
Alchemist
#9 Old 18th Dec 2010 at 10:11 PM Last edited by orangemittens : 18th Dec 2010 at 10:31 PM.
When looking at your original table and HL's fixed one in S3PE the big difference between them is that hers has the 2x1 dining table _rig while yours has the 3x1 dining table _rig.

I tested this on a 3x1 table with a 2x1 mesh, RSLT, and FTPT but keeping the 3x1 _rig and got the same result as you show above:



You should be able to fix your issue by just importing a 2x1 rig into the object. Hopefully that means you don't have to start all over.

ETA: HL, I notice that your fixed table doesn't have the VPXY bounding box values changed. Is this something that is fixed in TSRW after the resources are imported into the project or is it just unnecessary to change them?
Test Subject
Original Poster
#10 Old 18th Dec 2010 at 11:12 PM
OrangeMittens - thank you for emailing me about the new test plug-in . Between you and HugeLunatic pointing out the key parts of the file and this new test version of the plug in, I was able to accomplish this with both programs. The version I was working with this morning would not allow for me to import the RIG file - this test version allows you to edit any resource from the file. I have successfully altered these files and the table works just fine now without confusing myself further in S3PE.

That said it is even more clear to me now that I need to learn more about these other programs. I had started working with them for pictures but gave up when I started to attempt meshing. You have both given me a way of making necessary and rapid changes to TSRW files. I still have no idea what was happening with the file that was being generated by TSRW earlier. Everything matched that I could see, but clearly something was amiss. This is not the first mystery that I have encountered with the program.

HugeLunatic - now I want a grilled cheese!

Thank you both so very much - I will give credit when this set is finally released!
Screenshots
Back to top