Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Theme Seasons and Celebrations - posted on 1st Oct 2017 at 1:52 PM
Replies: 146 (Who?), Viewed: 174083 times.
Page 6 of 6
Test Subject
#126 Old 5th Jan 2014 at 11:01 PM
Ellacharmed,
Well that was a dum-dum move on my part, I could have sworn I had s3pe_11-1216-1651 (maybe I went back and grabbed a different version to test it) so I re-downloaded the correct version and removed the ".7z" from the folder name. I also double checked the contents before running again this time and I see that everything is unzipped (only .txt, .helper, .exe, .dll, or .htm files and folders).

And now I'm back to the error message that mswestx33 and I were getting before:

uws26701usr:~ ladysilver814$ mono /Users/ladysilver814/Desktop/Games/SU3/s3pe_11-1216-1651/s3pe.exe
Missing method .ctor in assembly /Users/ladysilver814/Desktop/Games/SU3/s3pe_11-1216-1651/s3pi.CustomForms.dll, type System.ArgumentLengthException

Unhandled Exception:
System.TypeInitializationException: An exception was thrown by the type initializer for AutoUpdate.Checker ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.Custom, Version=1112.3.1951.35756, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'System.Custom, Version=1112.3.1951.35756, Culture=neutral, PublicKeyToken=null'
at (wrapper remoting-invoke-with-check) System.Windows.Forms.CopyableMessageBoxInternal:.ctor (string,string,System.Windows.Forms.CopyableMessageBoxIcon,System.Collections.Generic.IList`1<string>,int,int)
at System.Windows.Forms.CopyableMessageBox.Show (IWin32Window owner, System.String message, System.String caption, CopyableMessageBoxIcon icon, IList`1 buttons, Int32 defBtn, Int32 cncBtn) [0x00000] in <filename unknown>:0
at System.Windows.Forms.CopyableMessageBox.Show (System.String message, System.String caption, CopyableMessageBoxIcon icon, IList`1 buttons, Int32 defBtn, Int32 cncBtn) [0x00000] in <filename unknown>:0
at System.Windows.Forms.CopyableMessageBox.Show (System.String message, System.String caption, CopyableMessageBoxButtons buttons, CopyableMessageBoxIcon icon, Int32 defBtn, Int32 cncBtn) [0x00000] in <filename unknown>:0
at AutoUpdate.Checker..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at S3PIDemoFE.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for AutoUpdate.Checker ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.Custom, Version=1112.3.1951.35756, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'System.Custom, Version=1112.3.1951.35756, Culture=neutral, PublicKeyToken=null'
at (wrapper remoting-invoke-with-check) System.Windows.Forms.CopyableMessageBoxInternal:.ctor (string,string,System.Windows.Forms.CopyableMessageBoxIcon,System.Collections.Generic.IList`1<string>,int,int)
at System.Windows.Forms.CopyableMessageBox.Show (IWin32Window owner, System.String message, System.String caption, CopyableMessageBoxIcon icon, IList`1 buttons, Int32 defBtn, Int32 cncBtn) [0x00000] in <filename unknown>:0
at System.Windows.Forms.CopyableMessageBox.Show (System.String message, System.String caption, CopyableMessageBoxIcon icon, IList`1 buttons, Int32 defBtn, Int32 cncBtn) [0x00000] in <filename unknown>:0
at System.Windows.Forms.CopyableMessageBox.Show (System.String message, System.String caption, CopyableMessageBoxButtons buttons, CopyableMessageBoxIcon icon, Int32 defBtn, Int32 cncBtn) [0x00000] in <filename unknown>:0
at AutoUpdate.Checker..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at S3PIDemoFE.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0

So I can't even get to the Updater dialog box (not that I could before either) and yes the game can run - I've actually tried both when the game was open and running and shortly after I've closed it with the same results. I guess I'm back to problem square number 1. :-/

Is there anyway to update the code or something before launching the program to tell it to disable auto update? (Since in looking at those error messages it seems that the first problem it encounters is the auto update checker...)
In the Arena
staff: retired moderator
#127 Old 7th Jan 2014 at 6:20 AM
The autoupdate dialog is clickable in the Dock. After you press Enter/Return in Terminal, there should be a new icon showing up on the Dock. But the focus is not brought to that Dialog window for some reason in OSX. I usually have to click the icon manually myself, to bring the window to the forefront.

If there's no new icon, then read on...
It took a while and lots of digging, but I think I found the path.

In my windows system, I have a file called s3pe.user.config in the %appdata%\Roaming\Peter L Jones\sims3tools\ path, that controls the program's preferences and settings.
In OSX system, I found it in ~/.local/share/Peter L Jones/s3pe.exe_Url_<somestring> (.local is a hidden folder). The full path string is listed as
Code:
/Users/<username>/.local/share/Peter L Jones/s3pe.exe_Url_24e6e98035d807d44b298d49974f2fee495d1749}


So, what you need to do is open up this file in TextEdit, look for the following snippet and change the <value> field to "2". Auto update is set to "1", so to disable is a "2".
Quote:
<setting name="AutoChoice" serializeAs="String">
<value>2</value>
</setting>


Please let me know if this helps in getting you past that error, and I'll do a proper post for a How-To.
Test Subject
#128 Old 10th Jan 2014 at 6:23 PM Last edited by ladysilver814 : 11th Jan 2014 at 3:47 AM. Reason: removing unnecessary quote
Well, as it turns out that value field is already 2 in my user.config files. I changed it to 1, ran it (got the exact same error), re-changed it back to 2, and ran it - but I'm still getting the same error as before. Is there anyway we can tell the program to just skip that part of the coding that calls up the AutoUpdate all together (the more I look at this error type the more I think it's something about the program attempting to start AutoUpdate at all that's throwing the exception - maybe I'm finally starting to understand terminal)?
In the Arena
staff: retired moderator
#129 Old 13th Jan 2014 at 4:37 PM
If the AutoUpdate is not the root cause to the issue...
Quote:
Missing method .ctor in assembly /Users/ladysilver814/Desktop/Games/SU3/s3pe_11-1216-1651/s3pi.CustomForms.dll, type System.ArgumentLengthException

Quote:
Could not load file or assembly 'System.Custom

Those 2 lines points it right back to the folder's contents and what the exception is caused by. Do you have the "s3pi.CustomForms.dll" and "System.Custom.dll" files in the extracted S3PE folder? The s3pi.CustomForms.dll file has a line that is looking for something, and when it cannot find it, it throws out that Exception.

How many files are there?
File Info tells me there are 75 items in mine; 55 files (with 1 hidden) and 2 subfolders.
Test Subject
#130 Old 14th Jan 2014 at 4:48 PM Last edited by ladysilver814 : 14th Jan 2014 at 5:05 PM. Reason: Updating information in post
I don't have System.Custom.dll - I have System.Custom.xml and s3pi.CustomForms.dll.

Looking at the folder contents I wonder what else I'm missing: only 46 items in the main level with 2 subfolder with 11 (Helpers) and 10 (HelpFiles) items each. I wonder if my expander program is botching something and just ignoring some of the files. I'm going to test download it again and see if a different expander program will help me get out the missing files...

Yep, I re-downloaded and then use Unarchiver to expand the file. I end up with 56 files (no hidden items, I wonder why I don't have any hidden files) in the main folder level including the two subfolders with 11 (Helpers) and 10 (HelpFiles) items in each. When I run this newly expanded file - I am finally able to get into S3PE!

Thank you Ellacharmed for helping me muddle through this!

You may want to put a suggestion on the first post that if the program won't run that we should be checking our expanded file to make sure it has all the correct files in it (or at least that we're not missing any). If it is short on files hopefully it's just an expander program error and we should try and extract it with another program. So it appears that mswestx33 and I were using two different programs that couldn't extract all the files (since we were getting the same error messages) this suggests that Stuffit Expander and rar Extractor are both programs that can't deal with the extraction process correctly.
In the Arena
staff: retired moderator
#131 Old 17th Jan 2014 at 1:10 PM
Our wiki link to Archive tools have always been to Keka, since that was what came up when I searched for "7z os x". Perhaps the other archivers were not coded to handle that new extension properly.

I'll go and edit that first post...thanks for the find! Sure was puzzling why some encountered it and not others. So now we know!
Test Subject
#132 Old 25th May 2014 at 3:46 AM
Hi i cant seem to be able to be able to open the S3PE do you know any reason why?
Lab Assistant
#133 Old 22nd Jun 2014 at 12:03 PM
I'm back!

Learned something a bit useful while installing texture reduction packs in KSP. You know how on Windows you can do "replace all" and it will merge two folders? You know how Mac OS X doesn't have that? Doesn't that suck?

Turns out, there's a unix command that will do the same thing:

ditto src_directory dst_directory
Where src_directory is the folder you are copying from and dst_directory is the folder you are copying into.

The quickest way to use this command is by opening terminal, typing "ditto " (note the space), then drag the source folder from the finder into terminal, press the space bar, drag in the destination folder and then press enter.

I can't think of anything specific that this is useful for in TS3, but it's good to know it exists.


Quote:
Originally Posted by diana944846
Hi i cant seem to be able to be able to open the S3PE do you know any reason why?

More information is required. How are you opening s3pe? What version of Mac OS are you using? Are you using mono? Xquartz? What versions of those? Are you emulating? If so, what are you using and what version of Windows?

Or are you just having problems with regularly opening S3PE on Windows?

I like pie...
Test Subject
#134 Old 5th Sep 2014 at 8:14 PM
This is probably a stupid question, but how can I bulk select resources to import within S3PE on a Mac? I'm using mono, but S3PE doesn't seem to recognize the command key, and of course control-A doesn't work. Clicking and dragging DOES work, partially, but it gets old really fast when I'm trying to import 500+ resources. (I'm using ella's fixes for Sims 3 University.)
Test Subject
#135 Old 11th Nov 2014 at 10:55 PM Last edited by cKayD19 : 13th Nov 2014 at 3:14 AM.
So I dowloaded Delphy's Sims 3 Pack extractor last year (whichever version was the most current then) and Mono for Macs, and I was able to use the extractor perfectly fine. I recently updated my Mac to the new Yosemite update, and now for whatever reason it isn't working. I try to load it up and it just says application not responding and won't open. So I went and downloaded the newest Mono for Mac, which is I think version 3.10.0, and I tried using that to open up the Sims 3 Pack Extractor, so I can convert my .sims3pack files to .package files (I prefer having them in an easily accessed mod folder, rather than loading them up via the launcher and having to remove all my content and uninstall my games every time a bad piece of CC finds it's way into my collection). But so far the same thing has happened. It isn't working, it just says application not responding when I hover over the app in my dock and it won't open the extractor. I made sure to type "mono" into the terminal, hit space, drag the extractor into it, delete the extra space at the end, and press enter. Usually that works, but it doesn't. Any suggestions?

Update: I'm now also getting this incredibly long error message when I try to run S3PE.

System.EntryPointNotFoundException: GdipCreateFromContext_macosx
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdipCreateFromContext_macosx (intptr,int,int,intptr&)
at System.Drawing.Graphics.FromHwnd (IntPtr hwnd) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.CreateGraphics () [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.CreateGraphicsInternal () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.TextBoxBase:CreateGraphicsInternal ()
at System.Windows.Forms.Document.owner_HandleCreated (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnHandleCreated (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.OnHandleCreated (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBox.OnHandleCreated (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmCreate (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBox.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0
System.EntryPointNotFoundException: GdipCreateFromContext_macosx
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdipCreateFromContext_macosx (intptr,int,int,intptr&)
at System.Drawing.Graphics.FromHwnd (IntPtr hwnd) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.CreateGraphics () [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.CreateGraphicsInternal () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.TextBoxBase:CreateGraphicsInternal ()
at System.Windows.Forms.Document.owner_HandleCreated (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnHandleCreated (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.OnHandleCreated (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBox.OnHandleCreated (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmCreate (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBox.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0
System.EntryPointNotFoundException: GdipCreateFromContext_macosx
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdipCreateFromContext_macosx (intptr,int,int,intptr&)
at System.Drawing.Graphics.FromHwnd (IntPtr hwnd) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.CreateGraphics () [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextBoxBase.CreateGraphicsInternal () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.TextBoxBase:CreateGraphicsInternal ()
at System.Windows.Forms.Document.owner_VisibleChanged (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnParentVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnParentVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ScrollableControl.OnVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Form.OnVisibleChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmShowWindow (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ContainerControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Form.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0
Test Subject
#136 Old 11th Dec 2014 at 4:20 PM
Quote:
Originally Posted by cKayD19
So I dowloaded Delphy's Sims 3 Pack extractor last year (whichever version was the most current then) and Mono for Macs, and I was able to use the extractor perfectly fine. I recently updated my Mac to the new Yosemite update, and now for whatever reason it isn't working. I try to load it up and it just says application not responding and won't open. So I went and downloaded the newest Mono for Mac, which is I think version 3.10.0, and I tried using that to open up the Sims 3 Pack Extractor, so I can convert my .sims3pack files to .package files (I prefer having them in an easily accessed mod folder, rather than loading them up via the launcher and having to remove all my content and uninstall my games every time a bad piece of CC finds it's way into my collection). But so far the same thing has happened. It isn't working, it just says application not responding when I hover over the app in my dock and it won't open the extractor. I made sure to type "mono" into the terminal, hit space, drag the extractor into it, delete the extra space at the end, and press enter. Usually that works, but it doesn't. Any suggestions?

Update: I'm now also getting this incredibly long error message when I try to run S3PE.


Yes, I seem to be having the same problem, also after upgrading to Yosemite. S3PE, CTU, Delphy's Dash, worked fine before. Anyone have any ideas?
Test Subject
#137 Old 1st Jan 2015 at 1:03 AM
Quote:
Originally Posted by ladysilver814
If it is short on files hopefully it's just an expander program error and we should try and extract it with another program. So it appears that mswestx33 and I were using two different programs that couldn't extract all the files (since we were getting the same error messages) this suggests that Stuffit Expander and rar Extractor are both programs that can't deal with the extraction process correctly.

One year later and im finally using S3PE! Thanks for all the help ellacharmed & ladysilver814 you guys rock!
Lab Assistant
#138 Old 15th Jan 2015 at 7:01 PM Last edited by robotguy4 : 15th Jan 2015 at 8:45 PM.
I know I'm a bit late to the party, but...

Apparently Wineskin has an option in Winetricks to install everything for TS3.

I'm going to try to offset my tardiness by jumping the gun: are we going to continue this thread for TS4 or make a new one?

I like pie...
Field Researcher
#139 Old 11th Feb 2015 at 7:06 PM Last edited by pepoluan : 11th Feb 2015 at 7:26 PM.
Hello Mac users!

I'm (re-)creating the functionality of the WHOLE s3pi library in Pure Python. My hope is that, since this is Pure Python (2.7, to be precise), the library would be cross-platform... as long as Python 2.7 exists on your platform. It's neither ABI- nor API- compatible with s3pi., though. But it should have identical functionality/feature.

Now, since I don't have access to a Mac PC, only to Windows and Linux PCs, I can't really vouch if this library (and the toolkit I'm building with the library) will actually run on Mac.

So, I need your help in answering the following questions:
  1. Do Macs have Python 2.7 out of the box?
  2. If not, can you easily install Python 2.7 on Macs?
  3. I'm not good at GUI design; do you mind using text-based tools?

Note 1: The library is currently in pre-Alpha stage; (1) I'm still ironing out the 'fatal' bugs, and (2) The resource parsers/writers are still far from complete. But I'm open to volunteers to help fix the library and/or make it complete.

Note 2: Although the tools are currently text-based only (i.e., you have to run it via Terminal -- or whatever it is called on Macs), I strive to separate the logic and the presentation, so that better Mac programmers can just 'wrap' a GUI around the core logic.

Note 3: Finally, do remember that this is pre-Alpha. Not even Beta. Interfaces & implementations are still 'floating around', so to speak. So, if you're developing something relying on this library, please don't be mad if a newer version b0rks your code...

-----

The 'official thread' for the library I'm talking about: sims3py -- a Pure Python library for manipulation of DBPF files


.

Nobody is Perfect. I am Nobody. And I'm trying to make something wonderful for The Sims 3.
Lab Assistant
#140 Old 30th Mar 2015 at 4:37 AM
Quote:
Originally Posted by pepoluan
Hello Mac users!
So, I need your help in answering the following questions:
  1. Do Macs have Python 2.7 out of the box?
  2. If not, can you easily install Python 2.7 on Macs?
  3. I'm not good at GUI design; do you mind using text-based tools?
.

I know you can install Python 2.7 on Mac OS X (modern Macs). Mac OS X 10.8 comes with Python 2.7 pre-installed by Apple.

More info found here:
https://docs.python.org/2/using/mac.html

Reminder: Mac OS X is UNIX. Almost anything you can do on a pure UNIX machine, you can do on a Mac. The small fraction that is different can usually be worked around by spending several hours reading Stack Overflow.

Text based tools are probably not ideal for most users, but it's better than nothing. If anything, someone may make a GUI using your text based tools.

I like pie...
Test Subject
#141 Old 25th May 2015 at 7:17 PM
This is probably long shot but here are my data:
Mac OSX ver. 10.6.8 snow leopard
Mono ver. 4.0.1
X11 the one that came pro-loaded: 2.3.6 S3PE ver. 14-0222-1852

I read almost every thread on this topic and tried to open up S3PE but I keep getting this error message


I'm aware that I'm using the latest version of Mono and my X11 is the old one that came with my computer; should I update to Xquartz? If anybody could help me with this it would greatly appreciated

"Don't worry Ma'am, I am a professional. Underneath this pillow lies the key to my release."- Sherlock Holmes
Test Subject
#142 Old 9th Jun 2015 at 2:43 AM
I need help with adding the S3OC on my computer i have a mac book Air i got S3PE to work but now i need the S3OC to work. i have the newest updates and everything what is wrong??? this is the code i get from terminal.... WARNING: The runtime version supported by this application is unavailable.
Using default runtime: v4.0.30319

how do i get the runtime of my mac higher? it opens then crashes, tried both .net version and the one linked in your guide both aren't working.
Test Subject
#143 Old 12th Jun 2015 at 7:04 AM
Where are the files needed for S3OC on mac to be able to clone it!?
Test Subject
#144 Old 13th May 2016 at 9:47 PM
Default Went from "Old way to new way" and now Old way doesn't work
I've done everything. I went from old to new and the new way crashes the game once it gets to the first loading screen. I would get "Exception Was Raised". So, I went back to the "old way" and found that this method no longer works when it worked just fine before. Now, you guys (modthesims) sort of screwed me over. AND I can't find the .dll file I'm suppose to delete in Games>Bin. It's nowhere in site. I checked everywhere in the Bin section. I need some serious help here. I'm pulling out my hair trying to get it to work like it had before.
Top Secret Researcher
#145 Old 14th May 2016 at 12:15 AM
Quote:
Originally Posted by sixstringbrad
I've done everything. I went from old to new and the new way crashes the game once it gets to the first loading screen. I would get "Exception Was Raised". So, I went back to the "old way" and found that this method no longer works when it worked just fine before. Now, you guys (modthesims) sort of screwed me over. AND I can't find the .dll file I'm suppose to delete in Games>Bin. It's nowhere in site. I checked everywhere in the Bin section. I need some serious help here. I'm pulling out my hair trying to get it to work like it had before.

Regardless of which "way" you intend to stay on, wouldn't the answer at this point be to uninstall and reinstall at least the base game?

I wouldn't recommend the old way though. Package based CC might be okay that way, but core mods and very many script mods developed in the past few years are not going to be happy. We know that several NRaas mods of recent vintage won't work in there, most notably MasterController.
Test Subject
#146 Old 14th May 2016 at 6:45 AM
Quote:
Originally Posted by igazor
Regardless of which "way" you intend to stay on, wouldn't the answer at this point be to uninstall and reinstall at least the base game?

I wouldn't recommend the old way though. Package based CC might be okay that way, but core mods and very many script mods developed in the past few years are not going to be happy. We know that several NRaas mods of recent vintage won't work in there, most notably MasterController.


Btw, I'm using a mac. (I can hear the sighs from here lol) I agree that reinstalling is my only option at this point but shoot... This sucks! lol I really don't want to go through the hassle of fixing the "exception raised" debugging error...but I guess I'll reinstall and test it out the new way first.

Any tips on how to fix the Sims 3 "exception has been raised" indication on macs? Links to info?
Top Secret Researcher
#147 Old 14th May 2016 at 7:04 AM
Quote:
Originally Posted by sixstringbrad
Btw, I'm using a mac. (I can hear the sighs from here lol) I agree that reinstalling is my only option at this point but shoot... This sucks! lol I really don't want to go through the hassle of fixing the "exception raised" debugging error...but I guess I'll reinstall and test it out the new way first.

Any tips on how to fix the Sims 3 "exception has been raised" indication on macs? Links to info?

No sighs here. I figured you were on a Mac, why else would you have posted to this thread (never mind, rhetorical question).

Once the game's launch process gets underway and by the time it starts reading content and mod files, it doesn't matter if you are on a Mac or PC. The game is the same, and for all of the borked up things EA did with its Cider implementation into OS X, it really is being tricked into thinking it's running on Windows and undergoes the same basic routines. Except for that nasty 2 GB RAM usage limit, but that's probably not an issue here. Probably.

The raised exception, would you like to debug jazz is just a fancy way of the program reporting that it has crashed. You probably already know that by the time you see that, it doesn't matter how you answer the question, a crashed program is still just that. There isn't any magical solution I'm afraid except gaining a better understanding, if possible, as to why it crashed. If this wasn't happening before, I would say it's really unhappy with your Package Framework and/or something is missing from deep within the base game's files in Applications > blah blah > Transgaming, but you already suspected that and hopefully an uninstall/reinstall can put it right again.
Page 6 of 6
Back to top