Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Movie Night #3 - posted on 20th Oct 2017 at 10:54 PM
Replies: 5 (Who?), Viewed: 15372 times.
Test Subject
Original Poster
#1 Old 7th Sep 2013 at 10:27 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Supernatural, Seasons
Default Screen is too dark while in fullscreen mode?
Hello, I just started having an annoying issue with my game. When I run the game in fullscreen mode, the game looks significantly darker than it should be. If I run it in windowed mode, the brightness is correct, but I can't stand running it windowed. If you take a screenshot while playing fullscreen, the game looks totally fine, which makes me think the game is displaying improperly or something. I've tried updating my drivers, updating the game to the latest patch (1.57), running it in compatibility mode, running as admin, taking out my cc and mods, nothing works.

I did recently upgrade my graphics card from an integrated one to a Radeon HD 7850, but the game's brightness was fine after upgrading up until about last week. The last time I remember playing and it being normal is August 30th, but I haven't done anything to my computer between then and now. Googling the problem led to a lot of people reporting the same problem, but only after tabbing out of the game. Mine does it immediately from launching it. A solution they suggested was upping the game's refresh rate and then cancelling the change after it switches, but this didn't help me.

Here are some comparison pictures:

Fullscreen:


Windowed:


Any help would be greatly appreciated!
Advertisement
Scholar
#2 Old 8th Sep 2013 at 5:32 PM
Have you tried opening task manager and terminating a process named igfxpers.exe? Just make sure it's your username the process runs under, not system or something else.

(I'm not entirely sure how this method works on dedicated graphics, but you could give it a try. The worst case scenario is that you have one process less. )

Felicity Island! :D
"When people put their mind to things, when people are inspired, when people are motivated; anything is possible. I saw a naked woman riding a giant telephone." -nicepeter
Test Subject
Original Poster
#3 Old 8th Sep 2013 at 6:32 PM
I knew I was forgetting something in my first post; that was the other fix people suggested. I've scoured task manager and I don't have that process. : /

I'm running on Windows 8, if that helps at all.
Test Subject
Original Poster
#4 Old 8th Sep 2013 at 7:02 PM
Hey, I fixed it! I was looking on the TS3 forums and in the problems with Windows 8 thread, someone said that they had the same issue when running TS3 in compatibility mode. Strangely enough, turning off compatibility mode makes it the correct brightness! Woo! I guess that means its a Windows 8 problem.

Thanks for replying, though! : )
Test Subject
DELETED POST
2nd Dec 2014 at 1:45 AM
Hi
This message has been deleted by Buzzler. Reason: useless post
Lab Assistant
DELETED POST
2nd Dec 2014 at 4:25 AM
This message has been deleted by Buzzler. Reason: reply to deleted post
Test Subject
#5 Old 31st Dec 2014 at 6:12 AM
Quote:
Originally Posted by kbaseballboy765
Hey, I fixed it! I was looking on the TS3 forums and in the problems with Windows 8 thread, someone said that they had the same issue when running TS3 in compatibility mode. Strangely enough, turning off compatibility mode makes it the correct brightness! Woo! I guess that means its a Windows 8 problem.

Thanks for replying, though! : )


Gah! That figures. I was having huge issues with the game lagging before, and it loaded much faster, when I made it compatible with W8. But it loaded dark. -.-' So my options are slow and clear, or fast and dark... *sigh* Slow and clear, it is.

I'm glad you knew the answer, though. You've saved me several frustrated weeks of cursing/intermittent searching.
Test Subject
#6 Old 17th Sep 2016 at 10:57 AM
Quote:
Originally Posted by kbaseballboy765
Hello, I just started having an annoying issue with my game. When I run the game in fullscreen mode, the game looks significantly darker than it should be. If I run it in windowed mode, the brightness is correct, but I can't stand running it windowed. If you take a screenshot while playing fullscreen, the game looks totally fine, which makes me think the game is displaying improperly or something. I've tried updating my drivers, updating the game to the latest patch (1.57), running it in compatibility mode, running as admin, taking out my cc and mods, nothing works.

I did recently upgrade my graphics card from an integrated one to a Radeon HD 7850, but the game's brightness was fine after upgrading up until about last week. The last time I remember playing and it being normal is August 30th, but I haven't done anything to my computer between then and now. Googling the problem led to a lot of people reporting the same problem, but only after tabbing out of the game. Mine does it immediately from launching it. A solution they suggested was upping the game's refresh rate and then cancelling the change after it switches, but this didn't help me.

Here are some comparison pictures:

Fullscreen:


Windowed:


Any help would be greatly appreciated!


Hey there, I know i'm like 3 years late but I did find a solution. Well Technically it's not much of a long term solution but it works for me every time like a charm :P
Actually I happen to have two solutions:
1) If you have NVIDIA Graphics card then I suggest you download the GeForceExperience program. Run the program after you open it and it'll automatically acknowledge the games in your PC. After that click on the sims 3 You'll need to Optimize your game before running it.



After you optimize it, fire up your game and if the problem still persists then try my other solution. Bare with me this is very easy I promise. The only bad thing is that you'll need to do it every time you fire up the game

In the sims 3 while your game is running
1) click on the options menu and click options
2) Make sure you are on the Screen options tab
3) Change your screen refresh rate and voila





If you have any questions feel free to message me and I'll be happy to help
Happy Simsing <3
Back to top