Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 7 (Who?), Viewed: 2287 times.
Guest
Original Poster
#1 Old 1st Dec 2005 at 3:35 AM
Default how can fix " cannot locate the CD-ROM,...
please can anyone help...i've installed sims2 however when trying to launch the game i get a message saying "cannot locate the CD-ROM, please insert the correct CD-ROM, select OK and restart application" and im sure it's the correct one, i even tried the rest but none works. i dont know much about computers.. any help?

thank you!!!!!!!!!!!!
Advertisement
Lab Assistant
#2 Old 1st Dec 2005 at 4:57 AM
this may help but it could slow down the computer.

I also had this happen to me but it was uni when it decided to say please insert disk and try again. here is how I fixed it. I found that it makes the computer run a little slow but I can play the sims 2.

try this, we've posted it before and it has helped others. You have an nvidia, just maybe it will help. It worked for us. This was on another site for another of maxis's games that has the same safedisc thing. Also for XP users, such as us.
Windows® 2000 users:
There is a known incompatibility with Macrovision™'s SafeDisc® (the copy protection mechanism Call of Duty™ employs) and motherboards with the nForce™2 chipset under Windows® 2000. To remedy the situation, do the following:
1) Locate the "My Computer" icon on your computer and right-click it.
2) Choose the "Manage" option.
3) Once the Computer Management program launches, select "Device Manager."
4) In the Device Manager, double-click "IDE ATA/ATAPI Controllers."
5) Right-click on "nVidia nForce 2(TM) SPP/IGP ATA Controller" and select "Properties."
6) Click on the "Secondary Channel" tab. If the Select Transfer Mode is set to "BIOS Default," click on the pull-down menu and select "PIO Mode."
7) Close all open windows and restart your machine when prompted

I hope it helps.
Guest
Original Poster
#3 Old 1st Dec 2005 at 6:46 AM
but i was using windows me, and how ???
Lab Assistant
#4 Old 1st Dec 2005 at 8:02 AM
I am not using windows me either I am using windows XP and a I nvidia motherboard, need to do this for my game to work. Follow the instructions on the screen or print them out so u can read it.
Guest
Original Poster
#5 Old 1st Dec 2005 at 9:18 AM
yes i know, but different windows system,
on my windows me have cannot find what you say
4) In the Device Manager, double-click "IDE ATA/ATAPI Controllers."
5) Right-click on "nVidia nForce 2(TM) SPP/IGP ATA Controller" and select "Properties."
6) Click on the "Secondary Channel" tab. If the Select Transfer Mode is set to "BIOS Default," click on the pull-down menu and select "PIO Mode."
Guest
Original Poster
#6 Old 1st Dec 2005 at 9:23 AM
where i can find the PIO Mode on windows me?
windows xp and me the setting is different,
Lab Assistant
#7 Old 1st Dec 2005 at 10:41 AM Last edited by meek_monkey : 1st Dec 2005 at 11:05 AM.
opps I will se if I can Find some info

Method 9: Change DMA transfer mode to PIO mode (Windows XP)
1. In Windows XP, click Start, and then click Control Panel.
2. Double-click System, click the Hardware tab, and then click Device Manager.

If you do not see System, click Switch to Classic View in the left pane.
3. Double-click IDE ATA/ATAPI controllers, double-click Secondary IDE Channel, and then click the Advanced Settings tab.

Note If you do not see the Advanced Settings tab, your computer probably has a small computer system interface (SCSI) drive. DMA transfer mode options are not available for SCSI drives.
4. Under Device 0, select PIO only in the Transfer Mode box. If you have more than one CD or DVD drive, also select PIO only in the Transfer Mode box under Device 1.

Note If Current Transfer Mode under Device 0 or under Device 1 states Not Applicable, that device is not in use. Change only the Devices that no do not state Not Applicable. If both devices state Not Applicable, your CD or DVD drive is on the Primary IDE Channel.
5. Double-click Primary IDE Channel.
6. On the Advanced Settings tab, under Device 1, select DMA if available in the Transfer Mode box.

Note that Device 0 is most likely your hard disk drive and should not be changed.
7. Click OK.
8. Restart the computer.


Try it this way I cant find any info on windows me though I think this will take u a different way. Make sure u locate this controler IDE ATA/ATAPI controllers. I am not sure but I think u can get there.

I hope u have a controller for ur cd drives and the hd drives the controller we are looking for controls your cd drives and hard drives.
Scholar
#8 Old 3rd Dec 2005 at 4:56 AM
I get this problem once in a while. I generally end up reinstalling my cd-rom driver. Might check and see if there is an updated driver for it. Some cd-roms are slower and have problems reading the disc causing this message sometimes. Good luck!

Teresa
Back to top

Section jump