Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 11 (Who?), Viewed: 2217 times.
Test Subject
Original Poster
#1 Old 28th Jan 2006 at 9:41 PM

This user has the following games installed:

Original, University, Nightlife, Open for Business
Default Please ensure the sims 2 nightlife disk is in drive and try again.. message
I cannot get the drive to read that theres a disk in there well the sims 2 disk the other ones work and the sims 2 nl worked fine last night but all day iv'e been getting the message Please ensure the sims 2 nightlife disk is in the drive click ok and restart the application..
PLEAAAAAAAASEEEEE HELP!!!!!!!!!!!!!!!!!!!!! ASAP
---Matt
Advertisement
Object(ive) Investigator
staff: retired moderator
#2 Old 28th Jan 2006 at 9:48 PM
Is it disc 1? Try booting up with it already in the drive.

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
Original Poster
#3 Old 28th Jan 2006 at 9:51 PM
Yeah it's disk one.. I'll try that and post if it works or not

This could be the start of somethin new, it feels so right to be here with you...
~~~Matt~~~
Test Subject
Original Poster
#4 Old 29th Jan 2006 at 1:11 AM
Nope i tried it still wont work and idk what to do!!!!
My downloads also wont show up in game.

This could be the start of somethin new, it feels so right to be here with you...
~~~Matt~~~
A missing part of me that grows around me like a cage
staff: retired moderator
#5 Old 29th Jan 2006 at 2:04 AM
Try cleaning your disc- if this doesn't work, you should be able to exchange it through the official EA site.
http://www.modthesims2.com/showthread.php?t=82492
For your downloads, read this:
http://www.modthesims2.com/showthread.php?t=52706

I will choose a path that's clear- I will choose free will
RUSH
Test Subject
Original Poster
#6 Old 29th Jan 2006 at 2:32 AM
i tried cleaning it but i just dont know what else to do, any more ideas?

This could be the start of somethin new, it feels so right to be here with you...
~~~Matt~~~
A missing part of me that grows around me like a cage
staff: retired moderator
#7 Old 29th Jan 2006 at 3:31 AM
If all of your other discs can be read by the cd drive except for that one, then it means that the disc is damaged. You'll have to exchange it through the official site.
http://support.ea.com/cgi-bin/ea.cf...ated=1118428053

I will choose a path that's clear- I will choose free will
RUSH
Test Subject
Original Poster
#8 Old 29th Jan 2006 at 4:05 PM
i found another game i had and tried it now that wont work either,,
rrggghh...

This could be the start of somethin new, it feels so right to be here with you...
~~~Matt~~~
Object(ive) Investigator
staff: retired moderator
#9 Old 29th Jan 2006 at 5:58 PM
Try getting new drivers for your cd drive.

Please don't PM me with questions. Post them in the appropriate thread.
Instructor
#10 Old 12th Feb 2006 at 2:57 AM
i have this problem too. where would i get the Drivers? Ive gone on the computers website (acer) and cant find anything. Also, i got NO information about my computer hardware with it

DONT ASK ME FOR A REQUEST ^-^
New Policy,applies to all my meshes ^-^
Im not meshing/Simming now,details in my Policy thing
Object(ive) Investigator
staff: retired moderator
#11 Old 12th Feb 2006 at 3:59 AM
Right-click on My Computer and click properties. Click on the Hardware tab and then the Device Manager button. Find your cd drive, right click on it and click properties. Click the Dirver tab and then Update Driver.... Follow the onscreen instructions from there.

Please don't PM me with questions. Post them in the appropriate thread.
Lab Assistant
#12 Old 12th Feb 2006 at 9:31 AM
If all else fails trry this it may help or it may not.

try this, we've posted it before and it has helped others. You have an nvidia, just maybe it will help. It worked for us. This was on another site for another of maxis's games that has the same safedisc thing. Also for XP users, such as us.
Windows® 2000 users:
There is a known incompatibility with Macrovision™'s SafeDisc® (the copy protection mechanism Call of Duty™ employs) and motherboards with the nForce™2 chipset under Windows® 2000. To remedy the situation, do the following:
1) Locate the "My Computer" icon on your computer and right-click it.
2) Choose the "Manage" option.
3) Once the Computer Management program launches, select "Device Manager."
4) In the Device Manager, double-click "IDE ATA/ATAPI Controllers."
5) Right-click on "nVidia nForce 2(TM) SPP/IGP ATA Controller" and select "Properties."
6) Click on the "Secondary Channel" tab. If the Select Transfer Mode is set to "BIOS Default," click on the pull-down menu and select "PIO Mode."
7) Close all open windows and restart your machine when prompted
Back to top

Section jump