Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 4 (Who?), Viewed: 839 times.
Field Researcher
Original Poster
#1 Old 7th May 2014 at 12:19 AM
Default How to Stop a Texture From Stretching?
Greetings,

After being unable to find a custom mesh to use for a project, I have recently tried to modify a base game female swimsuit mesh (this one) because I wanted to cover up and smooth out where the cleavage is exposed at the top... I intend to retexture the mesh and make it into a Star Wars flightsuit. I was able to bring up the edges of the mesh where the swimsuit ends and drag them up closer to the neck to cover up the chest and smooth out the area, but when I put the texture onto it the texture stretches where I brought up the edges in the mesh. I understand why it's stretching the texture but I'm not sure how to fix it... or if I can fix it.

Here is what the mesh looks like after I modified it. Here it is with an older version of my custom texture. As you can see, the gray box is getting stretched pretty badly because it should look more like this.

Is there some way that I could stop the texture from being stretched like that? I'm entirely a novice when it comes to meshing (I'm better at making recolors) and I don't really know much about what I'm doing, and it took me a few hours just to figure out how to to that modification-- though, admittedly, originally I was trying to bring up the area where the cleavage is, bring it up to match the edges of where the swimsuit ends and flatten it out because I figured that it probably wouldn't stretch out the texture that way, but it didn't go so well and there was a large seam where the swimsuit ended and the flesh was exposed on the original model...

Any help would be much appreciated. Thank you!
Advertisement
Mad Poster
#2 Old 7th May 2014 at 5:05 PM
Import your mesh in Milkshape
Apply the texture as material:
select your mesh(its faces) either by drawing a rectangle arround it or select it in the groups tab.
material tab/new/none/browse to your texture/select it/assigne.
right click in your 3d window and choose textured(untick colored groups if ticked).

you mesh should now show up textured similar as in bodyshop.
Visit the texture coordinate editor under the windows tab(top)
make the popup window a little smaller so you both view the coordinates in the window and the 3d preview of your mesh in the 3d window.
In the texture coordinater draw a big rectangle arround the problem area and click fit selection.
Tick redraw box.
Select and move each individual(or maybe a row) coordinate and view the results in the 3d window.
keep editing till satisfied
Field Researcher
Original Poster
#3 Old 8th May 2014 at 12:53 AM
Ah, I think that worked. Thank you very much.

Unfortunately, I screwed up the collar/neck of the mesh... Boy it's hard to get it back to the right size. I think I got something that works, though it's a tiny bit bigger than the neck on the Sim head... Ah well...
Site Helper
#4 Old 8th May 2014 at 7:26 PM
Quote:
Originally Posted by ZeonZumDeikun
Unfortunately, I screwed up the collar/neck of the mesh... Boy it's hard to get it back to the right size. I think I got something that works, though it's a tiny bit bigger than the neck on the Sim head... Ah well...


That's easy enough to fix. Import a Maxis mesh and transfer the vertex information for the vertices around the neck onto your mesh (using the Vertex Data Merge and Normal Data Merge plugins). Then delete the Maxis mesh.
Field Researcher
Original Poster
#5 Old 9th May 2014 at 10:15 PM
Ah, interesting. I might have to give that a try. Thanks.
Back to top

Section jump