Replies: 16 (Who?), Viewed: 5010 times.
Scholar
Original Poster
#1 Old 30th Oct 2006 at 10:44 AM Last edited by tiggerypum : 10th Nov 2006 at 9:54 PM.
PETS EP - Hair Animation Issues
Edit by Tiggerypum - split this off into it's own thread because it's not clear which of the tools or combination is causing this -- I believe these meshes were edited with Unimesh and then put through the SMD export/import -- but if people would verify that would be helpful.

Meantime, lets get some working prepets and non-working files posted here, so that people who know how can look at the insides and see if they see something different we can then adjust for!


----


I blame this on Pets!
But I cannot get animation bones to work properly anymore... this is what I posted on the SimPE Forum:



"Hi there

Ignoring all warnings about using SimPE with Pets, I have created a new hairmesh (ponytail) and tried to add animations with it. ( I am using the newest QA version)

The more the mesh is assigned to the b_hair hairbones, the more it's pulled inside the head...

Could that be because of the new ep? May this info be useful for the up coming new Pets version of SimPE with your lovely plugins?

Before



After




Thank you

*Edit*
Most of the hairbones will have a strange effect after import... I will have to test f_hair. c_hair looks fine.

b_hair pulls the hair forward.
r_hair and l_hair will shrink the mesh, the more it's assigned.


Using an earlier version of the .SMD exporter/importer has no effect. I think the .smd exporter and/or SimPE will have to be adjusted to the new EP."

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Advertisement
world renowned whogivesafuckologist
retired moderator
#2 Old 30th Oct 2006 at 10:59 AM
Nouk, I don't know if it's Pets causing it but... Here's a way you could check for sure: http://www.modthesims2.com/showthread.php?t=107015 ... all hail the glory of the Modfather.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Scholar
Original Poster
#3 Old 30th Oct 2006 at 7:27 PM
SimPE still detects the Pets Game Files... I think it's a combination with SimPE not being compatible with Pets. I think I'll have to reinstall and not install Pets at all to know for sure....

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Lab Assistant
#4 Old 1st Nov 2006 at 10:45 AM
Hello,Nouk! Did you find a solution? I get the same pulled up animations as you and I also have pets installed.This is a bummer,now that I finally gotten around to do this.

I'm off enjoying Real Life.
Please take a look at my digital artwork HERE!
You can find more of my Sims2 creations HERE and HERE
Thank you!
Scholar
Original Poster
#5 Old 1st Nov 2006 at 11:04 PM
Hi, Sussi! My solution was to try and get rid of Pets, by de-installing and re-installing the game... now the game won't start at all anymore XD Not a good idea for my computer.
But I'm getting help from the great SimSample, so I think it will be fixed soon enough

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Lab Assistant
#6 Old 1st Nov 2006 at 11:40 PM
I'm so sorry for you! It is most likely to be Pets causing this.I tried to move my hair to my other computer that has only the base game installed,but it acted the same way there and the thumbnail in CAS showed a nude full body! It didn't show up in base game bodyshop either,so damned the Pets. I have to do the hair from scratch now and I will also uninstall Pets until there is an update for SimPE and a patch for the expansion.

I'm off enjoying Real Life.
Please take a look at my digital artwork HERE!
You can find more of my Sims2 creations HERE and HERE
Thank you!
Test Subject
#7 Old 8th Nov 2006 at 6:57 PM
i have pets installed, aswell. I was meshing a new hair earlier on, assigning anything other than the "head" bone gets distorted. i fucking hate pets now. any solutions anyone?

~Charlie


I Do not take ANY requests!

Visit my TSR FA site!
Admin of Randomness
retired moderator
#8 Old 8th Nov 2006 at 11:23 PM Last edited by tiggerypum : 10th Nov 2006 at 9:57 PM.
ChazDesigns, I dunno what is causing the animation errors. I think Nouk pointed some stuff out also. Does all your OLD hair act up, or only new stuff? If the old stuff is fine - go try the legacy bodyshop for building your recolors and see if that helps.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Test Subject
#9 Old 9th Nov 2006 at 4:30 PM
Tried legacy bodyshop, tried basically ANYTHING that causes this to happen. And none of my before-pets-installed stuff act like this. i made this mesh after pets installed.

anymore help would be appreciated!

~Charlie


I Do not take ANY requests!

Visit my TSR FA site!
Scholar
#10 Old 10th Nov 2006 at 1:01 PM
This sounds like it is related to the same bug that is causing problems with clothing recolors made with the Pets BodyShop.

I would guess that you made your new mesh by linking it up with a haircolor exported with the Pets BodyShop?

Try using the Legacy BodyShop to again export the same haircolor you used.

Then get rid of your first one, and link your new hair mesh up to the "legacy" one.

You'll also want to make sure to create all haircolors for it using Legacy BodyShop.

=================================

Oh, and if you are using a newer (QA) version of SimPE, I would also try using an earlier SimPE version.
Test Subject
#11 Old 10th Nov 2006 at 5:58 PM
I ried making the whole thing with legacy bodyshop aswell. Made no difference, spine2 + still distorted.

I am using the Nightlife version of SimPE (I don't own OFB).

~Charlie


I Do not take ANY requests!

Visit my TSR FA site!
Admin of Randomness
retired moderator
#12 Old 10th Nov 2006 at 9:46 PM Last edited by tiggerypum : 10th Nov 2006 at 10:13 PM.
Can I strongly suggest that 2 meshes (one working that was created pre-pets, that has the same sort of bone assignments) and the new one be posted over at the SimPE QA area, along with info about exactly what steps you took and what tools you used... Perhaps we have a subtle difference in the skeleton between versions that is throwing the hair off?

Please also post the same here, and maybe someone who knows enough about internals will dig though it... but the more heads we get involved with this, the better.

I just finished writing up pets issues and the corresponding documentation... but it looks like we have more to deal with.

General Pets issues: http://www.modthesims2.com/showthread.php?t=202496

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Test Subject
#13 Old 11th Nov 2006 at 10:19 AM
Ok, I had enough of this chaos over hair, I finally had the guts to uninstall pets and reinstall from the original to nightlife again, see how things go when i go out to by OFB today. See if anything goes back to normal.

~Charlie


I Do not take ANY requests!

Visit my TSR FA site!
Scholar
Original Poster
#14 Old 14th Nov 2006 at 11:51 AM
Ok guys, it really is the pets ep, and this is how to correct your mesh:

1. Get rid of the stoopid Pets ep. It sucks for creators. Uninstall! destroy! Burn!
2. Build new mesh packages for the meshes.
3. To be sure, reimport and export your mesh from milkshape.
4. Replace gmdc.
5. Extract and import a new texture file for your mesh.
6. Assign the brand new meshfiles to the brand new texture files.
7. Animate the way you want. It will work now!
8. (Optional) Ritually burn your Pets cd. It sucks for creators.

I have not tried anything with the Pets ep installed, and the Legacy Bodyshop.

Please visit WickedNoukFamily Forum for my creations.
Can't take requests, I'm completely swamped with unfinished projects! :O
Admin of Randomness
retired moderator
#15 Old 14th Nov 2006 at 2:21 PM
I was just about to PM you Nouk and ask you if you got your hair working with Pets or not. The answer is no pets. Hmm.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Lab Assistant
#16 Old 14th Nov 2006 at 8:20 PM
Quote:
Originally Posted by Nouk
Ok guys, it really is the pets ep, and this is how to correct your mesh:

1. Get rid of the stoopid Pets ep. It sucks for creators. Uninstall! destroy! Burn!
2. Build new mesh packages for the meshes.
3. To be sure, reimport and export your mesh from milkshape.
4. Replace gmdc.
5. Extract and import a new texture file for your mesh.
6. Assign the brand new meshfiles to the brand new texture files.
7. Animate the way you want. It will work now!
8. (Optional) Ritually burn your Pets cd. It sucks for creators.

I have not tried anything with the Pets ep installed, and the Legacy Bodyshop.

Hi !
it's the first time as i answer to this sort of thread, i've read them houndred times to learn and learn from you all : thousand thanks !
I'm not a good "technician" (and french speaking...) but i'll try to explain what i've done to resolve that same animation problem.
I've got Pets installed i use Milkshape and Weh's plugin ( )
and Simpe.
So i've tried to fix hair (human) animations with Shankyboy's smd export/import it never works, and was about thinking that i'm too stupid but by hasard i've tested this :
create your mesh as allways with Milkshape and export it with Weh's plugin, replace it in Simpe, then use the export function from SimPE and export the gmdc with "Milkshape 3D ASCII (*text)".
Import it right back (in the same format, without modify anything), I use the "remove all groups before" and "add" fonction in Simpe, comit, fix integrity as allways and it works fine ! Hair with natural motions !!
I don't know if this is interesting for you but i've never read anything about this SimPE function, if that could help someone it would be great !
Bye !

Visit my site :
http://sites.estvideo.net/bipsouille.sims/
to much request... I can take no more requests Sorry !
Admin of Randomness
retired moderator
#17 Old 15th Nov 2006 at 12:35 AM
I could be mistaken, but saving as milkshape ascii I believe turns the mesh back into a single bone assignment mesh, so I'm puzzled how this would solve Nouk's problem, as she wants extra assignments on the hair. I will try and experiment with this issue myself in the next few days.

"Undertake something that is difficult; it will do you good. Unless you try to do something beyond what you have already mastered, you will never grow." - Ronald E. Osborn

Please do NOT PM me with requests, creation questions, or game help questions. Click for help:
Game Help | Create | Content List | Where Can I Find?
Back to top