Replies: 18 (Who?), Viewed: 2024 times.
Test Subject
Original Poster
#1 Old 25th Sep 2008 at 7:18 PM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Newspaper Print Issue: Need some more help
http://www.modthesims2.com/showthread.php?t=299222
I am currently having problems with my Sims 2 games and after a long google search I finally found the above thread.
Since the thread is closed, my issue is not exactly the same and I haven't been able to resolve it yet, I decided to open this new thread.

I haven't played Sims 2 for a while and I recently bought Appartment Life. I have all other expansions and stuff packs except for Ikea. After installing Appt. Life though I found out i had the so-called 'newspaper print' issue. i uninstalled all my sims games and reinstalled them one by one in the order of release (leaving out stuff packs for now), after each install checking if it still worked. It did up to Bon Voyage.

After installing BV however, the newspaper print reappeared. i uninstalled BV, it worked fine. I installed it again, newspaper print. I uninstalled, it worked fine, cleaned the disc, installed, same result.
I uninstalled and instead installed Free Time. This also caused the newspaper print.

I tried a few older drivers (NVIDIA GeForce 8400M GS), no avail.

The newspaper problem seems to be happening in most sims stuff that was already there in the original game, since I have been checking Strangetown all the time. My sims have grey faces with no texture, and some even have newspaper print clothing. Even walls, floors and fences have it! Most of the game seems newspaper printed, making it unplayable. Changing quality settings makes no difference. I have only the maxis created folder in my game now, since it re-creates the folder every time I uninstall an EP.

I'm a little lost at what to do now after trying all above obvious things.

What is the most likely thing that has happened, and what should I do now? Clean all my disks and reinstall everything? or just the ones that don't seem to work? Clean my registry, then re-install? Copy files, as suggested in the thread I linked to? if so: which ones on which EP?
Can you help me find the solution that is most likely to solve it before i go and randomly do something?

This is so strange... I payed a few hundreds of euros for this game + EP's. I want to be able to play it!
Advertisement
#2 Old 25th Sep 2008 at 7:46 PM
Just an idea ---- but have you applied all of the appropriate patches too?
Née whiterider
retired moderator
#3 Old 25th Sep 2008 at 7:52 PM
Have you cleaned your BV disk and tried a manual install? Game Help:Installwiki

What I lack in decorum, I make up for with an absence of tact.
Test Subject
Original Poster
#4 Old 25th Sep 2008 at 8:29 PM
I cleaned my BV disk, but haven't tried a manual install yet.

This issue seems to be caused by all EP's after Seasons, being BV, Free Time and Appartment Life.

Patching the game? I thought that each new EP automatically has a patch for the previous EP. Seems I was wrong since your link seems to tell me to patch all the games I own. I will try what patching it all does, and report back later!

Thanks for your help so far!
Edge Of Darkness
retired moderator
#5 Old 25th Sep 2008 at 8:52 PM
No, each new EP is not patched- many new patches have been released since the earlier EPs were released. However patching will not directly correct the problem you are having.
The 'newspaper print' is definitely caused by missing or corrupted textures- therefore upgrading graphics drivers will have no impact upon this. It is most likely caused by the files for the EPs you install not being copied correctly- either because your DVD player is faulty, your discs dirty/ damaged or possibly due to other resasons such as insufficient disc space. I would definitely recommend to try what whiterider has recommended- uninstall the entire game, make sure there are no Sims 2 registry keys OR files remaining on the PC (important- as corrupted files may not be removed during the uninstall process) and then manually reinstall from cleaned discs. This involves copying the files to the hard drive of your PC so ruling out transfer errors.

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Test Subject
Original Poster
#6 Old 25th Sep 2008 at 9:14 PM
Okay, gonna work on this and then report back what worked
Shaken, Not Stirred
#7 Old 25th Sep 2008 at 10:44 PM
To compound the confusion even more, which is what REALLY gets me:

The Newsprint can be made to go away or reappear just by adding removing bon voyage, with exactly the same results every time you uninstall/reinstall

But here's the kicker, that I wonder might rule out corruption. The textures missing are from the base game, not the EP. So suddenly the base game textures are disappearing or reappearing based on whether an EP is installed? That smells bad, even for wierd corruption.

Correct me if I'm wrong Resie
Edge Of Darkness
retired moderator
#8 Old 26th Sep 2008 at 2:36 AM
I still think this is a case of file corruption though, as a lot of the basegame items were updated in each EP and so BV corruption would cause textures to be called incorrectly. If it were just a case of the basegame textures becoming corrupted then replacing them would solve the issue. I have instructed how to do that in the thread Resie linked to in the first post but that didn't work. It does sound strange though- we'll find out more by the results of what Resie tries next.

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Test Subject
Original Poster
#9 Old 26th Sep 2008 at 10:23 AM Last edited by Resie : 26th Sep 2008 at 12:37 PM.
Oh i think i mislead you guys a bit. i haven't tried replacing textures yet since I have no idea where to start. Base game? EP? Both? And where are those textures?

Yesterday i tried uninstalling everything, deleting all folders and checking registry (was clean, however I don't know what the reg of Appt Life is). Then cleaning my base game disks (4 CDroms) and installing it without any problem at all. It worked just fine and as far as i could see all textures were there. Then I installed ONLY Appt. Life (although disk is brand new i still cleaned it), boom, textures gone. So there goes my small hope of being able to solve it that way or at least rule something out.

What makes it even stranger though, is that when I install the last 3 EP's, I hear a strange sound coming from my DVDrom from 95% on, when it's trying to do "Support". I wonder if that could be causing my problem.
But missing something as futile as support files can hardly break my game, can it? Maybe it's something it's supposed to install AFTER Support, but fails to? In that case I basically got it|: Install first 5 EP's normally, install last 3 manually. or maybe manually replace some stuff from the last EP"s?

Does anybody know if the last EP's change something about textures from the base game, maybe even something as small as the way the base game textures load?-> EDIT: never mind that, Simsample basically said it does. This means I could try manually replacing files. But which ones?

Trying to rule out some things here, because I hate randomly doing something. On top of that, as much as I hate this problem I also find it qwuite interesting. Meanwhile my game looks very broken, spectacular and disturbing. Almost everything is newspaper. Want screens? :p



EDIT 2: OK something more, sorry to cram so much into one post but I sincerely hate double posting.
i am now browsing through my Appt life CD. Should every file and every folder that's there also be on my Appt folder in my program files? In that case at least some folders are missing!
EDIT 3: Uninstalled Appt Life, game seems fine now. Doing manual install thing now. Might be interesting to know what happens then.
EDIT 4: Before I was going to manually install i decided to install the newest drivers again as this wasn't causing the newspaper thing. So i thought. Because after installing the new drivers and a reboot, the newspaper thing re-appeared in my base-game. Uninstalling and re-installing fixed it again.
I'm at loss of what to do now. drivers do seem to have something to do with it... Very weird...

EDIT 5: I decided to carry on as planned. I copied the Appt. Life disk to my laptop and installed from there. Since this is the first EP i installed after the original, it did ask for my CD4 of the original of course. It seemed to go very smoothly. However the newspaper thing is back...
I think for now I am out of options. Clearly this problem doesn't seem to be caused by a broken disk since everythihng copied fine to my HD.
I shall stand back and wait for further help...

EDIT 6: OK I tried one last thing which is manually copying the files as instructed in the post i linked to at the start of the thread, but then of course for Appt Life. No change whatsoever, still newspaper. I even tried copying ObjectScripts. Didn't do anything. And NOW I will just play Spore and wait for a reaction from you guys.
Screenshots
Edge Of Darkness
retired moderator
#10 Old 26th Sep 2008 at 9:01 PM
Karybdis, the plot thickens!

Resie, it's the basegame textures we'll try first, so that is the files in Program Files\EA Games\ The Sims 2\ TS Data\ Res\ Sims3D. Follow this:

Look on your Basegame discs for the correct files. The relevant files should be in a file called compressed.zip. The files you are looking for are:
objects00.package to objects09.package
Sims00.package to Sims13.package
Textures.package
Objects.package
You need to put the objects00.package to objects09.package files, the Sims00.package to Sims13.package files and Textures.package into Program Files\EA Games\ The Sims 2\ TS Data\ Res\ Sims3D. The Objects.package file goes into Program Files\EA Games\ The Sims 2\ TS Data\ Res\ Objects.

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Test Subject
Original Poster
#11 Old 27th Sep 2008 at 12:04 PM
OK files are scattered all over those 4 CD's. I find myself forced to keep notes of what I copied and from which CD.
My laptop seems refuse to copy anything to that folder unless I delete the original first... Is this a vista "feature"?

(45 mins later OK done, booting game... please let this be it!

Sigh, didn't fix it. Argh, this is really strange and complicated!
Any more ideas?
Edge Of Darkness
retired moderator
#12 Old 27th Sep 2008 at 10:38 PM
So you have replaced all of those files for the basegame and you're still getting corrupted basegame textures? Could you just clarify for me which EPs you have installed now? And if you uninstall some EPs, when do the textures appear normally?

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Test Subject
Original Poster
#13 Old 27th Sep 2008 at 11:34 PM
I only have the base game and Appartment life installed at the moment. So uninstalling that will leave me with the basegame only. The basegame is not causing problems...
I don't know, I find this very very strange...
Edge Of Darkness
retired moderator
#14 Old 28th Sep 2008 at 1:21 AM
I'm thinking that this has to be something to do with Securom, Vista or a combination of both. Maybe something is preventing the game from correctly reading the basegame textures when the later EP(s) are installed. We'll first need to rule out a few other things though... could you just try replacing those same texture files in the Apartment Life folders. The only difference from my first instructions are that you'll need to copy the files to Program Files\EA Games\ The Sims 2 Apartment Life\ TS Data\ Res\ 3D and Program Files\EA Games\ The Sims 2 Apartment Life\ TS Data\ Res\ Objects. From the compressed.zip file on the AL disc, of course! If that has no lucj can you just confirm for me that the basegame textures function correctly if you then simply uninstall AL?

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Test Subject
Original Poster
#15 Old 28th Sep 2008 at 11:06 AM
OK doing that now.

Hmm, My Appt. Life sims01 file seems to be missing on my laptop. Very strange since I don't remember deleting anything from my Appt. Life folder...

OK I found out why... On my CD there is no Sims01 file either. I checked and I double checked and it's just not there.

Replacing the Appt. life files did nothing for me. I wonder if that missing Sims01 could be the key.

So before I uninstall Appt Life, can somebody check if it is normal for the Sims01 file to be missing in Appt Life?
Edge Of Darkness
retired moderator
#16 Old 28th Sep 2008 at 1:41 PM
Sorry that's my fault; when I glanced at the files I didn't notice that! It is correct, there is no Sims01 file for Apartment Life. Well spotted!

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Shaken, Not Stirred
#17 Old 28th Sep 2008 at 11:40 PM
Well, just verified that it's not the SecuROM...

DirectX10 Error possibly? I don't know how to get around that.
Test Subject
Original Poster
#18 Old 29th Sep 2008 at 12:11 AM
Me and Karybdis tried a few things in my game. We managed to find out a few things, eventhough the problem is still there. So here goes:

The problem is not Securom.

We finally discovered that my households are fixed by setting texture details on low.

My neighborhood view though, is still messed up, which is why I missed the texture details thing before. In Strangetown (the neighborhood i always check in my attempts to solve this) the watercooler thing still has missing textures, as well as the trees in the Smiths' houshold. However, if I enter the Smiths' household with texture details on low, the trees are there.

I'm calling it a night for now, I'm in Europe and it's getting quite late. I hope you guys can tell me what to do next?
Edge Of Darkness
retired moderator
#19 Old 29th Sep 2008 at 12:17 PM
So is this still with AL installed, or have you uninstalled AL? If you have uninstalled then do the textures appear on high res if you replace the texture files or reinstall? I'm still thinking that, if the texture files are there and intact then something must be preventing the game from reading them correctly. The fact that the low res textures work only proves that the low res textures are intact. We still haven't demonstrated that the files aren't damaged.

I will choose a path that's clear- I will choose free will
-RUSH
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Back to top