Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 11 (Who?), Viewed: 548 times.
Lab Assistant
Original Poster
#1 Old 9th Oct 2015 at 12:17 PM
Default Is there any way to increase UI size for Sims 3 ?
My monitor is 27" 2560x1440 , GPU is GTX 780 Ti @ 1203Mhz/1907Mhz. I can play any game with no problem.

But I really want to play Sims 3 with DSR (Dynamic Super Resolution). Basically it make my monitor become 5K (5120x2880) and of course SUPER SHARP image quality and almost no jaggies.
Learn more about it here. http://www.geforce.com/hardware/tec.../dsr/technology
Of course my 780 Ti cannot handle 5K gaming ultra setting in AAA games like GTA V or BF4.
But Sims 3 and Sims 4 is easy as you can see 5120x2880 resolution with every thing max setting but still 60FPS (I enabled V-Sync in Nvidia Control Panel).
Problem is UI size is so small (even 4K 3840x2160 is still too small for 27" monitor).

For Sims 4 increasing UI size is very easy by editing uiscale in options.ini file.
But for Sims 3 I try searching in Google but all says "reduce your in game resolution" (cause lame image quality) or "get bigger monitor" (lower PPI so worse image quality and what ? why new monitor ???).
Any help would be appreciated. Thanks !!



Advertisement
Lab Assistant
#2 Old 9th Oct 2015 at 1:45 PM
I want to know the answer to this one too.I have a GTX 970 and would really love to have higher resolutions using DSR.
Theorist
#3 Old 9th Oct 2015 at 2:54 PM Last edited by nitromon : 9th Oct 2015 at 7:10 PM.
Hey this looks extremely interesting. I noticed that this technology extends all the way down to generation 400 cards, but it seems to be only for the GTX cards? Anyone able to get it working on a GT card?

EDIT: (For people who's Nvidia GPU is NOT on the supported DSR list)

List of supported Nvidia GPUs

Alright, I did some playing around and research so you people don't have to. If you have a Nvidia that is within the range 400+ but not on the supported list for DSR, you can still partially take advantage of this technology.

From what I've researched, in order to increase performance, most games render at lower resolution than your HD quality and then blow it back up. The DSR does the opposite and renders it higher with choices of 2x, 2.5x, 3x, and 4x and then shrink it back down to your resolution. So essentially you can get 4k rendering resolution then shrunk back down to your resolution.

If your Nvidia GPU is not on the list, you can try enabling this via Nvidia Inspector.

1) Make sure your driver is updated.
2) Run Nvidia Inspector
3) In global, turn on "Nvidia Quality Upscaling." (It is at the bottom under "other.")

What this does is turn on the DSR. However, I cannot find the flag to tune the scaling. If someone finds it, please share. With this turned on, the rendering will be set at 1x. It means that it will not render at lower resolution and blow it back up. It will simply render at your current resolution. (It basically means it doesn't upscale or downscale)

The result is actually quite visible. Everything is sharper, better image quality. There doesn't seem to be a performance tax, but then again this is only 1x. The reason your card is not on the supported list is probably because at 2x, there will be a performance hit for older cards.

Anyhow, for anyone interested, try it at your own risk and report back if you like to add to the performance data.

Everything happens for a reason
but sometimes the reason is
that you're stupid and you
make bad decisions.
Top Secret Researcher
#4 Old 9th Oct 2015 at 5:03 PM
Quote:
Originally Posted by nitromon
you can try enabling this via Nvidia Inspector.

1) Make sure your driver is updated.
2) Run Nvidia Inspector
3) In global, turn on "Nvidia Quality Upscaling." (It is at the bottom under "other.")


That's a different way to how I do it.
I just open up Nvidia Control Panel (right click on desktop) and go to manage 3D settings. Under the global tab, turn DSR factors on and checkbox all the new resolution options. Apply changes. They now appear in game under options.

Anyhow, the answer to the OP is that there is no way to do that currently. Someone could surely do it, a few people on this site could do it, but I personally only have a GTX460 and any attempt to upscale Ts3 only results in obvious FPS loss. OP, have you checked your FPS count in fraps? I doubt with your card it would run as smoothly in 4k as opposed to your default highest resolution. With such a glitchy, script heavy game, the vast majority of people right now will experience performance loss if raising the resolution.
My advice would be to experiment with things like FXAA and anisotropic filtering within Nvidia Control Panel to improve the look of the game, because having the UI that small will never ever work....

Oh... one game that really benefits from DSR is Pinball Arcade. Pin-sharp image.

TS3 NEEDS: TENNIS COURTS > BUSES > PIGS/SHEEP
Can't find stuff in build and buy mode? http://www.nexusmods.com/thesims3/mods/1/?
Theorist
#5 Old 9th Oct 2015 at 5:08 PM
Quote:
Originally Posted by tizerist
That's a different way to how I do it.
I just open up Nvidia Control Panel (right click on desktop) and go to manage 3D settings. Under the global tab, turn DSR factors on and checkbox all the new resolution options. Apply changes. They now appear in game under options.


That only shows up on supported GPU. I don't know why the GT 650m is not supported. The GTX 650m is supported and GT 645m is supported. Do you think you can take a look in Nvidia Inspector to see what flags are turned on? I really like to find out the multiplier flag.

Everything happens for a reason
but sometimes the reason is
that you're stupid and you
make bad decisions.
Lab Assistant
Original Poster
#6 Old 9th Oct 2015 at 6:24 PM
Quote:
Originally Posted by tizerist
That's a different way to how I do it.
I just open up Nvidia Control Panel (right click on desktop) and go to manage 3D settings. Under the global tab, turn DSR factors on and checkbox all the new resolution options. Apply changes. They now appear in game under options.

Anyhow, the answer to the OP is that there is no way to do that currently. Someone could surely do it, a few people on this site could do it, but I personally only have a GTX460 and any attempt to upscale Ts3 only results in obvious FPS loss. OP, have you checked your FPS count in fraps? I doubt with your card it would run as smoothly in 4k as opposed to your default highest resolution. With such a glitchy, script heavy game, the vast majority of people right now will experience performance loss if raising the resolution.
My advice would be to experiment with things like FXAA and anisotropic filtering within Nvidia Control Panel to improve the look of the game, because having the UI that small will never ever work....

Oh... one game that really benefits from DSR is Pinball Arcade. Pin-sharp image.


No matter what resolution I play Sims 3 (1440p , 4K , 5K) , performance is always the same.
I already set anisotropic filtering to 16x in Nvidia control panel.
But FXAA I think it's not working in Sims 3 because I still see some jagged that MSAA (I think MSAA is edge smoothing in game?) don't do anything. Actually some type of jagged cannot reduce by MSAA but FXAA can. So I assume FXAA is not working ?
Maybe Sims 3 engine is not support post processing effect like FXAA SMAA MLAA ?

Anyways thanks for reply
Lab Assistant
Original Poster
#7 Old 9th Oct 2015 at 6:32 PM
Quote:
Originally Posted by nitromon
Hey this looks extremely interesting. I noticed that this technology extends all the way down to generation 400 cards, but it seems to be only for the GTX cards? Anyone able to get it working on a GT card?

EDIT:

Alright, I did some playing around and research so you don't have to. If you have a Nvidia that is within the range 400+ but not on the supported list for DSR, you can still partially take advantage of this technology.

From what I've researched, in order to increase performance, most games render at lower resolution than your HD quality and then blow it back up. The DSR does the opposite and renders it higher with choices of 2x, 2.5x, 3x, and 4x and then shrink it back down to your resolution. So essentially you can get 4k rendering resolution then shrunk back down to your resolution.

If your Nvidia GPU is not on the list, you can try enabling this via Nvidia Inspector.

1) Make sure your driver is updated.
2) Run Nvidia Inspector
3) In global, turn on "Nvidia Quality Upscaling." (It is at the bottom under "other.")

What this does is turn on the DSR. However, I cannot find the flag to tune the scaling. If someone finds it, please share. With this turned on, the rendering will be set at 1x. It means that it will not render at lower resolution and blow it back up. It will simply render at the resolution you set.

The result is actually quite visible. Everything is sharper, better image quality. There doesn't seem to be a performance tax, but then again this is only 1x. The reason your card is not on the supported list is probably because at 2x, there will be a performance hit for older cards.

Anyhow, try it at your own risk and report back if you like to add to the performance data.


I have laptop with GT 740M 2GB. DSR is not support on my laptop. Maybe like you said only GTX 400 and above is support.
Theorist
#8 Old 9th Oct 2015 at 7:12 PM
Quote:
Originally Posted by enterprise24
I have laptop with GT 740M 2GB. DSR is not support on my laptop. Maybe like you said only GTX 400 and above is support.


Hey, give my suggestion a try. Rendering at 1X is still better than downscaling. I'm surprised that even at 1X the difference is quite noticeable. I can't imagine how smooth the graphics is at 2X or more, it must be fantastic. Thanks for sharing this info.


Oh, and to answer the original question concerning the UI. I also do not know of a way to change the UI. However, at 1X, the UI will remain the same.

Everything happens for a reason
but sometimes the reason is
that you're stupid and you
make bad decisions.
Lab Assistant
Original Poster
#9 Old 10th Oct 2015 at 7:13 AM
Quote:
Originally Posted by nitromon
Hey, give my suggestion a try. Rendering at 1X is still better than downscaling. I'm surprised that even at 1X the difference is quite noticeable. I can't imagine how smooth the graphics is at 2X or more, it must be fantastic. Thanks for sharing this info.


Oh, and to answer the original question concerning the UI. I also do not know of a way to change the UI. However, at 1X, the UI will remain the same.


Try Nvidia Quality Upscaling (I only have 0 or 1 for select I think 0 is off and 1 is on) but to be honest I don't see any difference...
So no way to increase UI size ? Never mind .Next I will try SGSSAA (Sparse Grid Super Sampling Anti Aliasing) via NV inspector. I hear it's the best possible type of AA for Nvidia card.
Top Secret Researcher
#10 Old 10th Oct 2015 at 11:14 AM
Quote:
Originally Posted by nitromon
I'm surprised that even at 1X the difference is quite noticeable. However, at 1X, the UI will remain the same.

I'm a bit confused. If you're running it at x1 then surely this is your standard resolution without DSR?
Quote:
Originally Posted by nitromon
Do you think you can take a look in Nvidia Inspector to see what multiplier flags are turned on?

I don't have Nvidia Inspector but if you mean what resolution options I have it's x1.20, x1.50, x1.78, x2.00, x2.25, x3.00, x4.00

TS3 NEEDS: TENNIS COURTS > BUSES > PIGS/SHEEP
Can't find stuff in build and buy mode? http://www.nexusmods.com/thesims3/mods/1/?
Theorist
#11 Old 10th Oct 2015 at 12:43 PM
Quote:
Originally Posted by tizerist
I'm a bit confused. If you're running it at x1 then surely this is your standard resolution without DSR?


From what I understand, most games (not all) will downscale less than your set resolution and then bloat it back up. So in sense you are getting less than x1. So with that option on, all it does is rendering it at the current resolution. The DSR option upscale it to x2-x4, then shrink it back down to your set resolution.

Quote:
I don't have Nvidia Inspector but if you mean what resolution options I have it's x1.20, x1.50, x1.78, x2.00, x2.25, x3.00, x4.00


Thanks anyways, I have a feeling it is the same flag, except in the Nvidia control panel it will modify it to higher scales. That's the same thing they did in the pre-rendered frame setting in which in Niv Ins, you can only set it to 1 or 2 frames while in the control panel you can up it to 4 frames.

Everything happens for a reason
but sometimes the reason is
that you're stupid and you
make bad decisions.
Lab Assistant
Original Poster
#12 Old Yesterday at 5:35 PM Last edited by enterprise24 : Yesterday at 6:28 PM.
There is a better way to improve image quality in Sims 3 rather than DSR if anyone interest (for Nvidia owner's).

"SGSSAA or Sparse Grid Super Sampling Anti Aliasing" http://forums.guru3d.com/showthread.php?t=357956

Download nvidia inspector here http://www.guru3d.com/files-details...r-download.html

Instruction
1.Open nvidia inspector and select Sims 3 profile.
2.Set anti aliasing compatibility bit to 0x000000C1
3.Set anti aliasing mode to override application setting.
4.Set anti aliasing setting to 8xQ (Multisampling).
5.Set anti aliasing transparency supersampling to 8xSparse Grid Super Sampling.
6.Set texture filtering LOD BIAS (DX) to -1.5
7.Click apply and done !!
8.For even better image quality set texture filtering to high quality and anisotropic filtering setting to 16x (16x will not cause any performance penalty even on very low end VGA). Don't forget to add ambient occlusion http://modthesims.info/t/489269



I recommend at least GTX 670 , 770 , 960 for 8xSGSSAA at 1080p. If your VGA card is below this try 4xSGSSAA or 2xSGSSAA with this simple rule.
1.MSAA should be equal to SGSSAA for example 2xMSAA should pair with 2xSGSSAA. This will have better image quality than 2xMSAA with 4xSGSSAA or 4xMSAA with 2xSGSSAA. For in depth reason see this http://naturalviolence.webs.com/sgssaa.htm
2.LOD BIAS for 2xSGSSAA is -0.5 and for 4xSGSSAA is -1.0

I ask in guru3d forum and got answer that compatibility bit for Sims 3 and perhaps Sims 4 is 0x000000C1 or 0x00000041.
Wrong compatibility bit can cause blurry image.

Please ignore my bad English
Back to top