Home | Help | Download | Community | Site Map | New Posts | Sign in
Replies: 12 (Who?), Viewed: 35987 times.
Field Researcher
Original Poster
#1 Old 9th Jul 2009 at 3:32 PM
Default Error Code 12
When trying to save the game, I am suddenly continually getting Error Code 12, and it refers me to check the readme file - which I do not have. I installed from a digital download, not sure if that makes a difference, but I don't have the readme, and I didn't delete anything when I installed The Sims 3.

I've played the game since its release date, and only this week started seeing Error Code 12.
It started happening while I was playing Sunset Valley, and instead of saving every time I changed households, I just hit continue.
I'm not a programmer, but it crossed my mind that perhaps it was something to do with too much game play stacking up that needed saving.

Anyway, I did a few scans of this site and some other sites, I see where other people have had this issue, but I haven't come across any resolution.

I am now playing Riverview. Saving every 5 minutes seemed to do the trick - until I added a very small fishing hole on the lot I was playing. Tried to save, got the code, cursed for a few minutes, endured the loading crashes from Awesomemod, get back in the game finally. I completed NO GAMEPLAY after the reload, the game was paused. I added the fishing hole again, and tried to save. Error Code 12.

Is it length of time between saves? Is it the water? I dunno. I'd like to see some more exploration and discussion on this.
Advertisement
Coffee, anyone?
staff: retired moderator
#2 Old 9th Jul 2009 at 8:01 PM
Error code 12 appears to be a World File save issue. It appears to be hardware/software memory related from what I can gather at other sites.

Can you duplicate this with fresh user files and no custom content? Have you patched your game?
Could you please give us your computer specifications?

I'm worried that my latest Salvation Army donation will result in homeless people looking like sluts from the 90s.
Field Researcher
Original Poster
#3 Old 9th Jul 2009 at 11:36 PM
Quote:
Originally Posted by Canoodle
Error code 12 appears to be a World File save issue. It appears to be hardware/software memory related from what I can gather at other sites.

Can you duplicate this with fresh user files and no custom content? Have you patched your game?
Could you please give us your computer specifications?


Yes, my game is patched - this started happening a few days later, so I didn't think the patch would have been the cause.

I did NOT try without custom content (but I will, I know that's one of the first things I should have done) because I have very little, and what I have was in place loooong before this started happening a few days ago. But, I will try to duplicate the error without the content, and see what happens.

AMD Athlon X2 2.7 (or 2.6, can't remember) ghz
4gb ram
Geforce 8600 GT
Windows XP Pro sp3

I'll report back after I try duplicating this without CC.
Field Researcher
Original Poster
#4 Old 10th Jul 2009 at 4:27 AM
Quote:
Originally Posted by Canoodle
Error code 12 appears to be a World File save issue. It appears to be hardware/software memory related from what I can gather at other sites.

Can you duplicate this with fresh user files and no custom content? Have you patched your game?
Could you please give us your computer specifications?


I didn't get as far as even removing CC. My husband, who does a lot of coding and creation for Second Life, and is generally a computer god (in my eyes) decided to try a few things first.

While I watched Steve McNair's memorial service, he worked on my system. I've tested the lot I was having issues with before after adding the fishing hole, and I've tested other lots in Riverview, as well as a couple lots in Sunset Valley - no error 12 so far.

He:

*updated BIOS

*updated video and motherboard drivers

*removed unnecessary startup items, such as java quicklaunch, microsoft office quicklaunch, Nvidia control panel quicklaunch, etc. (which don't show up in system tray, btw)

*removed and replaced ram

*blew dust out of case and cleaned heat sink

*removed what minimal spyware could be found with Spybot

He says it was most likely video drivers, and a small chance that it was the BIOS.

Why it started happening, I'm not sure, that isn't my area of expertise. I can tell you that I had not added or removed any programs, or updated any programs, changed any settings or configuration. Nothing was downloaded, nothing was deleted.

If anyone wants me to do any further testing of this, let me know.
Coffee, anyone?
staff: retired moderator
#5 Old 10th Jul 2009 at 5:24 AM
I vote for gremlins. Yes. That's it.

Seriously, folks are reporting this error everywhere and it seems to be totally random. It's not one sort of video card, or a shortage of RAM. It is a mystery as of now.

I'm worried that my latest Salvation Army donation will result in homeless people looking like sluts from the 90s.
Inventor
#6 Old 10th Jul 2009 at 11:56 AM
I also have been following the various threads on this issue as it's something I had a few days ago and not since. Having said that, my game takes ages to save, so I am anticipating that there is still a problem. I don't see any consistency in what people are saying is the 'reasons' or 'solutions'.. I too vote for gremlins.

*♥.¸My creations are to stay FREE only, enjoy and give credit where it's due¸.♥*
Test Subject
#7 Old 10th Jul 2009 at 11:59 AM
wat do u mean vote for gremlins?
Inventor
#8 Old 10th Jul 2009 at 12:53 PM
Quote:
Originally Posted by narutothealc
wat do u mean vote for gremlins?


I guess it was an attempt at humour borne of frustration. At this point in time I have yet to see a better explanation or a consistent one.

*♥.¸My creations are to stay FREE only, enjoy and give credit where it's due¸.♥*
Test Subject
#9 Old 10th Jul 2009 at 1:58 PM
i got it fixed. i just .. didnt save, quit without saving, when i got back it was working normally as usual again. weird
Field Researcher
Original Poster
#10 Old 10th Jul 2009 at 5:39 PM
there _must_ be something triggering it... I'll go with gremlins, too :P
Lab Assistant
#11 Old 10th Jul 2009 at 5:54 PM
I tried saving during a party and got the same message twice. Then tried after all the guests left and it saved fine.
shiny!
staff: retired moderator
#12 Old 10th Jul 2009 at 8:15 PM
What version of Sims 3 are you running? Are any of you running version 1.0.615?
Field Researcher
Original Poster
#13 Old 11th Jul 2009 at 8:21 PM
Jcasjr - that's interesting that it gave you the error and then after the guests left, saved successfully. I never tried saving more than twice before I got pissed off and just exited the game :P

callistra - I run the legit non-demo of the game, which was downloaded directly from EA. Oh, and I have the patch, too. The version number listed is 1.2.7.00107.
 
Back to top

Section jump