Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 20 (Who?), Viewed: 4265 times.
Test Subject
Original Poster
#1 Old 15th Sep 2009 at 4:43 PM
Default Step 4
I'm stuck here.. i'don't know what to do richt now..
I'm new at making a mesh..so..i made a table..i'm verry proud off but it is still in milkshape...i can't get it to export...i have to map it first..? i don't know how to do that...i have read it over and over again..i've read sims2 tut but just don't understand how to do it..can some please help me..



Advertisement
Doilyrific Diabolical Disagreer about Water Reflections
#2 Old 15th Sep 2009 at 5:15 PM
Is this part 4 of Wes's meshing tutorial in the Wiki?
Test Subject
Original Poster
#3 Old 15th Sep 2009 at 5:37 PM
http://www.modthesims.info/showthread.php?t=363856

no it's this one..from Deluxe designs
Lab Assistant
#4 Old 15th Sep 2009 at 5:41 PM
Take a look at this =)

http://www.sims2wiki.info/wiki.php?...Meshing_Part_IV

<'',><
Just keep swimming..
Test Subject
Original Poster
#5 Old 15th Sep 2009 at 6:20 PM
Step 4: Milkshape bit

Ok now open milkshape and select “file>import” and scroll down to “Sims 3 Object Import by Wesley Howe”, locate your .mcfg file that you want to edit and then select “open”, now make sure that the main mesh you make is labelled “group00” in the groups tab, in every file. Now do your meshing stuff until you are finished up (you also need to map your object before exporting it back to an mcfg).


i'm not ready to uv map the table that's next ..ik have to map my object before i can export it back to an mcfg file..this is what i don't understand...
Doilyrific Diabolical Disagreer about Water Reflections
#6 Old 15th Sep 2009 at 6:26 PM
Well save it as a native Milkshape file, so that it's safe, and then try exporting through Wes's plugin. Then recompile and replace the meshes in your package (after also taking a safe copy of the package). You can edit the mesh and export as often as you like.

So your problem is you are not sure how to map a mesh? Did you start with an table from the game and just edit the mesh or is this a complete mesh you started with a blank project in MilksShape?
Test Subject
Original Poster
#7 Old 15th Sep 2009 at 7:23 PM
i have inport a table from sims3 en then delete the frame..when i was finnisht with the table..now i don't know what to do..
Doilyrific Diabolical Disagreer about Water Reflections
#8 Old 15th Sep 2009 at 7:29 PM
So basically your problem is you don't understand what it meant when it said "do your mapping?"
Test Subject
Original Poster
#9 Old 15th Sep 2009 at 10:33 PM
yes..i have made a table but i don't understand how i can get it out of milkshape i'm getting a error when i do the export thingie..
Doilyrific Diabolical Disagreer about Water Reflections
#10 Old 15th Sep 2009 at 10:41 PM
Can you make the error happen again and write down what it says?
Test Subject
Original Poster
#11 Old 15th Sep 2009 at 11:46 PM
when i go to export i get this





then it has to overwrtite that one ..??
and then i get this...





i need to map it first i have read that but i'm going nuts here...
Alchemist
#12 Old 16th Sep 2009 at 12:35 AM
Bone assignments.

I have no idea how many joints are in your table, but there is probably only one root joint there.

Assigning that is simple. Go to the joints tab and double click on the first and only joint name on the list. Then go to the groups panel and select the group for your table (probably "group00"). Then in the joints panel, click on AssignSel.

Then you can export without the error.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Test Subject
Original Poster
#13 Old 16th Sep 2009 at 12:58 AM
now i get this one..i feel so stupid...but i'm not giving up..thx for the patience





i've done the regrouping thats oke now...i now have only group00
Alchemist
#14 Old 16th Sep 2009 at 2:23 AM
I think you are using the program on the wrong file. You select the .mcfg file and it gets recompiled back into a MODL or MLOD file. The end of the file should be "_cfg.mcfg", the recompiler is complaining that it isn't seeing "_cfg" in the name, so it isn't being directed to the right file.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Lab Assistant
#15 Old 16th Sep 2009 at 5:38 AM
I encountered these problems when I was manually splitting up the cutgem's amalgam mesh into the individual cuts in my earlier investigations of geometry states.

If you've changed the groups, what you have to do is change the files to match them.

All groups in the Milkshape file need to named group##, where ## is a number starting from 00. Don't skip numbers.

I'm not sure how temperamental Wes's exporter is to group names, but it's best to use that naming convention, since group names are irrelevant in the final binary .model files.

Next, you need to choose a name for your mesh. For the sake of easy explanation, we'll use the string "My_Mesh".

Now, you need to create a new .mcfg file or copy the original mesh's decompiled file and rename it to the following naming convention:

$$$$$$$$_cfg.mcfg

Replace the dollar signs with your mesh's name. In the case of the our example, this would be name of the file:

My_Mesh_cfg.mcfg

Now, for each group in your Milkshape mesh, you need to create an .s3asc file.
It is best to copy and rename the .s3asc files of the original mesh.
However, if you have added additional groups, you will have to create additional blank .s3asc files.
You need to use the following naming convention for your .s3asc files:

$$$$$$$$_group##.s3asc

Simply replace the dollar signs with the string name of your mesh and the pound symbols with the number of the group. If you've copied the original mesh's decompiled files, they should already be appropriately numbered.

In the case our example, we have three groups, so these would be the names of the three .s3asc files for our mesh:

My_Mesh_group00.s3asc
My_Mesh_group01.s3asc
My_Mesh_group02.s3asc

Just follow the naming conventions, and you'll be fine. Wes's exporter is actually quite powerful, and can write data to a blank group file. You just have to follow the group and file naming conventions for it to work properly.

Someday, when I've solved all the mysteries of geometry states, that's when the file names will really start to matter. For now, all you really have to worry about is groups.
Test Subject
Original Poster
#16 Old 16th Sep 2009 at 10:46 AM Last edited by Kyta1702 : 18th Sep 2009 at 3:48 PM.
I have read alot..sorry...i thought it was a little simpeler then that... but now i have the problem...that i have uvmapt it and all it is finisht..but it is still a milkshape file..can i get it back to a mcgf file?? so i can finish it .. or do i have to do it again...that no problem... but maby there is a way to get it in S3PE back...i've lost all my files that i've started with...so i onley have a milkshape file...a mesh...



Test Subject
Original Poster
#17 Old 21st Sep 2009 at 9:51 PM
OOh THX I finely understand...THX so mutch..sorry it took some time...but now the groups are oke and i don't get a error anymore..so it's out off milkshape...it took me to make 8 tables..lol..to understand..
Test Subject
Original Poster
#18 Old 22nd Sep 2009 at 12:55 PM
well i can transport regroup uv map it i realy understand how to to things now but i stil can't fix this one i have made a uv map and no mather how i fill it in the table looks terrible ingame..dit i regroup them wrong?? so the uv map i made is wrong?? the joint dot is groupoo and the table it self is group01 just like the table i used to make it...i'm still doing samething wrong..i've check here and can't find the anwser.. the top of the table is perfect..but the rest isn't..





The painting behind is a recoller i made...that i understand now..with thanks of Xanaton's tuturial...THX for making dreams come true on this site..
Inventor
#19 Old 25th Sep 2009 at 6:42 PM
I am struggling myself with making objects for TS3, but I think your trouble is your UV-map. Maybe if you could take a look at the section about UV-mapping a table for TS2 in this tutorial:

Sims 2 start to finish Object Creation Tutorial V 2.1 - UPD 22 feb 06
http://www.modthesims.info/showthread.php?t=104795

you will find how to make a new UV map for your table?
Field Researcher
#20 Old 1st Oct 2009 at 4:07 PM
A question to this bone assignment error:
I always ignored this message and assigned nothing. The object worked in game so far.
Will I get errors? Should I assign this joint before I export it?
Test Subject
#21 Old 4th Oct 2009 at 4:14 AM
Valuable information.
Back to top

Section jump