Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Locked thread | Replies: 14 (Who?), Viewed: 16334 times. | Locked by: callistra Reason: locked at OP request - answered
Test Subject
Original Poster
#1 Old 19th Nov 2009 at 10:00 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets
Default Sims 3 runs fine; With World Adventures: SLOW, SLOW, SLOW!
I haven't asked a question here in years, so I hope I'm doing it correctly. I've been playing the Sims 3 with no major problems. Yesterday I installed the update and then World Adventures. I had to return an ini file to normal first, because I'd been using the camera mod.

Now my game is practically at a standstill. The graphics are blurred or white, or the items are invisible for a long time before they fill in. Even when I return home from "vacation." The game lags so badly, I want to just give up. And loading and saving times are ridiculously long!

I played The Sims 2 with no problems, even though I had all the expansions, stuff packs, and a huge number of custom content files.

I read the post here at MTS about recommended specs, and I believe I meet all of them, and then some. However, I may have missed something. I've attached my Everhome html file called "report". I have 1209 files (1.39 gigabytes of custom content) in my Mods/Packages folder.

I hope someone can tell me what I've done wrong. Here is the file link... I couldn't figure out how to attach an ".htm" file here. Thank you!

http://www.mediafire.com/file/gz2n0edtitn/Report.htm

PS... My OS is Vista Ultimate (the report calls it media center) and I have Direct X 10 installed.
Download - please read all instructions before downloading any files!
File Type: rar Report.rar (7.8 KB, 60 downloads) - View custom content
Description: Darsky's Everesthome Report
Advertisement
Lab Assistant
#2 Old 19th Nov 2009 at 10:15 PM
What settings are you playing on? Do you have everything set to "High?" I see your using a 1680x1050 resolution, dropping that (in game) would probably help, I know it helps mine a lot. Just play around with the game res until you find one that looks decent.

Also, your graphics card may not be able to handle the EP, especially if you're using high settings in the game. Mine takes a little while to load as well. Most of my furniture and objects are white for a minute or so until the game essentially catches up with itself.

Honestly though, the best thing you can probably do is lower the settings and lower the resolution.
Née whiterider
staff: administrator
#3 Old 19th Nov 2009 at 11:00 PM
First up, it looks like you don't have the correct graphics drivers installed - I could be wrong, but it never hurts to update them anyway. You need these: http://support.amd.com/us/gpudownlo...10&lang=English
Your graphics card is getting old, but it should be ok for TS3.

That is a hell of a lot of CC - do things go faster without it?

What I lack in decorum, I make up for with an absence of tact.
Forum Resident
#4 Old 20th Nov 2009 at 12:00 AM
I was having the same problem at first, I went through and weeded out CC that I didn't need, cutting down my CC count to 193 instead of a wopping 552. Even then it was running slow. One thing I hadn't done was save the game yet after the installation of WA. So I did. After that it worked fine. But I did recieve the error 16 yesterday, which was new to me. I also have a high end machine and all the specs needed.

Facebook! | Find more of my stuff at my blog! | Tumblr | Donate
shiny!
staff: retired moderator
#5 Old 20th Nov 2009 at 12:53 AM
White is right, something is up with your video card drivers.

Since those aren't working right lets also make sure other drivers are properly installed. Install the drivers White linked to, and these:

http://www.realtek.com.tw/downloads...3&GetDown=false
http://downloadcenter.intel.com/con...lName=&lang=eng
Test Subject
Original Poster
#6 Old 20th Nov 2009 at 4:50 AM Last edited by Darsky : 20th Nov 2009 at 5:17 AM.
I got the error 16 while I was trying to update the base game... That's when I took the camera mod out. The update finished and I was able to install World Adventures.

Traelia, the error 16 is often a changed .ini file.

Thanks for the suggestions! I'm going to check my drivers now.

-----------------------------------

EDIT: I feel like an idiot. Turns out there were 2 more updates online. One for the base game and one for World Adventures. It is supposed to fix Error 16 during saves also. I usually bypass the launcher, so I hadn't noticed until just now. I'm starting the game, and I'll report back on how it goes.
Top Secret Researcher
DELETED POST
20th Nov 2009 at 12:23 PM
This message has been deleted by callistra. Reason: please don't hijack other threads. If you would like help please follow the advice previously given and make your own thread
Test Subject
#7 Old 21st Nov 2009 at 5:25 PM
I had the same problem...Delete your mods folder and resource.cfg , only the sims3pack custom content works with world adventures without any side effects :/
Test Subject
#8 Old 21st Nov 2009 at 5:40 PM
new solution...havent tried it yett:

"Before World Adventures, the Mods folder and file Resource.cfg were placed in the following directory:
C/ProgramFiles/ElectronicArts/TheSims3 or go to the directory you installed to your game.
WA When installed it created a new folder under:
C/Programfiles/ElectronicArts/TheSims3WorldAdventures.
This is where you need to move your Mods folder and file Resource.cfg. to C/ProgramFiles/ElectronicArts/TheSims3WorldAdventures
You can move the Mods folder and Resource.cfg by right-clicking, selecting Cut, then Paste into the appropriate directory.
SimGuru_BGY_11"
Test Subject
Original Poster
#9 Old 21st Nov 2009 at 8:36 PM
Default UPDATE on Slow, Slow, Slow
"Real Life" interrupted my working this problem yesterday. I still need to install the latest drivers, and thin out my downloads folder...

Does Delphy's Sims 2 Download Organizer work with the Sims 3 packages?

After the last two updates, the game was improved - temporarily. With a new problem: I couldn't get the FREE Explorer's items to download from the official site and show up in the launcher... Though the "site" thinks it worked. I'm not asking for help with this.

I'm also going to try Rzaashaa's suggestion about moving the Mods folder. Wish me luck! I'll report back with my results.
Lab Assistant
#10 Old 21st Nov 2009 at 10:29 PM
Didn't work for me, still laggilicious.
Test Subject
Original Poster
#11 Old 22nd Nov 2009 at 4:29 AM
I updated my graphics driver. Then I removed the Mods folder to my Desktop. Next, I started adding back files (I really wish I knew what some of them were) and putting them in the WA location. And I moved the resource.cfg file too.

At the moment I have 970 files (985 megabytes). Most of it is now divided into the four sub-folders. But there are about 309 packages in the root of Mods/Packages.

The game is very much improved, and I'm able to play for the first time since the problem started.

I appreciate all of your help and suggestions. If someone knows a way to organize my files that don't have descriptive filenames, please let me know.
Test Subject
#12 Old 22nd Nov 2009 at 12:57 PM
ok...after messing around with the mods folder...here is the final solution

any hack will slow down or crash your game : Hack=stuff that mod the way the game works eg:indiestone etc

only items that do work are hair and clothes

only if you put them in your world adventures folder
Test Subject
Original Poster
#13 Old 23rd Nov 2009 at 4:30 AM
I removed what I believe to be the only hack I had: the Camera hack. I changed the .ini file to it's original state.

Last night, I opened the saved game I made when I first got World Adventures and played for a long time with only a few lags. I had my sim take a trip to China, and noticed the lag was more pronounced.

I guess I have too many files (still). But, I find it strange that it worked perfectly before I got World Adventures (and the corresponding updates/patches).

It seems EA wants us to quit making custom items. They underestimate the modding community, and our need for control and variety, not to mention QUALITY. As far as I'm concerned, EA's fashion and design sense is non-existent.

I thank you all for your help! I'll continue to monitor the help forums for new information.

I guess you can lock this thread now.

Dara, aka Darsky, aka Lolacat
Lab Assistant
#14 Old 23rd Nov 2009 at 10:28 PM
OMG I have over 1600 downloads and that's not icluding the sims3.packs!!!
No wonder my game is slow too!!!
Now I think I'm going to need 10 litres of coffee and some headache tablets to start the task of filtering down my mods/packages folder!!!
shiny!
staff: retired moderator
#15 Old 24th Nov 2009 at 12:12 AM
Hopefully EA will release a patch. TS2's way of handling CC was poorly done but it looks like EA really topped themselves this time.

I'll lock for now then. Let me know if you need it opened before it goes to archive.
Closed Thread
Back to top

Section jump