Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 25 (Who?), Viewed: 24572 times.
Page 1 of 2
Test Subject
Original Poster
#1 Old 21st Nov 2009 at 6:27 AM
Default Flame Fruit in Pyramid of Burning Sands?
I have fully explored the Pyramid of the Burning Sands... can anyone throw me a screen shot or a good description of where the Flame Fruit are supposed to be?
Advertisement
Test Subject
#2 Old 21st Nov 2009 at 6:48 AM
It's down one level from where you start. One area has three plants right against the staircase. The other area (it has the most flame fruits as well) is accessed by exploring the dive well, which is after you find the first three. Here's two screenshots for you.

http://i53.photobucket.com/albums/g...reenshot-26.jpg
http://i53.photobucket.com/albums/g...reenshot-27.jpg
Test Subject
Original Poster
#3 Old 21st Nov 2009 at 6:51 AM
Thank you so much! Now I get to see if I have some sort of bug, or I'm crazy... I'll report back.
Test Subject
Original Poster
#4 Old 21st Nov 2009 at 6:53 AM
Yeah, I have something wrong with my game... the room with all the fiery sphinxes has nothing in in the middle of the room... rocks, but no fire fruit... I guess I'll have to grow some of my own.
Test Subject
Original Poster
#5 Old 21st Nov 2009 at 6:54 AM
Thank you again by the way!
Field Researcher
#6 Old 21st Nov 2009 at 3:24 PM
Rose, You're not the only one. There are no plants in my game either. Because I just checked again after seeing the screenshots and there is nothing there. I have no mods at all in my game, so that's not the problem.
Test Subject
Original Poster
#7 Old 21st Nov 2009 at 10:58 PM
Neither do I... I wish EA shipped stuff with less glitches. My boyfriend and I got Dragon Age for XBOX a few weeks ago and we have noticed some very irritating glitches too... I miss Maxis.
Forum Resident
#8 Old 21st Nov 2009 at 11:12 PM
Hmmm I did this adventure earlier too. But I never saw any plants. I remember unlocking a door and then the game told me I'd found them. Maybe because I had flame fruits in my inventory already (my sim is a gardener) but I'm not sure.
Test Subject
#9 Old 22nd Nov 2009 at 5:34 AM
Yeah, everyone is having problems with the flame fruit. I know when I first found it, the ones by the stairs disappeared after I took a picture of it, but they showed back up the next sim day.
Alchemist
#10 Old 22nd Nov 2009 at 5:47 AM
maybe their like other plants in game and have to grow to be there?
im not sure.
Field Researcher
#11 Old 22nd Nov 2009 at 8:16 AM
I got the game today, went against my better judgment, but I am actually enjoying it....

anyway my first trip was to Egypt, and right at the end of my sim's first visit I had this task. I was only able to get into the door before my sim's time was up, so he went home. I was annoyed by the fact he had to go home and shift clicked away the moodlet for the adventure, so he could go back. :P

I had no problem at all getting the flame fruit, my sim was able to collect more than was required, and had enough in his inventory to eat later, it came in handy, cause he kept autonomously eating the dried food that I made him buy, even tho he wasn't hungry.

I have no hacks or CC aside from some store carp, but have in the past used Awesomemod and NRaas Story Progression on this save game file, I took them out before install and have not had a problem ....... yet .... knocks on wood........

Not sure if him leaving and then going back had anything to do with the availability of Flame Fruit or not, will try again, in a new hood.
Test Subject
#12 Old 22nd Nov 2009 at 7:01 PM
The same thig happened in my game, but I don't have any cc aside from a few hair and clothes. So, yeah, I have no idea why it does that.

Anyway, what I did is:
-explored the tomb until I got the fully explored message
-went to edit town and choose a nearby fishing spot
-used the buydebug cheat and put some flame fruit there
-had my sim go pick it.

So, I suggest doing that until someone is able to figure out why flame fruits appear in only some people's games.
Test Subject
#13 Old 22nd Nov 2009 at 10:06 PM
im having the same problem what region are you guys in? If it is a glitch in the game it my only be affecting one region thus explaining why some people are having problems and not others. im playing in region 2
Banned
#14 Old 23rd Nov 2009 at 3:08 AM
Do this... get soaked in the well and walk near the plant. Wait a bit and there will be new fruit growing... that's what happened with mine...
Test Subject
#15 Old 23rd Nov 2009 at 5:48 AM
I had the "fruithack" mod and the buy all fish mod. Once I deleted them things started working again for me. (Fruit plants showed back up, fish able to be caught again and able to buy fruit, veggies and meat from the market.)
Instructor
#16 Old 23rd Nov 2009 at 6:34 AM
I was reading on another forum that Rick's "no-mosaic" is causing problems with effect and items not appearing in WA. Crazy Town has a version that works with WA.
Lab Assistant
#17 Old 23rd Nov 2009 at 7:00 AM
Prior to installing WA, I had both Awesome Mod and Indie Stone. Now, I'm running a fresh hood created post-WA. I have recently re-installed a ton of my cc, but the only mods I've tried to put in are chaavik's more fun mods.

While all of this makes me an excellent candidate for game glitches, I was able to harvest the flame fruits without any problems. The only (minor) issue I encountered was the fact that one of the flame fruit plants was dead and could not be harvested. The tomb contained plenty of fruits, though, so I had no problem harvesting the requisite amount. I even had several fruits to spare!

I think the "problem" is just that the fruits are acting like any other wild plants that you find in the game. Because there's no active gardener on a community lot, the plants' maturity stages are variable and probably set at random. That might explain why the fruits showed up for charmed14; the game reset the plants on the next sim day.
Test Subject
#18 Old 23rd Nov 2009 at 2:58 PM
Its not just in the tomb i'm having the problem havestable plants are not showing up anywhere in my game. Anyone else having this problem? I don't have any CC btw.
Test Subject
#19 Old 24th Nov 2009 at 5:34 AM
i'm having the same problem imamum. i sent a question into ea on the sims site 4 days ago and haven't heard anything back from them.
Test Subject
#20 Old 25th Nov 2009 at 12:00 AM
Wow, I'm experiencing this as well! I thought it was because I needed that axe to chop down the rocks, because ther were no plants..I just gave up!

Sims 3 story is here http://petalpaths.wordpress.com
Test Subject
#21 Old 25th Nov 2009 at 12:41 AM
Hmm, weird. They show up in two places (so far) in that tomb for me. Early on (maybe a room or two in), there are two right beneath a staircase and then much further in, there is a whole garden of them (I'd guess probably 10 or 12 plants all clustered together). I didn't get to finish the rest of that tomb past that point as my vacation was going to end and I had to race back to turn in the fruit.
Test Subject
Original Poster
#22 Old 25th Nov 2009 at 5:08 AM
I have no hacks or mods, just hair, outfits and patterns.... but no fruit, no plants... just empty space where they should be.
Instructor
#23 Old 25th Nov 2009 at 6:41 AM
Believe it or not RandomRose, people are discovering that hair, clothes and patterns can and have been affecting WA is very strange ways. As a test you might want to cut/paste your mods folder to another location outside of your game and see if you get the plants back.
Test Subject
#24 Old 26th Nov 2009 at 7:15 PM
sadielee9 i emailed ea aswell they still haven't replied 5 days later i have unistalled all CC including hair and clothes and reinstalled the game still no flame fruits
Test Subject
#25 Old 20th Aug 2012 at 7:07 PM
IT'S NOT A GLITCH!! I know this is an old thread but I noticed it's been viewed over 13,000 times.

IT'S SIMPLE, you went the wrong way!! When you enter the pyramid of burning sands it's natural for most of us to keep straight ahead and explore the open room then head down the stairs where the pool and big boulder is, I've been through there and was almost beaten to death in my first mummy encounter, anyhow after that you find a door leading out and it says you've completed your quest but alas....No flame fruit.

THE SOLUTION. When you first enter the pyramid there is a door on the right (Yeah I know you missed it the first time but it's a huge pyramid). That's where you should be heading, I won't add any spoilers here but I'm sure you'll find more than enough flame fruit if you head that way.

Stop blaming EA for everything

Cheers
Page 1 of 2
Back to top

Section jump