Replies: 11 (Who?), Viewed: 14879 times.
Field Researcher
Original Poster
#1 Old 12th Feb 2010 at 12:16 PM
Default Export a world-installing-not showing up-help!
Hi!

I'm having a problem that's driving me nuts!!

I've already successfully installed an exported world into my game and played with it.

I now wanted to export another one into the game and play with that one... except it isn't showing up! I export it and that's OK... I install it and that's OK... I can even see the .world file in the imported worlds folder, but when I play and go to choose a new world, it isn't there...

can anyone shed any light on this problem for me please?

thanks!

~ Nyn ~
Advertisement
Field Researcher
Original Poster
#2 Old 13th Feb 2010 at 1:50 PM
well after spending hours searching goodness knows how many sites I found what the problem was.

Basically I was trying to install an updated world of a world that I had already installed in my game. Even though I had taken the older version out, there were still traces of it, and I had to completely wipe out all traces of it's presense before I could install the newer version - even though the new version had a totally different name/description/photo...

So that's how to fix that problem in case anyone else runs into this problem!

~ Nyn ~
Instructor
#3 Old 14th Feb 2010 at 9:40 AM
Thank you for posting how to fix this problem. I have numerous versions of a world I am working on and only one has been place in game and uninstalled. I need to go through my files before I have the same headache.
Lab Assistant
#4 Old 9th Mar 2010 at 6:39 PM
Can you please tell me where the 'traces' are? Because I can't uninstall it with the Launcher. The installed filed don't load and the Launcher freezes.

I'd like to remove them manually.
Theorist
#5 Old 9th Mar 2010 at 6:58 PM
Earthgirl, the only way to manually uninstall all parts of a world is to delete all of the files, then delete the DCCache stuff. This means that anything you have installed via the launcher will need reinstalled. As far as I know, the launcher is the only thing that can deactivate the part of the world file that's installed to the DCCache stuff. And did you ever notice how the dcdb0.ebc file just gets bigger and bigger and never shrinks, even after uninstalling stuff? That's because the launcher doesn't really remove the stuff from that file, but just disables it.

Find your Installed Worlds directory in the My Documents section of your TS3 game. Delete the .world file.
Check both Exports and Downloads and delete that world's Sims3Pack file.
If there are saves of that world delete them as well.
Now get rid of the DCCache directory and its contents.
Lab Assistant
#6 Old 9th Mar 2010 at 7:21 PM
Well, this is the problem: it doesn't show up in the 'Installed worlds' folder. I tried to copy it manually from the CAW folder ans still won't show up in the game.

Renamed everything - title, layer, description, but it still shows it up as being the same file. I'm tired of this.

So, the conclusion is: take the DCcache folder out, install the world and then put it back in and this might work? I'll try it.
Theorist
#7 Old 10th Mar 2010 at 1:50 AM
What you copy manually from the Create A World files isn't the same as what the launcher installs, so as you found that isn't going to work.

Yes. Try taking out your current DCCache directory, export your world again through C-A-W, then find the file in Exports and double-click it for installing. Once you've double-clicked it the launcher will open and automatically install.
Scholar
#8 Old 15th Mar 2010 at 1:00 AM
You know, if you are exporting a world for a second time, don't just rename it in the save as, go into add/edit description from your layers pallet and change the name there. This is what's causing this for everyone, although you rename the world when you save it, it still has the same internal name and the launcher usually says it's already installed. I have 5 versions of one world installed right now but they all have different internal names, even if it's blah1 and blah2 they will all install even though they are the same. I did it to compare different layouts, etc.
Test Subject
#9 Old 5th Apr 2010 at 2:15 PM
Default Heeeeeeeeeeeelp!
Hi guys i am having the same problems,

ive once previously managed to install a created world but now after deleting all traces of that one and deleting the traces of a previous version of my current world it still wont install after exporting :/ ive changes the save as name, the add/edit description name, and deleted the traces and it will not appear in my installed worlds folder or launcher :/ im at a loss as to what to do so any of your help would be greatly appreciated

thanks very much

hannah x
Scholar
#10 Old 5th Apr 2010 at 4:09 PM
Make sure you have removed the save game for the old world, in saves folder, installed worlds folder, etc, etc, just look everywhere in my documents electronic arts and remove all mention of that world, in downloads too there will be a copy of it and you might install the wrong one again. Delete the world cahches for that world and If all else fails delete the contents of your dc cache and dc backup, I've had to do that a couple of times and you then need to open the laucher to reinstall all your cc again.

Hope this helps, it is a pain when it happens
Test Subject
#11 Old 21st Oct 2013 at 3:11 AM Last edited by MarleUral : 21st Oct 2013 at 2:41 PM.
Hi,
I'm having the same issue and I'm trying to resolve it.
So I should go into DCCache and DCBackup and delete everything that is in the folder?
I've manually deleted my world from InstalledWorlds and Downloads

Edit: Clearing my DCBackup and DCCache didn't work
Test Subject
#12 Old 15th Jul 2015 at 9:27 PM
I found a final solution to this problem...
- I deleted *everything* in the folders: DCcache, DCbackup, Downloads, Exports, Installedworlds.
- I deleted all cache files - IGACache, SigsCache, CASpartcache, scriptCache, simscopositorcache, socialCache.

THEN I went back to CAW, exported my world. I then went to the Exports folder, and moved my .sims3install file for my world into Downloads. Then I installed the world with installer. It shows up in InstalledWorlds, I open my game, now it is on the menu for worlds to play.

Basically deleting all cache files and all files in those folders, solved my issue...

It could just be that you need to move the sims3 custom content file for your world from Exports to Downloads, then install it... But I deleted those files for good measure. The game works fine with my new caw world now....
Back to top