Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Cutest Little PlumBob MTS Baby/Toddler Photo Contest for Sims 2, 3, and 4 - posted on 2nd Oct 2018 at 5:07 AM
Replies: 72 (Who?), Viewed: 81111 times.
Page 2 of 3
Field Researcher
Original Poster
#26 Old 24th Jan 2011 at 7:03 PM
Quote:
Originally Posted by AAshleySEG
I was wondering if we have EPs installed, would we try the same route just instead of in The Sims 3 GameplayData.package, would we use the package in the respective Expansion folders. Such as The Sims 3 Late Night GameplayData.package? I know up towards the top it says everything hasn't been fully tested for EPs, I thought I would try on my own, but was wondering if I was thinking in the right direction or can something like this only be changed in the original game's package file? Thanks
___________________________________________________________
I tried the above technique and this is what happened. When you click Change Channels on the TV, the channel name was blank but an extra one did appear. Then, when I clicked on that the TV turned off automatically. So I'm guessing that isn't going to work? There may also be some tweaky things that need to be done but I have no idea what those would be as I am not as familiar with all of these things as you all are. So I guess for now I am going to be on hold with this until there is some new info available. Thanks for all of your hard work as well as everyone that helped on this project.


No, the Gameplay package that you use should not matter, as long as your game is up to date. I use the base game Gameplay Data file.

Your problem with the TV might not be it turning off, I think that your video file is not being played correctly. Have you made sure to make a unique ID for it, and also imported the correct vp6 file?
Test Subject
#27 Old 6th Mar 2011 at 7:42 AM
How is the game supposed to know where my TvChannel.package is? If I put it in a random directory, how does it know where it is?

This is probably why the channel doesn't appear in the pie menu?
Test Subject
#28 Old 12th Mar 2011 at 12:05 PM Last edited by Doczott : 13th Mar 2011 at 7:03 AM.
The package should go into "My Documents\Electronic Arts\The Sims 3\Mods\Packages" directory. That is where the game should look for packages.

My problem is my video doesn't loop. It plays through fine but just freezes at the end. If I change channels and come back it plays from the beginning. But then it still won't loop.

Edit: I assumed that this was due to me having only 1 video for the mod. I made 2 more and inserted them into the package. It still locks at the end of the first. I also notice that it is showing the color clip on a BW TV.
Test Subject
#29 Old 15th Mar 2011 at 10:32 AM
I made a mods/packages directory, still no luck.
Test Subject
#30 Old 16th Mar 2011 at 2:42 AM
Test Subject
#31 Old 16th Mar 2011 at 9:16 AM
Thanks so much!

The video and audio works now, but I get a similar problem, my video won't loop. I get a black screen at the end.
Test Subject
#32 Old 17th Mar 2011 at 1:30 AM
Have you tried this converter?

http://files.planetcnc.ru/sg/video/VP6_Builder.rar

Use it instead of the one included in Odistant's download and you should get a looping video.
Test Subject
#33 Old 13th May 2011 at 8:58 PM
Okay I'm a little confused on this portion:

We can now insert our .vp6 file. With S3PE open, also open up the Snaitf's FNV Hash Generator. Now, go under "Resource>Import>From File" in S3PE. For type, select "_VID 0xB1CC1AF6". For group put in "0x00000000". With the Hash Generator, insert the name of your video file. Copy and paste one of the FNV64 codes into the Instance section. Your S3PE should not show EPFlags unless you’re using a later version, if you are use 0x00.

What file are we importing? I think that should be made much clearer and also when I attempt to put in the FNV64 coding that Snaitf's FNV Generator gives me for the instance in S3PE, I can no longer add the resource. Help?
Field Researcher
Original Poster
#34 Old 13th May 2011 at 10:24 PM
Quote:
Originally Posted by angsaysrawrr
Okay I'm a little confused on this portion:

We can now insert our .vp6 file. With S3PE open, also open up the Snaitf's FNV Hash Generator. Now, go under "Resource>Import>From File" in S3PE. For type, select "_VID 0xB1CC1AF6". For group put in "0x00000000". With the Hash Generator, insert the name of your video file. Copy and paste one of the FNV64 codes into the Instance section. Your S3PE should not show EPFlags unless you’re using a later version, if you are use 0x00.

What file are we importing? I think that should be made much clearer and also when I attempt to put in the FNV64 coding that Snaitf's FNV Generator gives me for the instance in S3PE, I can no longer add the resource. Help?


Working on a updated version as we speak. Had a bit of technical difficulties with my Win 7 installation

The file you're importing is the .vp6 you had created. Once you made the resource, right click on it and select Import from file and choose the .vp6 file.

Since this guide was made with an outdated version of S3PE, you no longer need to use Snatifs FNV Generator. Just use the FNV64 button on the resource edit screen. You'll need to select the check box that says "Resource Name" and give the resource a name and the select the FNV64 button next to it to the right and it will give you a Instance ID.

Because of how long ago the original version of this guide was made, I'll be completly redoing the whole thing and make it less confusing. I'll also go over the full process of resizing through Windows Movie Maker and VirtualDub if you don't have WMM. Expect it to come out at least next week. I'll also have to redo the whole wiki page too for the tutorial, but I'll do the PDF first.

Also, I'm sure you're going to get a blank pie menu. To fix that just use:
Code:
Gameplay/Excel/TV/TVChannel:OdistantTest <--- Change odistant test to whatever your channel name is in the .XML file.


Good luck and please do post your results. Will help me in improving the tutorial.
Test Subject
#35 Old 13th May 2011 at 10:43 PM
Quote:
Originally Posted by Odistant
Working on a updated version as we speak. Had a bit of technical difficulties with my Win 7 installation

The file you're importing is the .vp6 you had created. Once you made the resource, right click on it and select Import from file and choose the .vp6 file.

Since this guide was made with an outdated version of S3PE, you no longer need to use Snatifs FNV Generator. Just use the FNV64 button on the resource edit screen. You'll need to select the check box that says "Resource Name" and give the resource a name and the select the FNV64 button next to it to the right and it will give you a Instance ID.

Because of how long ago the original version of this guide was made, I'll be completly redoing the whole thing and make it less confusing. I'll also go over the full process of resizing through Windows Movie Maker and VirtualDub if you don't have WMM. Expect it to come out at least next week. I'll also have to redo the whole wiki page too for the tutorial, but I'll do the PDF first.

Also, I'm sure you're going to get a blank pie menu. To fix that just use:
Code:
Gameplay/Excel/TV/TVChannel:OdistantTest <--- Change odistant test to whatever your channel name is in the .XML file.


Good luck and please do post your results. Will help me in improving the tutorial.


Thank you! I figured it was because their were updates but I wanted to be sure. Looking forward to the new version.
Test Subject
#36 Old 4th Jul 2011 at 3:38 PM
I have a nasty problem.
When I sit and turn on the tv I can interact with a void bar... there isn't the name but I'm pretty sure it's my channel.

So the channel is created. Problem one... why I can't see its name?

Problem two: the video is black, pure black. You don't see or hear anything.
Probably it isn't correctly loaded!

Please help me, I'm so near to do this!
Test Subject
#37 Old 18th Jul 2011 at 10:23 AM
Thanks a lot!
It's very patient of you to write this tutorial!
whether I success to patch or not, I'm still grateful~
Test Subject
#38 Old 18th Jul 2011 at 12:36 PM
I can't find GUI.exe???
Plz tell me where I was wrong??
Lab Assistant
#39 Old 2nd Sep 2011 at 6:54 AM
I might need help.
When I go to convert the video with VirtualDub I can't find the VP6 compressor. I already installed the codec and everything, but I don't know what to do.

BRAINSTRIP | The media lab.
Field Researcher
Original Poster
#40 Old 2nd Sep 2011 at 11:23 PM
That's the thing with VirtualDub. I had the same exact issue as you. Did you try the cole2k codec pack? You can uncheck the things you don't need in the installer. Using that was the only way I could get it to show up. You might need to reboot too Also, use the newer tools for compressing the video into .vp6 since the ones that I included are outdated. Readme file gives links to where you can find them.
Lab Assistant
#41 Old 3rd Sep 2011 at 5:11 AM
^No, I didn't. I'll try that right now and see if it works. :P
Thank you! Awesome tutorial btw! Should have said that earlier.

BRAINSTRIP | The media lab.
Lab Assistant
#42 Old 26th Nov 2011 at 1:30 PM
Great tutorial! Thank you!

I created my own TV channel and everything is working fine except for the STBL. When I send a sim to watch TV and then click "Change to...", the new TV channel option will appear empty. Even though it is working it does not display the TV channel name I specified on the STBL.

Could it be because I have the game in the Portuguese version, and I should specifiy an STBL for Portuguese??
Field Researcher
#43 Old 3rd Feb 2012 at 1:26 PM
Sorry for the bump, but the same went for my case. Can you clarify that part for me? Also, the FMV files don't loop at all and end with a blank screen. Do I have to use the Cole codec pack instead of On2's official codec?
Field Researcher
Original Poster
#44 Old 4th Feb 2012 at 6:28 PM
What part is it that you're having trouble on exactly? The codec pack doesn't really matter, as long as it shows in virtualdub, then your good to go. How long is the video file you're trying to use?

Also, the string paths for the TV most likely changed, so use ScriptError and see what the new string path is. You'll be using ScriptError to view the string path which Sims 3 will read from. They removed words and changed it to nothing at all if a string couldn't be found some time ago. Twallan brought it back with that mod which is very helpful when scripting. (I'm assuming this is what you meant when you said you were having the same issue)

And could you post the XML code for your channel that you're using?
Field Researcher
#45 Old 5th Feb 2012 at 4:06 AM
Quote:
Originally Posted by Odistant
What part is it that you're having trouble on exactly? The codec pack doesn't really matter, as long as it shows in virtualdub, then your good to go. How long is the video file you're trying to use?

Also, the string paths for the TV most likely changed, so use ScriptError and see what the new string path is. You'll be using ScriptError to view the string path which Sims 3 will read from. They removed words and changed it to nothing at all if a string couldn't be found some time ago. Twallan brought it back with that mod which is very helpful when scripting. (I'm assuming this is what you meant when you said you were having the same issue)

And could you post the XML code for your channel that you're using?


The video's a 28-second clip based off this:
http://www.youtube.com/watch?v=tKwWm2aYNsk

And here's the XML code for the channel:
Code:
<TVChannel>
<Channel_Name>FegelStation</Channel_Name>
<Channel_Level>Level1</Channel_Level>
<Video_File_Names>Sims3TV_DerUntergang</Video_File_Names>
<Associated_Traits></Associated_Traits>
<Effect_On_Skill></Effect_On_Skill>
<Sync_Event_Name></Sync_Event_Name>
<Buff_Prereq></Buff_Prereq>
<Target_Buff></Target_Buff>
</TVChannel>


The converted clip does sync fine ingame, though.
Field Researcher
Original Poster
#46 Old 5th Feb 2012 at 4:32 PM
In Assocaited_Traits, Effect_On_Skill, Sync_Event_Name, Buff_Prereq, and Target_Buff, insert a "-" without the quotations. That could be the problem because in the script the games checking if there is no "-", and if there isn't then to try and run those events.


Try that and tell me if that works.
Field Researcher
#47 Old 6th Feb 2012 at 2:30 AM
I can't find the ScriptError mod, and I doubt that it'll work with my 1.29 install.
Field Researcher
Original Poster
#48 Old 6th Feb 2012 at 11:53 PM
It's called ErrorTrap. It's been so long since I modded for TS3, I'm starting to forget things

Patch Level: 1.29, so you're in luck!

http://nraas.wikispaces.com/ErrorTrap
Field Researcher
#49 Old 7th Feb 2012 at 12:43 AM Last edited by blakegriplingph : 12th Feb 2012 at 12:01 PM.
I actually have that mod already, but it didn't pick up the missing string.

EDIT: NVM, I just figured out that in order for the text to appear ingame, you'll need to change the resource name to "Strings_ENG_US_0x000f16b00ba8342f" (or whatever language file you're using), or else it will still display as a blank menu item.

EDIT 2: The one Vondure suggested works better than the VP6 Builder tool included in the tutorial file. Tried re-encoding my Downfall parodies using that tool and it now loops! :D
Test Subject
#50 Old 22nd Mar 2012 at 6:56 PM
Default It crashes on my win7 64bit
Quote:
Originally Posted by Vondure
Have you tried this converter?

http://files.planetcnc.ru/sg/video/VP6_Builder.rar

Use it instead of the one included in Odistant's download and you should get a looping video.


Is there a workaround for it, or newer version?
Get everything working from 1 minute video with sound to 10 minute video with sound, but none loop (used " -fps"30" -loops"-1" -loope"-1 to encode audio).
Please advise.
Page 2 of 3
Back to top