Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 233 (Who?), Viewed: 98430 times.
Page 2 of 10
Test Subject
#26 Old 16th Jul 2010 at 1:54 AM
Worked like a charm so far, now let's see what they look like in-game!
Field Researcher
#27 Old 16th Jul 2010 at 4:47 AM
Quote:
Originally Posted by Elinenger
I figured it out, I don't now what, but obviously I did something wrong... I've got the tattoo in the game now, but can't get into the "Advanced mode" (If that's what it's called in english?) for the tattoo I made. Can't change scale or opacity... What am I doing wrong this time? x)


Iīve made some tests just before posting and what you described happens when the red, green and blue channels are not enabled whether your tattoo uses those colors or not; even if the alpha channel is enabled, you canīt go into the advanced mode and once you clicked on the buggy tattoo, base game or functional custom tattoos canīt get into advanced mode either; functionality returns to normal if you leave the tattoo table then enters it again.
By the looks of it, the safest scenario is to always enable the red channel even if your image only uses the alpha (white over black, usually for outlines) and alpha itself is not enabled in Tattooinator.
Hope it helps.
Ms. Byte
Original Poster
#28 Old 16th Jul 2010 at 1:51 PM
Thanks for a very useful observation, Marcos!
Lab Assistant
#29 Old 17th Jul 2010 at 1:21 AM
maybe someone can do a photoshop tutorial for it, as i don't use gimp and in photoshop i can't bring it to work out with this tutorial, i get stuck at the alpha thing and the mask thing it is just a creep...

They tell us everything's alright and we just go along;
How can we fall asleep at night when something's clearly wrong?
When we can feed a starving world with what we throw away;
But all we serve are empty words that always tastes the same...


Nickelback - When We Stand Together
Lab Assistant
#30 Old 18th Jul 2010 at 7:53 PM
I tried making a tattoo with Paint.net but ran into an issue with the alpha channel. Since paint.net doesn't have a channel feature on the layers, I kept the outline of the image black and made the background the pinkish color and this is what I got:


this is what the tattoo is supposed to look like when it's done:


"It's a long, long way to Ba Sing Se..."
I'm so starstruck, Baby could you blow my heart up?
Mamma Mia! Here we go again! My my, how can I resist you?

Avatard, Monster, Zutarian, Twihard, and PROUD of it!
Call me Jacky, I take requests, even though I don't have anything uploaded yet. :P
Test Subject
#31 Old 19th Jul 2010 at 10:09 AM
Thanks for the tutorial; a very interesting read. I'm going to be another who gives it a go with photoshop, so we'll see how that goes with the reported issues with alpha channels.

As this seems to use RGB values as customisable colours, I'm curious as to if you can blend between colours by creating a gradient between say, red and green. For example, could painting like this:



Produce something to this effect?




Either way, I'll be testing that out myself in a bit. If it works I've got some stuff I'd love to try.
Ms. Byte
Original Poster
#32 Old 19th Jul 2010 at 12:06 PM
JackyFletcher: Your problem is probably the lack of an editable alpha channel. This seems to produce either an invisible tattoo or one that's solid black, maybe depending on how the graphics program being used encodes or omits the alpha data.

NummyBiskit: I experimented very briefly with blended colors, and found that if the color intensities are roughly equal green will override red and blue will override green and red. They're layered on top of each other and appear to weighted by intensity. In other words, if you try to do purple you'll get blue with a tinge of purple, etc. You could experiment and maybe get something usable.
Test Subject
#33 Old 19th Jul 2010 at 12:32 PM
Got both of these working. :D
Blending with RGB proved usable and working just fine, but as you said, a little iffy. I found that I had to leave a decent amount of the base colours at either end of the gradient to get what I was looking for.

For Photoshop Users:
We handle alpha channeling a little differently, and view it as a seperate layer. To manipulate the alpha layer in photoshop, first click on the 'Channels' tab above your layer.




This should show you your individual Red, Blue, and Green channels, as well as one channel to show you the collective RGB values. At the bottom of the window, click on the 'Create new Channel' button. It looks like a page corner.




This should give you your alpha channel under your red, blue, and green channels. It should be completely black by default. This is where you copy and paste your original black and white image.




You then invert it like in the original tutorial to make the lines white and the rest black. In Photoshop this is found under Image > Adjustments > Invert.




You won't need to apply the alpha layer, as you did that when you added the alpha layer to the layer list. So you won't be seeing the applied alpha layer in your image like in the original tutorial:




However, give heart and work onwards. It's worked just fine for me both in the Tattooinator, and in-game.





Lab Assistant
#34 Old 19th Jul 2010 at 4:06 PM
Thanks for the help!

"It's a long, long way to Ba Sing Se..."
I'm so starstruck, Baby could you blow my heart up?
Mamma Mia! Here we go again! My my, how can I resist you?

Avatard, Monster, Zutarian, Twihard, and PROUD of it!
Call me Jacky, I take requests, even though I don't have anything uploaded yet. :P
Lab Assistant
#35 Old 19th Jul 2010 at 8:22 PM
If I unselect R, G, B, and A, (essentially making the tattoo un-CAStable), couldn't I use as many colors as a I want?
If so, then I'm having a problem elsewhere.

Can you (or anyone with photoshop who's gotten this working) post a screen-grab of the settings you used to save the .DDS? When you said "check off", I don't know if that means make sure the check is off, or the check it on. >_<
Ms. Byte
Original Poster
#36 Old 19th Jul 2010 at 9:43 PM
Quote:
Originally Posted by SkankBenSkank
If I unselect R, G, B, and A, (essentially making the tattoo un-CAStable), couldn't I use as many colors as a I want?
If so, then I'm having a problem elsewhere.

Can you (or anyone with photoshop who's gotten this working) post a screen-grab of the settings you used to save the .DDS? When you said "check off", I don't know if that means make sure the check is off, or the check it on. >_<


If you look a few posts up you'll see what happens if you disable all the channels - the advanced settings in CAS stop working.

Plus, disabling the channels has no effect on how the colors look in-game. Doing blended colors is possible but tricky.

Settings: Load mipmaps should be unchecked when opening an image; Make mipmaps should be checked when saving. Maybe someone else can address the DDS and DXT options in Photoshop.
Lab Assistant
#37 Old 19th Jul 2010 at 11:57 PM Last edited by SkankBenSkank : 20th Jul 2010 at 12:08 AM.
Can someone upload a .dds that uses all 3 color channels & an alpha, that worked, and tell me what profile they saved it under? Because somewhere along the lines, I must be doing something wrong.

EDIT: And I'm not caring about functionality of changing its color. I just want it to look right. It was from a photo, and uses tons of colors. I don't need the ability to change said colors, I just want it to look decent in game, even if it means all colors have to be set to #FFFFFF in the game's color picker.
Field Researcher
#38 Old 20th Jul 2010 at 4:21 AM
I spent some time trying to get a photo to work, without avail. I honestly think that given the way tattoos deal with colors, the result will always look like a negative image or something Andy Warhol did...
Ms. Byte
Original Poster
#39 Old 20th Jul 2010 at 7:49 AM
As I said in the last section of the tutorial, a photo with lots of colors just isn't going to work. While it's theoretically possible to fiddle the colors, in practice I don't think you'd ever get it looking right. When I tried I also got the negative image effect that Marcos Edson mentions.
Test Subject
DELETED POST
20th Jul 2010 at 12:15 PM
This message has been deleted by kepazza.
Test Subject
#40 Old 20th Jul 2010 at 12:19 PM
Quote:
Originally Posted by NummyBiskit
Got both of these working. :D
Blending with RGB proved usable and working just fine, but as you said, a little iffy. I found that I had to leave a decent amount of the base colours at either end of the gradient to get what I was looking for.

For Photoshop Users:
We handle alpha channeling a little differently, and view it as a seperate layer. To manipulate the alpha layer in photoshop, first click on the 'Channels' tab above your layer.


This should show you your individual Red, Blue, and Green channels, as well as one channel to show you the collective RGB values. At the bottom of the window, click on the 'Create new Channel' button. It looks like a page corner.


This should give you your alpha channel under your red, blue, and green channels. It should be completely black by default. This is where you copy and paste your original black and white image.


You then invert it like in the original tutorial to make the lines white and the rest black. In Photoshop this is found under Image > Adjustments > Invert.


You won't need to apply the alpha layer, as you did that when you added the alpha layer to the layer list. So you won't be seeing the applied alpha layer in your image like in the original tutorial:


However, give heart and work onwards. It's worked just fine for me both in the Tattooinator, and in-game.




how you save the DDS file in Photoshop (?)
Lab Assistant
#41 Old 20th Jul 2010 at 3:32 PM
Quote:
Originally Posted by kepazza
how you save the DDS file in Photoshop (?)


NVIDIA DDS plugin.
Test Subject
#42 Old 21st Jul 2010 at 6:30 AM
When I come to step 6 the checkerboard doesn't show up. And I've done everything right (I think). Have I missed something?
Ms. Byte
Original Poster
#43 Old 21st Jul 2010 at 11:51 AM
Quote:
Originally Posted by lizzie88
When I come to step 6 the checkerboard doesn't show up. And I've done everything right (I think). Have I missed something?


Make sure you're creating the layer mask from the alpha channel, then if you've got a black background in your layer mask when you apply it you should get the checkerboard.
Test Subject
#44 Old 21st Jul 2010 at 3:54 PM
Quote:
Originally Posted by CmarNYC
Make sure you're creating the layer mask from the alpha channel, then if you've got a black background in your layer mask when you apply it you should get the checkerboard.


My game/gimp is in swedish version which makes it a little harder. Is there a video clip or something with this tutorial?
Ms. Byte
Original Poster
#45 Old 21st Jul 2010 at 4:21 PM
Quote:
Originally Posted by lizzie88
My game/gimp is in swedish version which makes it a little harder. Is there a video clip or something with this tutorial?


Sorry, no video.
Test Subject
#46 Old 21st Jul 2010 at 4:33 PM Last edited by lizzie88 : 23rd Jul 2010 at 9:48 AM.
Quote:
Originally Posted by CmarNYC
Sorry, no video.
I fixed it now, just forgot to have a dds plugin.
Lab Assistant
#47 Old 22nd Jul 2010 at 12:30 PM
I'm having a small issue here: I have enabled red, blue and alpha for being recolorable but in CAS I can only recolor red. Feeling_stupid_please_help ><

She dyes em Black no. 1
Test Subject
#48 Old 24th Jul 2010 at 3:23 AM Last edited by TONKaTruckss : 24th Jul 2010 at 4:10 AM.
I'm having a problem with step 4. When I go to add the alpha channel, the option is grayed out. I don't understand why, considering I followed all of the instructions on the first three steps. :p

EDIT: Just kidding. GIMP had the alpha channel already enabled it. So all I did was disable it, then do the coloring. Worked like a charm! :D
Ms. Byte
Original Poster
#49 Old 24th Jul 2010 at 1:52 PM
Quote:
Originally Posted by Merkaba
I'm having a small issue here: I have enabled red, blue and alpha for being recolorable but in CAS I can only recolor red. Feeling_stupid_please_help ><


I tried and got the same results. Probably you have to enable channels in order (red, green, blue, alpha) and the game stops looking as soon as it finds one disabled - you skipped the green channel so the game stopped enabling them after red.
Lab Assistant
#50 Old 25th Jul 2010 at 11:17 AM
Quote:
Originally Posted by CmarNYC
I tried and got the same results. Probably you have to enable channels in order (red, green, blue, alpha) and the game stops looking as soon as it finds one disabled - you skipped the green channel so the game stopped enabling them after red.


Solved! Thank you very much

She dyes em Black no. 1
Page 2 of 10
Back to top

Section jump