Home | Help | Download | Community | Site Map | New Posts | Sign in
Locked thread | Replies: 1347 (Who?), Viewed: 395153 times. | Locked by: tiggerypum Reason: Outdated, replacement tutorial posted
Page 3 of 54
Test Subject
#51 Old 7th Feb 2005 at 4:25 PM
Couple of questions: Firstly, can you use this to remove vertices? I'm guessing no, but could make things a little easier if I could.

Secondly, How close is close? Does it have to be, for example, on the same joint?

A foggy morning greets me quietly today
I smell a fragrance in the wind blowing my way
And ever further I run to find her
I yearn to define my life
Placing my faith in chance to meet me in half way
Test Subject
#52 Old 7th Feb 2005 at 4:33 PM Last edited by Vinther : 28th Feb 2005 at 8:23 AM.
I've followed the tutorial, and everything seems to work except the model shows up in Body Shop like the infamous "exploding mesh". I'm attaching the original GMDC from the MESH package and the modified .OBJ here, so that you (Miche) can take a look and see what's wrong.

Thanks in advance
Vinther
Field Researcher
#53 Old 7th Feb 2005 at 5:23 PM
Thanks for the tutorial... I followed it exactly - editing the same gown to try it out, and when I load up bodyshop to look at my mesh, it freezes up on me when I get to where it should be showing up. Do you know what might be causing this?
Test Subject
#54 Old 7th Feb 2005 at 9:06 PM
Thanks so much, Brianna (and Miche)! Body mesh mods are what I've been looking forward to doing and I'm working through the tutorial right now.

I've hit a spot someone else mentioned and before I continue I thought I would point it out before I stumble on through the rest of the tut. That is,

"25. Delete the shape and resource node from the package."

It looks like we're being instructed to delete the node and shape added in "21." and moved in "23." I'll go ahead and do it but it doesn't make a lot of sense to me since there will no longer be any shape or node in the package once I've done "Step 25".

Since others are making headway and since I reckon I'm about to find out if this is, in fact, what I'm supposed to be doing anyway I guess I'm simply pointing out that a note of clarification might be in order for Step 25.

Again, thank you tons!

Weji
(old fan of WDS)
Lab Assistant
Original Poster
#55 Old 7th Feb 2005 at 10:00 PM Last edited by WDS BriAnna : 7th Feb 2005 at 10:05 PM.
It's remove the ones from step 19 -- delete the ones from the packed files window. (They were added just so you could do 21). Adding them, pointing at them, and then removing them is just a way not to need to write them down from the MESH_ package and type them into the bodyshop package manually.

I'll edit and clarify. Thanks.

BriAnna
Test Subject
#56 Old 7th Feb 2005 at 11:46 PM
I can't thank you enough. Much to my astonishment, it all worked on first run as advertised. You're simply the best! <hug>
Field Researcher
#57 Old 8th Feb 2005 at 2:17 AM
help me please
Hi... I'm hoping someone here can help me out. I followed this tutorial exactly and both times I tried I ended up with an invisible body - it looks like a floating head. See my picture:

http://img.villagephotos.com/p/2005.../failedmesh.jpg

If someone can tell me what I'm doing wrong I would really appreciate it! It's getting very frustrating. :weep:

Thanks in advance...

~faeriegurl~
Sims 2 Creations - http://www.sims2creations.com

faerie's blog - http://spaces.msn.com/members/enchantedrealm/
Lab Assistant
Original Poster
#58 Old 8th Feb 2005 at 2:25 AM
Quote:
Originally Posted by faeriegurl
Hi... I'm hoping someone here can help me out. I followed this tutorial exactly and both times I tried I ended up with an invisible body - it looks like a floating head. See my picture:

http://img.villagephotos.com/p/2005.../failedmesh.jpg

If someone can tell me what I'm doing wrong I would really appreciate it! It's getting very frustrating. :weep:

Thanks in advance...


Which 3D program are you using? If not Milkshape, I don't know. If it is Milkshape, I've had that happen when I add vertices. If you really need to add vertices, I would suggest learning to use Wes's new plugins in place of the mesh tool (instead of steps 27-38).
Field Researcher
#59 Old 8th Feb 2005 at 5:42 AM
Quote:
Originally Posted by WDS BriAnna
Which 3D program are you using? If not Milkshape, I don't know. If it is Milkshape, I've had that happen when I add vertices. If you really need to add vertices, I would suggest learning to use Wes's new plugins in place of the mesh tool (instead of steps 27-38).



I used Wingse3D to edit it. I didn't add any vertices. I also tried importing it into Milkshape after and then exporting it from there. I did try the plugins as well.

Well, I just did a shirt and now it isn't changing it in Body Shop - it just looks like the original one.

I'm attaching my .package files so maybe if you have a minute you can see if I messed up something. Sorry I'm such a pain... I guess I'm just slow. :confused:

Thanks so much.
Download - please read all instructions before downloading any files!
File Type: zip bellsleeveshirt.zip (447.7 KB, 60 downloads) - View custom content

~faeriegurl~
Sims 2 Creations - http://www.sims2creations.com

faerie's blog - http://spaces.msn.com/members/enchantedrealm/
Test Subject
#60 Old 8th Feb 2005 at 8:47 AM
Well, I've done a lot of toying around and I've made some headway. If I edit a mesh in milkshape *slams head on desk* It comes out fine. It took me a while to find a method to get an mesh modified in Lightwave to appear in the game. I had to import the object file with milkshape then immediately export it in milkshape. (don't ask me why lightwave likes one and not the other, should be a wavefront object either way) Modify my mesh then export to an object file. I then have to reimport into milkshape and then assign a new body material. Export again. Use the mesh tool and follow the remaining steps in the tutorial. Then I have to again extract the object file using SimPE from the GMDC in the downloads folder. Load that file in milkshape re export in milkshape and the complete the tutorial again. This has been the only way I've got an edited mesh to show up in bodyshop from lightwave. If I don't do this step twice it only shows the original mesh. however the mesh is solid black. I thought that perhaps it was because the verticies were inverted. So I inverted them in lightwave and followed all the steps above. Now I have a black mesh that's inside out. If anyone has any clues on what I'm doing wrong or how I can simplify this method I'd truly appreciate it. (Aside from using milkshape, my trial period is about to end and I'm not going to stop it.)
Lab Assistant
#61 Old 8th Feb 2005 at 6:57 PM Last edited by saracentner : 11th Feb 2005 at 9:16 PM.
yes yes...i keep getting the famous exploding mesh...i have tried changing the options in settings to every possible combination, i have read and re-read the tutorial...now i am at a loss...
i hardly moved the vertices around and yet i can not win
i am posting a zip for the experts to help me if they could
i honestly can not see where i am going wrong
oh, i use milkshape

edit: never mind...i figured it out
i was welding the meshes
Lab Assistant
#62 Old 8th Feb 2005 at 8:35 PM
Oi. First off, this tutorial is great! Huge thanks to you, Brianna.

My problem is with Milkshape though (I think). I unchecked the Auto Smooth as you said to avoid the funky lines but I still get them.
What can I do?
Lab Assistant
#63 Old 8th Feb 2005 at 9:44 PM
Huge thanx for the tutorial BriAnna - it works perfectly for me (although it has taken me about 10 hours due to my system set up for Japanese as well as english - btw SimPE doen't seem to like that?!!!)

Have altered a few meshes, but if I try to add any vertices to an existing mesh (I'm using Milkshape and divide edge for example), then I get the exploding mesh syndrome in Bodyshop! If I just move the vertices around a bit it works fine!

Has anyone had any success at adding vertices?

Has anyone tried chopping one mesh and joining it with another, as was done in ts1 - like adiing heeled shoes to the basic underwear body?

Many thanx again for the great tutorial, and the absolutely fab tools and mods MTS2, and it's very clever contributors keep coming up with!
Test Subject
#64 Old 8th Feb 2005 at 9:49 PM
adding vertices doesn't work...
not with "snap together" and not with "weld together"...
always getting the exploring mesh...
i've moved all vertices new in all new meshes...
was so easy in sims1... but now it's a lot of work...

this is my HP - cu there?
Lab Assistant
#65 Old 8th Feb 2005 at 10:50 PM
Can this be converted to deal with hair? I'd kill for a male ponytail mesh. I converted the fponytail to male, and the vertices are all crazy!

Pweeeeeez?
Field Researcher
#66 Old 8th Feb 2005 at 11:31 PM
Thanks Brianna, Miche & Delphy
Thanks to everyone involved. I'm not a fan of milkshape so I'm also keen to hear if anyone manages to crack being able to work with 3D Studio, however I did manage to make my first new mesh so I'm feeling pretty pleased with myself!




www.parsimonious.org
Brand new version 2012. Now hosting Worlds! Artists - Get your own Studio! Always be featured!
Nearly alive
#67 Old 9th Feb 2005 at 12:06 AM Last edited by Miche : 9th Feb 2005 at 1:02 AM.
The last version of the mesh tool now being tested supports SDM files (half life models) , at the moment it is mainly being used to import NEW body meshes (this version of the mesh tool allows lots more changes to be made to body meshes).

So I would like people to tell me if their 3d program supports this format (I know milkshake and blender do, think 3ds max does, think gmax has a importer but not a exporter.) Also it would really help if people could post a example sdm file created by the 3d programs they are using (just check no one else has posted one from the same program before you post ) This will hopefully help avoid the current problem of some obj files from some programs working but not others.

Please post these in the main Mesh tool help and faq thread, not in this Tutorial thread.
Lab Assistant
#68 Old 9th Feb 2005 at 2:15 AM Last edited by poi_boi : 9th Feb 2005 at 2:21 AM.
I got past step 20. There were out of date plugins in the plugin folder that must have been overwriting the new stuff in SimPE 0.15. Once I cleared out the folder of all plugins except for the obj extractor it works fine.

Thanks for your help Miche.

Why kill two birds with one stone when you can feed two birds with one scone.
Test Subject
DELETED POST
9th Feb 2005 at 5:33 AM
This message has been deleted by BonesChapel. Reason: Thread hi-jack
Lab Assistant
#69 Old 9th Feb 2005 at 8:04 AM
Quote:
Originally Posted by chriko
adding vertices doesn't work...
not with "snap together" and not with "weld together"...
always getting the exploring mesh.....


oh my! i have been welding my meshes! i bet that is why it's exploding!
i am will try not welding them now
Test Subject
#70 Old 9th Feb 2005 at 8:31 AM
BonesChapel -

I really don't think the majority of the people in the community are professionals, with access to professional software. These programs are REALLY expensive, if you hadn't noticed, and by "gearing" the tool to work with these professional programs, a LOT of people would simply not be able start making any new objects for The Sims 2. That is, if they don't want to use cracked, illegal copies of the software, and... well, we don't want to go there.
This, to me, is all very clear, so I really don't understand what you're getting at here.
Test Subject
#71 Old 9th Feb 2005 at 9:26 AM
Lets not hi jack this thread anymore then Miche and I already have. Thanks BriAnna for a fabulous tut. it answered all my how to questions. My only problem lies in file conversions as I don't wish to use milkshape. My point was to use a file format like 3ds that's pretty consistant in it's behavior and one that milkshape will support. When you clean shelves you work from the top down. When you do it the other way around you have more shelves to clean.
Test Subject
#72 Old 9th Feb 2005 at 10:38 AM
For anyone using Cinema 4D, here's your fix. Go into your import preferences and make sure import normals is selected. I set the scaling to 10 so that the object isn't so small and hard to navigate around. To export properly you'll need the riptide plugin. This will allow you a vast number of options to export since cinema 4D has so little out of the box. You'll have to export through your plugins window, under riptide. When the setting window pops up set your scale to 10 this will downsize the object back to it's proper size. Check the following boxes. Under general settings check everything. Under face sorting check Cinema 4D, and under Group options, check mesh names, as groups, group tags, and preserve heirarchy. When you import the file with the Mesh tool make sure you only import the vertices under settings. Voila. As i find a work around with other programs I'll let you know. No more milkshape. *Doing the happy dance*
Test Subject
#73 Old 9th Feb 2005 at 10:44 AM
oh by the way, I used Cinema 4D release nine production bundle, the plugin is for 8.5 or higher I believe that the riptide plugin is also available for 7 but not possitive. I can't remember where I found it, but you should be able to google it.
Nearly alive
#74 Old 9th Feb 2005 at 11:32 AM Last edited by Miche : 9th Feb 2005 at 2:39 PM.
BonesChapel,

I don`t agree with you one bit, that the response that we give to people in these forums is that it works for us , so it`s your problem. I am not a 3d modeller so don`t know how every program works for each different thing, so can`t tell people how to do things on each program. The obj files not being read by some program , I know the reason on cinema 4d is normally that it doesn`t export normals and when it does it also inverse a lot of cordinates , for the mesh tool to be able to convert this back to how it needs it would need a complete rewrite of the obj reading code, and as we knew we would need to swap to a different format soon, I didn`t have the time, or think it was worth doing.

As for obj files 3ds creates, I don`t know why these don`t work, have looked a couple of times, but I haven`t had time to find the problem. Again as we were swapping to another format, it just wasn`t worth it.

Obj files created by maya do work , I`ve only seen one obj file created by that which didn`t.

As for trying to make the program only work for the lower end programs, this is not at all true. We have tried to make it work with as many as possible , however we only have limited time to work on it, (we do have to do our real jobs so we can eat etc, or should we start charging for the mesh tool?)
The way the program reads a obj file is based ont he documentation we could find on the OBJ format, it seems a lot of programs don`t stick to the format as wrote in these documents. We have tried to make what changes we can to support all the differences. (of course we know there are still some problems with some files.)


As for the exploding meshes, again we`ve tried to help, I`m not a modeller, but the most common reasons are: the person is either adding vertices; having the import polygons option checked; or trying to make to big a changes.
We don`t have time to look at every single file which people can`t get working , and correct it for them. We do try to offer as much help as we can though, to say that we just tell people it works for us and they have to find help else where is so untrue is makes me so angry.

And again the problem with the screen being black, we have told people a temporary solution , and it will be fixed in the next release.

The reason for the closed beta was to try to solve some of these problems before we did release it, could you imagine the posts what would be posted if we had of just released it without trying to solve problems first. It is a very common thing to have a select group of people testing programs before they are released. And we have a lot of talented people in the closed beta group, and most of them do use the more expensive programs.

As for the 3ds format, at this time support will not be added for this , I don`t like the internals of the format (it has been added and added to over the years and isn`t the easiest format to read) , with the limited time we have to work on the mesh tool, we don`t have time to add support now.I can`t even find any clear documentation on if 3ds files supports skeletons or how it is formated in the file. And again I wouldn`t be supprised if different programs created the 3ds files in slightly different ways.

And one final note sorry that it has been dissappointing for you to watch the problems people have had and the lack of help we give these people. But I wish people like yourself would realise that we are trying to help as much as we can, we can`t spend all our time giving help, we have jobs to do and we also want to make improvements to the program. We have been trying as much as we can to improve the progam and to give help to people using it.

Any program is going to have some problems when it is still in beta (or even once it is first released out of beta).
Delphinius The Great
site owner
#75 Old 9th Feb 2005 at 11:44 AM
Let me just add that it's not our fault if the program you choose to use generates non-standard OBJ files. The OBJ importer in the Mesh Tool started off as a standard OBJ file loader, and then I found myself having to add exception after exception for all different kinds of 3d program. You can't catch them all.

OBJ is actually a very common format to use, it's text based and so is easy to generate and read. It's also something that is supported in both cheap and expensive programs, so was a natural choice. Just becuase you may have a preference for 3ds files doesn't mean it is the best possible format for the job.


As Miche said, we are both very busy and sometimes don't have time to answer every question - but the resources to fix the vast majority of problems are already located here on the boards.

Regards
Delphy
Closed Thread
Page 3 of 54
Back to top

Section jump