Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Movie Night #2 - posted on 10th Aug 2017 at 2:58 PM
Replies: 351 (Who?), Viewed: 177175 times.
Page 1 of 15
Lab Assistant
Original Poster
#1 Old 6th Feb 2005 at 8:14 PM Last edited by semloh : 7th Feb 2005 at 2:01 AM.
Default Sims2 Bump Map Tester
To help people check if their system is displaying bump maps correctly in Sims2 I have created this simple outfit that will tell you what is going on.

Download the 'BumpMapTest.zip' file below and extract the package from the zip into your 'My Documents\EA Games\The Sims 2\Downloads' folder. Then load up Bodyshop or CAS.

Create an adult male sim and select the new custom underwear called 'Bump Map tester'.

..... If your sim looks like screenshot 'A', you are out of luck. You will need to either review your 'Graphics Rules.sgr' file or look for some new hardware (possibly both !!) as your system is not displaying bump maps in Sims2

..... If your sim looks like screenshot 'B', rejoice! You can see all the graphical splendour that Sims2 can throw at you!


*************************************

Help on enabling Bump Mapping by changing 'Graphics Rules.sgr'

A number of you may have been a bit confused about how to make changes to the 'Graphic Rules.sgr' file to enable bump mapping. So here are some simplified instructions (credits to tolkov who originally documented these settings at MTS2)....

Before you start I would strongly recommend you read the instructions carefully and make backup copies of the two files you will be changing - you may need to revert back to them.

1.) Open file 'Graphic Rules.sgr' using Windows Notepad from your 'The Sims 2\TSData\Res\Config' folder. This is normally found in your 'Program files' folder unless you made changes when you installed Sims2.

2.) In notepad select 'Edit | Find...' from the menu.

3.) In the 'Find what?' box type (without the quotes) "useshaders"

4.) You should now see the following lines at the bottom of your notepad window...


# disable shaders by default for NV3x generation, only enable for high end cards
if ($maxVertexProgramVersionHWMajor = 2)
boolProp useShaders false

5.) Change the line that reads 'boolProp useShaders false' to say 'boolProp useShaders true'

6.) Bring up the 'Find' window again (if you closed it) and this time type (without quotes) "vertexdata"

7.) You should now see the following lines at the bottom of your notepad window...


# since we don't do bumpmapping on less ps2.0-capable hardware, eliminate tangents
# from the vertex data
# also, the presence of per-vertex tangents in the vertex data stream causes
# "exploded" polygons on the Radeon 9000, even if the data is ignored by the shader
if ($maxPixelProgramVersionMajor < 2)
boolProp skipTangentsInVertexData true

8.) Change the line that reads 'boolProp skipTangentsInVertexData true' to say 'boolProp skipTangentsInVertexData false'

9.) Select 'File | Save' from the menu and close notepad.


These changes should enable bump mapping in the Sims2 game itself (for all capable video cards) but there is a separate file for Bodyshop in the 'CSConfig' folder rather than the 'config' folder....


a.) Open file 'Graphic Rules.sgr' using Windows Notepad from your 'The Sims 2\TSData\Res\CSConfig' folder. This is normally found in your 'Program files' folder unless you made changes when you installed Sims2.

b.) Follow steps 2 through 9 above


Now try the bump map test outfit to see if bump mapping is working.


Note that these changes should force Sims2/Bodyshop to attempt bump mapping on most types of video card, including ones that haven't a hope of doing it!!!

If your card cannot support bump mapping you might get an error when you try to load Sims2 or Bodyshop that says...

"the system could not find a DirectX9.0 supported graphics card and the application will close"

(Thanks to Bucks Glover for discovering this). If this happens to you then you will need to repeat the steps above and reverse out the changes (or restore the backups you made beforehand - you did create a backup didn't you? LOL).

I have tried this technique myself to enable bump mapping on an nVidia GeForce FX5200 and it worked fine. Please post your results in this thread to help others.
Screenshots
Download - please read all instructions before downloading any files!
File Type: zip BumpMapTest.zip (201.9 KB, 5570 downloads) - View custom content
Advertisement
Test Subject
#2 Old 6th Feb 2005 at 9:39 PM
You're a star. Thanks for all your effort in helping with this issue.

Just downloaded the test and tried it. Geforce4 MX 440SE, does not show the message on the vest. I've been unable to make it work using the Graphic Rules either. When I include the above card in the Graphics Rule and started Sims2, I got an error message saying the system could not find a DirectX9.0 supported graphics card and the application will close. Maybe some clever soul can work out how to fool the system into believing the card is DirectX supported.

I would urge others to try this test and post your results.That way we can build up a picture of which cards work and those that don't.
Lab Assistant
Original Poster
#3 Old 6th Feb 2005 at 11:04 PM
Pretty much what I expected. Shame though :weep:

Thanks for posting your results.
Retired Moderator
staff: retired moderator
#4 Old 6th Feb 2005 at 11:11 PM
semloh youre just amazing. going to test now.
Field Researcher
#5 Old 6th Feb 2005 at 11:17 PM
I haven't tested it yet...as I'm currently busy with SC4.
But I will let you know how the test works out on my laptop, as soon as I get to it.
Guest
DELETED POST
6th Feb 2005 at 11:19 PM
This message has been deleted by simster.
Test Subject
#6 Old 6th Feb 2005 at 11:19 PM
Mine is working! woot! I have a GeForce FX 5959 Ultra, so it better. lol
Lab Assistant
Original Poster
#7 Old 6th Feb 2005 at 11:47 PM
Quote:
Originally Posted by simster
I noticed that on the backside there is little detail. Is that just on my machine?


Just the light angles I think. It should be more apparent if you rotate the sim.
Field Researcher
#8 Old 6th Feb 2005 at 11:49 PM
I have a radeon 9500 pro it works and rocks...

With this stuff, we can do tits more bumpy ??? :bump:
Test Subject
#9 Old 6th Feb 2005 at 11:53 PM
ATI Saphire Radeon 9600 Atlantis / 256Mb

Bump Mappimg shows up fine!

I am not a number, I am a free man
Lab Assistant
#10 Old 7th Feb 2005 at 12:55 AM Last edited by DumBblOndE : 7th Feb 2005 at 1:02 AM.
Now I can use software.. but I really am dumb once it comes to hardware.. so can someone tell me what this means??.. Why cant I see the bump??

Graphics Engine NVIDIA GeForce 6800 Ultra
Memory DDR3/256MB
Memory Bus 256-bit
Core Clock 400 MHz
Memory Clock 550 MHz
Form Factor 2-slot
Bus Interface AGP 8X
Pixel Pipelines 16
Memory Bandwidth 35.2 GB/sec
Fill Rate 6.4 billion texels/sec.
Vertices per Second 600 Million
Memory Data Rate 1100 MHz
Pixels per Clock (peak) 16
Textures per Pixel 16 (max. in single pass)
400MHz RAMDACs
0.13 Micron Process Technology
CineFX 3.0 Engine
Unified Driver Architecture (UDA)
Intellisample 3.0 Technology HCT
High-Precision Graphics
nView Multi-display Technology
Digital Vibrance Control (DVC) 3.0
Architected for Cg
Microsoft® DirectX®9.0c Optimizations and Support
OpenGL®1.5 Optimizations and Support
On-board DVI support up to 1600x1200 resolution
Vivid NTSC/PAL TV-out support with flicker filter

No bump.. im sad..

ps i changed the settings as in tutorial.. but no go for me? :weep:
Test Subject
#11 Old 7th Feb 2005 at 1:04 AM Last edited by tjwish : 7th Feb 2005 at 1:07 AM.
Sigh... :fallen: I only have a Radeon 9000 series graphics card and "Obviously" nothing showed up... :weep:

But what I can't understand is why it won't show up on your computer DumbBlonde...Seems to me like your graphics card and everything is pretty high-end.

And yes, when I saw that it didn't work on mine, I got really sad because I can't afford to upgrade and I'm too obsessed with the Sims to not have the "Best" of everything for it...Grrrrr!!! Ah well, I'll get over it
Field Researcher
#12 Old 7th Feb 2005 at 1:15 AM
DumBblOndE
I don't know either...your rig really should have no problems whatsoever to display Bumpmaps.
Lab Assistant
#13 Old 7th Feb 2005 at 1:15 AM
Ok.. well I was looking around I found a few posts in regard to high end cards and bump mapping..

A few staments were to say..

That high end cards will not show bumps in TS2no expanation why.. then another states that once the game logs the card, if it is OUT OF RANGE.. as listed in the video card list sgr.. then it will automatically change the bump to false.. No explaination why.. I am going to play around with some of these files and see what happens..

Ps yea you would think a $500.00 US card would show bumps.. Everything else is amazing..BUT I WANT BUMPS!!!
Lab Assistant
#14 Old 7th Feb 2005 at 1:36 AM
I have a FX5200 card so wasn't expecting the bumps ...but wow! I got big bumps. I had placed 'boolProp useShaders true' in my usercheats folder for the better pool. Could this be why my settings are set to true in GR.sgr?
Lab Assistant
#15 Old 7th Feb 2005 at 1:47 AM Last edited by DumBblOndE : 7th Feb 2005 at 1:50 AM.
Now im confused..

if you look at some of the flooring I used bumpmaps when i created them you can see detail of the bump...
but i cant get the damn undies to show me anything..

I changed the settings.. then i looked back into the user config log to see if it stayed..

boolProp bumpMapping false

AGAIN????.. now does that mean it reverted again?

I am really sad.. yes the pictures look fantastic.. BUT.. as I stated before I want the bump..

the acne bump.. the freckle bump.. the hairy guy bump.. and for some of my creature skins ??

Someone needs to figure this out.. not just for me... but for the benefit of Simkind.. I beg of thee.. let thou cast unpon me thine bump.. :weep:

I forgot to add this is the hi res version of the oldman skin.. no bumps but look at the detail..same with the floors? A artificial bump??

IT MAKES NO SENSE..

http://forums.modthesims2.com/attac...achmentid=27182
Screenshots
Field Researcher
#16 Old 7th Feb 2005 at 1:51 AM
Err...shouldn't that "boolProp bumpMapping false " actually say true?
Test Subject
#17 Old 7th Feb 2005 at 2:08 AM
actually, I tried changing the files as indicated and STILL could not get the bumpmaping to turn on in the game, it would come on in Bodyshop (a 5700)...

so, I took drastic measures...

and put

boolProp bumpMapping true

in the startup cheat file...

the bumps map nicely now :D
Guest
DELETED POST
7th Feb 2005 at 2:09 AM Last edited by simster : 7th Feb 2005 at 2:26 AM.
This message has been deleted by simster.
Guest
DELETED POST
7th Feb 2005 at 2:18 AM
This message has been deleted by simster.
Lab Assistant
Original Poster
#18 Old 7th Feb 2005 at 2:22 AM
Ok, first up, you might like to check the first post again as I've edited it to give some simpler instructions on what to do in 'Graphic Rules.sgr' than those that were linked.

DumBlonde:

Theoretically there should be no problem with your card if you make the 'sgr' file changes I've documented. But we all know the difference between theory and practice!

I am intrigued that you say " ...look at some of the flooring I used bumpmaps when i created them you can see detail of the bump... but i cant get the damn undies to show me anything..". Do you mean that the textures you imported into homecrafter had pre-rendered bump maps or have you somehow managed to get normals maps into homecrafter floors in addition to your textures?

Looking at your old man pic he certainly looks bump mapped but I suspect you might just be pre-rendering your textures prior to import. Consequently Sims2 itself isn't rendering the bumps dynamically it's just displaying the texture as is. Could this be the case? It would explain the inconsistancies that you are seeing.
Lab Assistant
#19 Old 7th Feb 2005 at 3:32 AM
Wow .. i totally give up..

I did..
enabling Bump Mapping by changing 'Graphics Rules.sgr'
for both game and BS

In Cheats startup I used
boolProp useShaders true
boolProp bumpMapping true

I re downloaded DirectX9.0c

I Used in game cheats
boolProp useShaders true and boolProp bumpmapping true

I listed.. match("${cardName}", "*6800*")


My game and bs open and work fine.. but i still do not see the mapped shirt
.. then i checked to make sure it would export from BS showing the map.. yes i could see it...

As for the floors and the skin i realize they are pre rendered maps included in the textures files.. so yes they are my false bump maps

Well I guess I cant have everything.. Still looks phenominal.. Less the nipples :P
Test Subject
#20 Old 7th Feb 2005 at 4:12 AM
Im using a Geforce 4 TI 4600, 128mb, I figured that would be enough to see bumpmapping as I can in other games an such. But no luck here, I followed your instructions carefully and did everything on it.
Guest
DELETED POST
7th Feb 2005 at 4:26 AM
This message has been deleted by simster.
Test Subject
#21 Old 7th Feb 2005 at 5:15 AM
Looking Good
Thank you for this test and my card Radeon X300 Series 128MB work just fine with seeing the bumps. I was crossing my fingers because you never know what you can get with cards. I recently bought a Dell 8400 a few months ago for me and a few weeks ago bought another Dell 8400 with a Radeon X300 Series 256MB card for my wife.
These cards are the next new generations for graphics. Its all started with cards installed on PCI slot, moving over to AGP slot and now back to a PCI slot with a different twist call Express. Sad side to this story is these cards cannot be used on motherboards that are not very new. I will not get too technical, but in short, the PCIe path is twice, one in one out.
Lab Assistant
Original Poster
#22 Old 7th Feb 2005 at 5:16 AM
DumBblonde:

It certainly looks as if Maxis really screwed up on the graphics config for bump mapping. I'm sure the key to fixing your problem must be in the scr file somewhere. Just for the hell of it try this...

Look for the following code, it is a little way below the 'boolProp useShaders' lines you have been playing around with, just above the start of the "Print system info" section;

intProp deviceLocalVideoMemorySizeDefault ($textureMemory * 1024 * 1024)

else
setb forceLowSettings true
setb forceLowResolution true


Now, insert a 'boolProp useShaders true' line so that it looks like this...

intProp deviceLocalVideoMemorySizeDefault ($textureMemory * 1024 * 1024)
boolProp useShaders true

else
setb forceLowSettings true
setb forceLowResolution true


If I've understood the code correctly (and thats always open to question!) this should force shaders for any 3D card at all, regardless of manufacturer or name. If this doesn't work maybe you will have to trade your nVidia in for an ATI! (Or write nasty letters to Maxis )


Atlas:

I think your problem is the fact your card is one of the GF 4 family - no DirectX9 feature support. Must be annoying as hell 'cos the Ti was a pretty awesome piece of kit not too long ago.
Test Subject
#23 Old 7th Feb 2005 at 5:57 AM
[QUOTE=DumBblOndE]Now I can use software.. but I really am dumb once it comes to hardware.. so can someone tell me what this means??.. Why cant I see the bump??

DumBblOndE, look like you have the muscles but do you have the body to handle all that pump up? :loco:
Let look at your Display Property in your Control Panel. In The setting does it show your card in the display? What are your screen resolution and Color quality? 1024 x768 and Highest (32 bits), should not be less then those numbers. In the options of the SIMS games what are your settings? If all are set and look right the next questions are how old is your puter? Is this card an upgrade or did it come with the puter? If your puter is less then a 1GB speed your motherboard may not have the capacity to handle a graphic card this size of X8 speed and may default back to X4 speed.
This are just basic and without physically looking at your puter and checking setups it hard to point out what going on any further, but your card does have those muscles.
Lab Assistant
#24 Old 7th Feb 2005 at 2:37 PM Last edited by DumBblOndE : 7th Feb 2005 at 2:41 PM.
Hello.. I will try your suggestion once I get home semloh

dssly -
I just purchaced my computer at Show in November.. So its brand new..HI END.. maybe too high end..

UHhh lets see..

This is just a summary.. i am sure i am forgetting a few things.. But

Operating System: Microsoft® Windows® XP Professional
Power Supply: PC Power & Cooling 680
Processor: AMD Athlon™ 64 3200+
Motherboard: ATI
Memory: 1GB Kingson
Graphics Processor: NVIDIA® GeForce™ 6800
System Drive: High Performance - 80GB Seagate
Optical Drive One: Lite-On® 16x DVD / 52x32x52x CD-RW Drive
Sound Card: Internal ATI

And all settings are on max.. so Display is not issue..

I think as simster Stated mybe i am too high as far as standard settings go .. but I will try semloh's suggestion once i get home tnight.. Let you know..


I forgot to ad this computer was build for DOOM 3 And Half life 2.. evrything runs like melted butter.. so thats not an issue .. As for bumps...well we will see..

PSS.. YEA its a nice machine.. Incase yousaid that.. Case is black grating with blue neon lights.. GRIND with PINCH OF SALT** :nana:

PS Thanks to everyone for there assistance on this one
Test Subject
#25 Old 7th Feb 2005 at 2:50 PM
Some notes on my system and the results of the test

I have a Dell Inspirion 8600, Intel Pentium M 1.4 Ghz processor, 128 MB ATI Mobility Radeon 9600 Turbo Pro Video card, 1 GB of RAM with all game settings turned on max. Both the skin and the message display without a hiccup and with nothing done to the system.

The skin is fantastic! Thanks Semloh for a great contribution to the game. Will be using the skin in a Legacy game to see how the genetics work out.
Page 1 of 15
Back to top