Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 1 (Who?), Viewed: 2081 times.
Test Subject
Original Poster
#1 Old 10th Mar 2011 at 10:23 PM
Default All sims getting stuck
Apologies if this isn't in the right section but I have an issue that's driving me MAD!

My specs:
Intel Pentium(R) 4 CPU 3.00GHz
3.00GB of RAM
nVidia GeForce 9500 GT
Microsoft Windows XP Professional Version 2002

I'm running Sims 3 and WA only. I'm patched up to date on WA and as far as 2.13.6 on base game. I haven't updated to 2.14 because whenever I tried during initial setup, it kept saying there was a problem and that the WA was not 'compatible with' and 'please upgrade'. I gave up and stuck at 2.13 which ran.

So the current problem...last year (summer) I played Sims 3 and WA with no issues at all on a different, less powerful computer. I took a break from the game and decided to load it onto my own machine (spec above) and start again. Now I keep getting issues. First issue was the one above so I stopped at 2.13 BUT now it's a whole new thing.

The game was working great for a while and I had installed some custom content (from here and other main sims sites). I was also running NRAAS Master Controller and sometimes testingcheatsenabled. I'm playing in epic lifespan mode, aging on and no story progression.

All of a sudden the sims (my family and randoms in town) started getting stuck. I first noticed because the kids didn't come home from school. 90% of the town froze coming out of buildings etc and I'd have about 5 sims or so on exactly the same spot. I tried using resetsim and this worked until the next day (game time) when the same thing would happen. Then even resetsim didn't work because all my sims would either reset themselves to one spot on the household lot or I would use resetsim and they'd all get stuck in that one place. They would occassionally walk away from that spot only to bounce straight back to it a few steps later. They were/are literally layered on top of each other. I can't do anything...they can't make phone calls, move, talk anything they just get stuck in that one place EVERY time. Occassionally they'll also disappear from view. The icon tells me they are there but I can't see them.

When it does this, if I try to enter build or buy mode or edit town it wont even show the pannels or go into edit town mode itself.

Originally I thought it was because my computer wasn't powerful enough but I've upgraded the RAM to 3GB and bought a new graphics card (9500 GT) and it is STILL doing it. The sims are still getting stuck and they get stuck different places, different times not long into the gameplay.

I've tried running it without custom content - deleted package files (didn't touch DCBackup, should I?) - no change. I tried deleting the cache files - no change. I tried taking out the mydocs files - no change.

I'm all out of ideas. Help?
Advertisement
A missing part of me that grows around me like a cage
staff: retired moderator
#2 Old 11th Mar 2011 at 4:09 PM
Yes, you can delete the DCBackup folder- that just contains a copy of the contents of the Sims3Packs you installed, and is not needed by the game. It is read by the game though so will take up resources.

For your routing problems, it sounds like you are having a bottleneck at certain sites, and that the computer is not able to calculate the routes fast enough. I don't think you mention which world you're using, but perhaps you can place a fresh copy of the affected lots from the library, in case something has become corrupted.

Other things you can do are to have two versions of busy rabbitholes, for example schools. You can make another lot with a school rabbithole building upon it, and the sims will begin to use this after a few days. This can alleviate any problems. I always seem to get a bottleneck at my spa too (as I have adults and teens working there, and they all seem to finish at the same time), so I have two spas in my world. If you want a variation you can download Riverview, as that has a different school and spa, as well as several other rabbitholes.

The game seems to pause animations when it cannot process the information- so your sim will stand still, or tap their foot, until the processor can catch up and calculate a route (they do this when changing outfits, too). This can cause a pile up, and cause several sims to occupy the same tile.

This can also cause your game to not cope if you try to enter Edit mode- I'm certain that this is a problem with your computer running out of resources, so if you can prevent the pile ups you most likely won't have the issue.

I will choose a path that's clear- I will choose free will
RUSH
Back to top

Section jump