Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Locked thread | Replies: 5 (Who?), Viewed: 4773 times. | Locked by: ellacharm3d Reason: resolved-outdated framework
Lab Assistant
Original Poster
#1 Old 15th Jun 2011 at 4:54 PM Last edited by SmexySims2 : 15th Jun 2011 at 5:29 PM.

This user has the following games installed:

Sims 3, World Adventures, Late Night, Pets
Why Won't my Custom Content Show Up?? Please Please Help!
I have spent yesterday and most of today trying to figure out what's wrong with my .package files and overall have not found an answer. I have a Mac computer and The World Adventure Expansion Pack. Here's everything I did:

I was on my sims game and had all of my custom hairs, clothing, and furniture working perfectly (.package and sims3packs). Since I was working on a video I decided I needed to get the Pose Player so that I could get my sims to stand in different poses. I downloaded the Pose Player and a couple of Poses. But I put them in ProgramFiles/ElectronicArts/TheSims3/Mods/Packages where all my other working package files were. I tested it out and the pose player appeared but was not working because there were "No Interactions Available." I shut down the game and went on ModTheSims to find out why it was doing that and found out that my game version (2.16) was higher than 1.22 and I needed to move my files to the Documents for them to work.
I'll admit I was a bit confused at that because it seemed as though my other custom content was working perfectly fine. But I put all my files (Dragged them since I don't have cut-paste) onto my desktop and then into Documents/ElectronicArts/TheSims3/Mods/Packages anyways. ( I really hope I did it right cause I sometimes read things wrong.) (When moving my .package files to the Documents Mods/Package folder I deleted the resource.cfg that was in the Program Files Mods/Packages as instructed. I did not know what 'Old Framework' files were, so that might've screwed things up a bit.) I then went on the game and NOTHING showed up. Not even the unworking (is that even a word?) Pose Player. The only things still there were my Sims3Packs. I got angry and quit the game then tried moving the files back into the program files mods folder to see if they would work again and I would just ditch working on the Pose Player since it wasn't that important to me. Once everything was back into place I tried starting up my game again and my custom content STILL didn't show(Besides Sims3Packs)! I tried putting my custom content into a Mods/Packages in TheSims3 World Adventures in Program Files (I deleted the Mods folder in the Regular Program Files/ Sims 3 first) but it still didn't work. The last thing I tried before coming here was putting custom content in both the Program Files Mods/Packages (I recreated the folder) and the Documents Mod/Packages. (<- That's probably where I screwed things up a lot.)
I really hope you guys can help me out because it took a long time getting all that custom content to work and to lose it all in one day would be devastating. I feel like such a dope for not knowing what to do or not being able to understand the FAQ/Guide computer lingo. I would be soo grateful if someone could give me a straight answer for my situation in understandable English!
Advertisement
A missing part of me that grows around me like a cage
staff: retired moderator
#2 Old 15th Jun 2011 at 6:46 PM
First, double check that you have removed all of the old way files- this might help:
http://www.simswiki.info/wiki.php?t...ove_the_Old_Way

Next, download the new framework, and put it in place. Full instructions and pictures are here- the instructions are the same for Mac and PC at this stage:
http://www.modthesims.info/wiki.php...Setup_and_Files

Test the game, with just that test framework and nothing else. Does the nointro mod work? If so, add the rest of your package files to the Mods folder, and play.

Let us know what you have tried so far if you get any more problems.

I will choose a path that's clear- I will choose free will
RUSH
Lab Assistant
Original Poster
#3 Old 16th Jun 2011 at 3:11 AM
Oh yay! My regular custom content came back! Thank you! :DD There's just one problem though (i know, lame, right ._.), my Pose Player appeared again but there's still "No Interactions Available." Why is it still doing that? When I looked on the guide for fixing it, it told me to do the exact same thing I just did (put the .package files in a Documents Mods/Packages). Is there something I'm missing?
In the Arena
staff: senior moderator
#4 Old 16th Jun 2011 at 6:04 AM
You still have conflicting interaction-type CC somewhere or the "old framework" files are still lurking somewhere.

You've checked all Program Files path for them, even in the EPs' and SPs' paths?
  • /Applications/The Sims 3
  • Right click on <EP Name>
  • Select Show Original
  • Select <EP Name>
  • Select Show package contents

You may need to remove the Preferences folder. And fix Permissions, too, if that didn't help.
  • delete your /Users/<User>/Library/Preferences/The Sims 3 Preferences folder
  • /Applications/Utilities/DiskUtility, "Repair Permissions".

Also, thread moved to OSX section.
Lab Assistant
Original Poster
#5 Old 16th Jun 2011 at 3:32 PM
Wait, quick question. Did I need to delete the resource.cfg that was in the Program Files Mods/Packages folder?
Lab Assistant
Original Poster
#6 Old 17th Jun 2011 at 1:41 AM
Oh nevermind! It's working! Thanks a lot guyss!
Closed Thread
Back to top

Section jump