Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 1 (Who?), Viewed: 3214 times.
Lab Assistant
Original Poster
#1 Old 1st Aug 2011 at 7:39 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Showtime, Seasons, University Life, Island Paradise
[SIMS 3: GEN] "Disc Authorisation Failure" error
Howdy y'all!
Ever since I updated The Sims 3: Generations, I keep getting the error "We are unable to verify that your disc is a valid copy of The Sims 3 Generations. Please contact customer service." I dunno what changed, since I only played it last night, without the update. I've recently added a few new custom items, but I highly doubt they'd decided whether my game is "authentic" or not. Unless they do... then thats stupid. Because that means I can't put any new custom content into TS3!!

Operating System: Mac OS X / Snow Leopard / 10.6.8
Version: 8.0.152.012001
Custom Content: Yes

Need more information? Lemme know.

Yellowbox - Real Estate for The Sims || visit our new tumblr page , or our blogspot site
Advertisement
Test Subject
#2 Old 2nd Aug 2011 at 12:04 PM
I'm getting the same message, but with Late Night not Generations (I only have World Adventures and Late Night installed).

My problems started with upgrading to Mac OSX Lion. I upgraded and then my modem driver software was no longer supported, and Sims 3 crashed seconds after opening it. I got a whole new Wifi system (I'd been meaning to anyway, I didn't just get it for The Sims!) and was back online, and when I next tried to open Sims 3 it said there was an update. So I installed the update, hoping this would make the game work again, but now it just comes up with the message "We are unable to verify that your disc is a valid copy of The Sims 3 Late Night" and then it closes down! (I hope they fix this stuff up soon, otherwise most of the Mac users won't be able to get the next expansion! Surely that's gonna hit em hard enough in the sales to make them wanna fix it.)

And btw I have no custom content, only stuff from the store that was working fine until this latest debarcle!
Back to top

Section jump