Home | Help | Download | Community | Site Map | New Posts | Sign in
Replies: 4 (Who?), Viewed: 3653 times.
Test Subject
Original Poster
#1 Old 29th Oct 2011 at 6:30 AM
Default Cannot install Sims3Packs because "service initialization failed"
Like it says, for some reason I cannot install Sims3Packs anymore. I used to be able to without any problem; that was before I installed Generations. The game is completely up-to-date patch-wise. I'm running version 8.0.152.013001, with every episode except Pets installed.

When I try to install a SimPack, either from the launcher or by double-clicking it in the downloads folder, a black window pops up. The rainbow-wheel of eternal waiting spins for several minutes, and when I right-click the Sims icon in the dock it tells me that the program is not responding and gives me the option to force quit. If I don't force quit, then eventually I get a message stating:

"Unable to start game

Service initialization failed (0x065d0274)"

Now, I can launch the game just fine from the launcher. I have had no gameplay issues other than a few graphic glitches (well, and my sim's paramour being stuck in the bathroom wall of a club for a couple of days, but that's another story).

On a whim, I attempted to use 3Viewer as a way of bypassing the launcher to install packs. However, this also doesn't work. Instead I get an error message stating:

"java.io.FileNotFoundException: Usually C:\Documents and Settings\UserName\My Documents\Electronic Arts\The Sims 3\/Downloads/LianaSims3_100609_10_1.Sims3Pack (No such file or directory)"

I have no idea what any of that means. I can assure you that both the file and the directory exists, however.

Now, looking around the forums makes me think that maybe this is an Origins issue? Only I don't know what, exactly, Origin is or what I can do about it to fix my issues with installing packs. If anyone could help, that would be great.

Oh, and I have had no problem installing package files.
Advertisement
In the Arena
staff: senior moderator
Test Subject
Original Poster
#3 Old 30th Oct 2011 at 3:20 AM
OS X - which is why I posted here. Snow Leopard v. 10.6.8. I'm on a Mac Mini with 4GB memory and a 2.4 GHz Intel Core 2 Duo. And yeah, it's not enough machine to run the game, but like I said this is the first major issue I've had so far.

Information I forgot the first time: this problem first seemed to start after I installed the latest patch. But I haven't tried to install packs in ages (multiple patches ago) so those two things may not be related.
In the Arena
staff: senior moderator
#4 Old 30th Oct 2011 at 3:48 AM Last edited by ellacharm3d : 30th Oct 2011 at 3:58 AM.
Default MTS2 Staff Reply
  • Sims 3 - Installing / Patching / Uninstalling
    1. Whether you are Installing for the first time or Reinstalling, be sure to read the Game Help:Installwiki FAQ.
      -
    2. This Game_Help:TS3_Uninstallwiki link has the step-by-step instructions to guide you through uninstalling The Sims 3,
      and its (EP/SP) packs. As well as removing any leftovers after uninstalling.
      -
    3. The Game_Help:TS3_Patchingwiki Guide provides information on:
      • Tips Before You Begin
      • Patching Common Errors
      • Manual patch Downloads
      • Invalid File Errors and more

The Svc Init failures and the path to "Documents and Settings" made me doubt myself.

Try on new folders: Game_Help:GCCTSU3_Redo/DCCachewiki

And, do this:
  1. delete preferences
    • /Users/<Username>/Library/Preferences/The Sims 3 Preferences folder
  2. delete caches:
    • <diskname>/Library/Caches/<anything with Sims 3 in it>
    • /Users/<Username>/Library/Caches/<anything with Sims 3 in it>
  3. repair permissions
    • /Applications/Utilities/Disk Utility, "Repair Permissions"

If the above does not help, when that Svc Init error shows up, usually only a clean, full uninstall + reinstall + patching solves it.

What graphics do you have on that Mac Mini? The patch 1.27 has some of Pets features and there's been lots of reports of failures on systems with weak or unsupported graphics, even if you don't have Pets. The requirements have increased considerably (just for updating to 1.27) and as usual EA never updates their System Requirements with this fact.

And 3Viewer has not been updated in aeons, while the Sims3Pack file format has had some changes in the meantime. We suspect this when past installs are suddenly not being read, stuff shows as Uninstalled. And the Store Items needed to be redownloaded and reinstalled all over again.

It was indeed an Origin issue, but EA claims to have that fixed. And as Origin is only a PC (another reason to think you were on one) program to manage Downloadable Content from EA, and you're installing a 3rd-party item, I didn't see the connection. Have you tried another Sims3Pack that you know has no complains from people, a Lot/World from here, for example?
Test Subject
#5 Old 9th Nov 2011 at 1:41 PM
I have this problem occasionally on my MacBook Pro. I have worked out that if I try to install any Sims 3 Packs through the launcher with the Mods folder in the game, then I get that message and I can't install. If, however I remove the Mods folder to the desktop and then try to install the Sims3 Packs then it works fine. I load the game to make sure the item/s are installed ,then quit, put the Mods folder back in the game and restart the game. Works every time.
Hope that it works for you too.
 
Back to top

Section jump