Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 9 (Who?), Viewed: 2568 times.
Lab Assistant
Original Poster
#1 Old 18th Dec 2011 at 11:08 PM
Default missing uv map
I have been attempting to move on from clothes texturing and have been trying change a skirt mesh as a learning exercise. The mesh itself looks okay in terms of shape, but that's about it. In CTU most of the mesh is flesh coloured, and some of the original texture is showing in various weird places. Whilst trying to work out what i've done wrong, my first step was to check the uv map. I have applied the blue checked pattern to the mesh, but when I open the texture coordinate editor, I just have a blue square grid. There is nothing on it at all; even as a novice I am sensing that this is wrong! The group name is in the drop down and the scale is .5. Can someone please tell me whether this is salvageable or will I need to start again? I've obviously deleted it along the way, but i've been doing this for so many weeks I couldn't begin to remember what, when or how. I would be grateful for any help.
Advertisement
Née whiterider
staff: administrator
#2 Old 18th Dec 2011 at 11:12 PM
Make sure you've hit Ctrl-A to select everything before opening the texture co-ordinate editor, as you have to have the vertices selected for them to appear in that window.

What I lack in decorum, I make up for with an absence of tact.
Mad Poster
#3 Old 19th Dec 2011 at 12:39 AM
upload if you can not figure it out.
If it is screwed(happens sometimes when welding stuff together) you need to reuvmap your skirt.
Lab Assistant
Original Poster
#4 Old 19th Dec 2011 at 5:54 PM
Thanks to you both for the responses. Hitting ctrl A sorted it out; I can now see the uvmap. Not sure what I do now but i'll go back to the tutorials and try to figure it out. Thanks!
Scholar
#5 Old 19th Dec 2011 at 5:57 PM
Is your alpha map white in the areas where you want your texture to show?

When you assign the material to the mesh in Milkshape and change the viewport display to textured, does the blue check grid display correctly?

.:Kitty Klan:.
Visit for Sims 3 Hair, Tattoos, and other free custom content downloads.

.For website updates, subscribe to my RSS feed at.
Dreamwidth Blog
Lab Assistant
Original Poster
#6 Old 19th Dec 2011 at 6:14 PM
I've tried to upload a picture but I can't even figure that out! Basically, in texture view the skirt that i've changed, and the body underneath is all in blue grid, and it all looks okay. Nothing is twisted or anything; the skirt has a smaller sideways grid, whilst the body is a straight slightly larger grid. In the texture coordinator, there is the uvmap of the new skirt, diagonally on top of what I presume to be the body, which is straight up and down underneath.

Also, I have to use a bit of a roundabout way to use photoshop as I only have elements and as far as I know, it still doesnt support alpha layers. I export as a DDS file, open that in gimp, then resave as a PNG file. I open that in photoshop, make the changes to the textures (minus any alpha layer) then do the opposite in reverse to get it back into CTU. Nothing that I make is for upload and so far for what I need, I havent had any problems not using an alpha channel but maybe this time, I need it for the mesh to work? I'm way out of my comfort zone but am not prepared to give up just yet!
Scholar
#7 Old 19th Dec 2011 at 6:23 PM
Whatever texture you're setting as the multiplier in CTU, set that as the texture in your Materials tab and tell me how that looks. If your mesh is looking skin colored, I'm guessing that the alpha in your multiplier is messed up, and you may need to find a DDS plugin for GIMP so that you can save it as the correct file type w/ a working alpha.

.:Kitty Klan:.
Visit for Sims 3 Hair, Tattoos, and other free custom content downloads.

.For website updates, subscribe to my RSS feed at.
Dreamwidth Blog
Lab Assistant
Original Poster
#8 Old 19th Dec 2011 at 6:38 PM
I've tried that and it's all kinds of ugly! I'm pretty sure that it's to do with the alpha channel as well as the uvmap. I'm going to go through the uvmap tutorial that bloomsBase advises in the shoe meshing thread below this one to make sure that the uvmap is okay, then i'll hunt out the DDS plugin and see if I can sort out the alpha channel. I suppose if this was all easy, everyone would be doing it Thanks so much for the help and if when i've done all of this i've still got problems i'll post again. I'm guessing that both the uvmap and the alpha are messed up. Here goes.....
Scholar
#9 Old 19th Dec 2011 at 7:05 PM
All kinds of ugly = texture & transparency showing up in weird places and stretched? --> indicates UV mapping & alpha channel issue

Or all kinds of ugly = texture showing up like grainy, pixelated rainbow snow? --> not actually a big deal and indicates the file needs to be saved as an 8-bit (or 16 bit... can't remember which one right now) image instead. I don't know where this is on Elements or GIMP, but in Photoshop, it's under Image -->Adjustments.

.:Kitty Klan:.
Visit for Sims 3 Hair, Tattoos, and other free custom content downloads.

.For website updates, subscribe to my RSS feed at.
Dreamwidth Blog
Lab Assistant
Original Poster
#10 Old 19th Dec 2011 at 7:16 PM Last edited by alfiemoon : 19th Dec 2011 at 10:30 PM.
All kinds of ugly = texture & transparency showing up in weird places and stretched? --> indicates UV mapping & alpha channel issue


Yeah, it's this one; wrong textures in the wrong place, twisted, stretched, all sorts. A crash course in UV mapping & alpha channels coming my way I think! The uv map tutorial is quite easy to follow so hopefully it will be within my skills level.


EDIT: I've just found out by accident, that photoshop elements now supports DDS files; not sure for how long as I just saved a texture as a DDS file by accident Still not sure about the alpha channel but, one step further forward.
Back to top

Section jump