Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 12 (Who?), Viewed: 4531 times.
Test Subject
Original Poster
#1 Old 9th Apr 2012 at 6:11 AM

This user has the following games installed:

Sims 3
Default service initialization failed 0x039e8474
so I tried Installing Sims 3 Package Files: Setup & Files and i thought i had done everything right. It looked just like how the intro said to do it. But then i left my laptop and didn't do the test. about 6 hours later i tried to run the game but it didn't work. The sims 3 launcher opens but when i press play it tries to open the game but then crashes and says "service initialization failed (0x039e8474)". I haven't installed any other content. I am new, yes. Please don't patronize me for messing up. i realize i did. or maybe i didn't? im just very confused. i didn't go into this without knowing anything. i probably read the Game Help:TS3 CC Basics like 20 times to see what i was really getting myself into. (prior to trying to download anything) So i stormed the site to see if this had happened to anyone else. i found something that said to delete the content i had downloaded and then delete cache files and try to run the game. which i did and it didn't work. so i searched the forum and found someone who the same thing happend to, just a bit different. The help she got didn't help me. So then i googled it. Still no help. I dont know if this matters, but i have a mac. so PC advice wont exactly help me... and yes i did follow the rules for mac users.
I have no idea what to do next. I think i did about as much as i know what to do. please, Im in desperate need.
Advertisement
In the Arena
staff: senior moderator
#2 Old 9th Apr 2012 at 6:19 PM
Default MTS2 Staff Reply
  • Sims 3 - Game Problems
    Please go through this FAQ and follow the instructions, doing each step in order and not skipping anything:Most issues with the game can be resolved by following those steps.

You've tried undoing the CC installation but still get the same error? Did you continue on with step#3 with new user files as the linked FAQ states?

If you bypass Launcher, does the game load then? Game Help:TS3 Bypassing the Launcher#OS_Xwiki. Or same error pop-up again?

Then, try these steps too:
  1. delete preferences
    • /Users/<Username>/Library/Preferences/The Sims 3 Preferences folder
  2. delete caches:
    • <diskname>/Library/Caches/<anything with Sims 3 in it>
    • /Users/<Username>/Library/Caches/<anything with Sims 3 in it>
  3. repair permissions
    • /Applications/Utilities/Disk Utility, "Repair Permissions"

You didn't follow all the rules, though, as you did not post in the Mac forums. Thread moved.
Test Subject
Original Poster
#3 Old 24th Apr 2012 at 2:46 AM
sorry i haven't been able to get back to you, some things came up.

okay, so the Game Help:Sims 3 Game Problem did not help. Bypassing the launcher didn't help, but im not sure how to do delete preferences because i cant find the library. Ive deleted the catch files and tried to run the game many times but it doesn't help. Do i continue onto step 3?
Test Subject
Original Poster
#5 Old 24th Apr 2012 at 6:00 PM
repair permissions
/Applications/Utilities/Disk Utility, "Repair Permissions"
Typo Queen
staff: moderator DELETED POST
24th Apr 2012 at 7:34 PM Last edited by porkypine : 24th Apr 2012 at 7:36 PM. Reason: forget it. My instructions won't help - you have a mac - not windows 7 -
This message has been deleted by porkypine. Reason: forget it. My instructions won't help - you have a mac - not Windows 7
In the Arena
staff: senior moderator
#6 Old 25th Apr 2012 at 4:35 AM
Test Subject
Original Poster
#7 Old 27th Apr 2012 at 2:02 AM
it didn't work :/ is that all i can do?
In the Arena
staff: senior moderator
#8 Old 27th Apr 2012 at 3:50 PM
Default MTS2 Staff Reply
  • Sims 3 - Installing / Patching / Uninstalling
    1. Whether you are Installing for the first time or Reinstalling, be sure to read the Game Help:Installwiki FAQ.
      -
    2. This Game_Help:TS3_Uninstallwiki link has the step-by-step instructions to guide you through uninstalling The Sims 3,
      and its (EP/SP) packs. As well as removing any leftovers after uninstalling.
      -
    3. The Game_Help:TS3_Patchingwiki Guide provides information on:
      • Tips Before You Begin
      • Patching Common Errors
      • Manual patch Downloads
      • Invalid File Errors and more

So, bypassing Launcher still give the exact error?
Well, if removing user data so a new set is created and repairing Permissions do not work, that indicates the issue is in the Program Files path under /Applications. You have not messed about with files in there, when doing the CC Setup? You might want to verify the "old framework" is not present in /Applications path. Try Game Help:Installing Sims 3 Package Files/Old Way to New Waywiki.

If all that is checked, and still issue persists, means only a clean reinstall would help.
Test Subject
Original Poster
#9 Old 28th Apr 2012 at 6:26 AM
oh my God! it worked!! thank you sooooo much!! I can not begin to express my gratitude. If not for your help, i would have been lost forever! I just have one more question, do you think i will i be able to download anything from this site?
In the Arena
staff: senior moderator
#10 Old 28th Apr 2012 at 10:56 AM
Test Subject
Original Poster
#11 Old 30th Apr 2012 at 4:19 AM
hmm i see what you mean. so what your trying to say is that just because i had this problem i shouldn't let it keep me from downloading custom content? i agree. I'll try again hopefully not run into any problems. thank you again for all your help.
Test Subject
#12 Old 30th Apr 2012 at 5:38 AM
Default service initialization failed 0x039e8474
After update with launcher and installing patch, my game not running.
Why? Any body can help me?
I just installing the sims 3 game base.
In the Arena
staff: senior moderator
#13 Old 30th Apr 2012 at 5:58 AM Last edited by ellacharm3d : 30th Apr 2012 at 6:10 AM.
@hayabusadragon,
as the OP's issue has been resolved, this thread is going to be locked and archived soon, so you should start your own Help thread if after trying all the suggestions above does not clear up the error for you.

@kina363
Downloading and Installing are 2 separate steps.
Downloading from this site (or any site) just involves a web browser, an internet connection and enough space on your harddrive. So, even if the game has issues starting, the game is not running when you're downloading, is it?
Installing, on the other hand, has to be done per the CC Installation FAQs we have on the content type - .Sims3Pack / .package / .sim. Incorrect installation is almost always what causes game to not start or have issues. Or incompatible CC from not reading the CC's requirements, would cause the game to have issues when playing.

If you haven't done so, you should read the CC Basics (link in the .package Installation wiki page) and DFDD FAQ (link in my signature).
Back to top

Section jump