Home | Help | Download | Community | Site Map | New Posts | Sign in
Replies: 5 (Who?), Viewed: 2247 times.
Test Subject
Original Poster
#1 Old 1st May 2012 at 4:16 PM
Default Pets EP: dog's texture clipping
Somehow I'm having trouble with dog textures. White lines appear along the coat, and it looks as if the UV seams could be seen (see attached picture). It happens both in CAS and in game, with and without CC installed, to all dog breeds.

Weird thing is it only happens with about 80% of the coat shapes (solid coats seem to work fine) and only to dogs.

I'm running the game with the following specs: iMac 2.93 GHz Intel Core i7 / 8 GB ram / Lion OS. I have all EPs up to pets and my game is updated to the latest patch.

I'm not having any other weird graphic issues.

Is this a known glitch? If not, is there a way to solve it?

I would really appreciate any help since this it's becoming tiresome to see pets with "split" coats. Thanks!
Screenshots
Advertisement
In the Arena
staff: senior moderator
#2 Old 4th May 2012 at 4:59 AM
What graphics does the iMac have?
What version of Lion, 10.7.3?
Also, a picture of the settings you used in Options would also help - is Advanced Rendering on or off?

Thread moved.
Test Subject
Original Poster
#3 Old 4th May 2012 at 7:04 PM
1. ATI Radeon HD 5750 1024 MB
2. Exactly, 10.7.3. I try to keep both my iMac and my game always up to date.
3. I have tested the game with different settings and it keeps happening. I attach a picture of the ones I have right now.

Thanks a lot!
Screenshots
In the Arena
staff: senior moderator
#4 Old 5th May 2012 at 5:20 AM
The Edge Smoothing slider changes didn't change anything? Have you tried with a new Options.ini file? Just move or rename the current one, load game to regenerate. Perhaps all the tweaking messed up something in there.

But the OSX graphics drivers are so tied to the hardware it is hard to tweak things on Macs. Is there an AMD/ATI icon in Preferences? That allow any tweaking of the card features like Anti-aliasing options? If tweaking the Edge Smoothing option, didn't result in visible changes, that's just another confirmation the control is done at the hardware level. http://superuser.com/questions/1001...fat-on-mac-os-x

How did you get to 1.33? What was the previous version? Ever had 1.29? And do you usually patch via Launcher or manually?
According to this, 1.29 is supposed to have fixed this on Macs for this GPU model. But the PC version of 1.3x (direct superpatch) has issues and we have had to patch in a roundabout way - Q&A for "Issues with 1.3x Superpatcher" wiki FAQ.
I have yet to find anyone willing enough to Uninstall and reinstall and follow that long-winded way on OSX. I didn't push for it, simply because I believed OSX is not affected, but there are some other weird Mac-related reports that just give me a ping on my "maybe related to 1.3x superpatcher" radar...if one patch directly to 1.33 from unpatched 1.0 for instance, after an uninstall.
Test Subject
Original Poster
#5 Old 7th May 2012 at 12:07 AM
1. The edge smoothing slider changes the way the edges of sims can be seen, but does not affect the dog's texture issue I'm having.
2. I tried deleting the options.ini file as you suggested, unfortunately it didn't help.
3. There is no ATI button in preferences.
4. Well, maybe this is the issue since I did in fact superpatch my game. I played on a PC before pets, so when I moved to the imac I just installed the super patch to 1.33... I already tried to reinstall the game before this post to see if it would solve the issue, but it persisted so I guess patching in a roundabout way is the only thing left to try. I will post again as soon as I have the patience to do it.

Thank you for your help!
In the Arena
staff: senior moderator
#6 Old 7th May 2012 at 6:59 AM
You can adapt that FAQ to use the tgz files to do manual patching
  1. to 1.29 from 1.0
  2. to 1.33 from 1.29

If mac patch 1.33 has the collections folder for Showtime, if not, have to do it in the convulated way just like for PCs as shown in the FAQ.
  1. to 1.29 from 1.0
  2. to 1.31 from 1.29, assuming this patch add the Showtime Collection folder as it should
  3. to 1.33 from 1.31

If you had not archived and stored the .tgz files away (as our sticky advised), let me know so I can upload my archives to mediafire. EA only have the link to the current Mac patch; they don't archived old .tgz files like they do PC's .exe patches.
 
Back to top

Section jump