Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Summer Movie Night - posted on 13th Jun 2018 at 10:07 PM
Replies: 2 (Who?), Viewed: 3561 times.
Theorist
Original Poster
#1 Old 25th Oct 2014 at 3:24 AM Last edited by scumbumbo : 16th Jan 2016 at 10:19 PM. Reason: Uploaded to file downloads
Default TS4 XML Compare (outdated, now in uploads)
This is outdated - the latest version is now available in the file uploads: http://modthesims.info/download.php?t=570775

4 users say thanks for this. (Who?)
Advertisement
Theorist
Original Poster
#2 Old 5th Nov 2014 at 7:21 AM Last edited by scumbumbo : 16th Jan 2016 at 8:20 PM.
VERY IMPORTANT SAFETY TIP

Do NOT do what I just did. I tried to use this on the entire "interactions" folder. Windows choked, puked, and died a horrible BSOD as it tried to launch over 3000 processes of WinMerge! Very painful! Multiple files that were open at the time were corrupted by the crash.

Thankfully I have Windows 7 Ultimate and was able to recover the files on the "previous versions" tab in Windows folders properties.

Just use this on a single mod, maybe 50 or so XML files, at a time and you should be fine!

If you want to check a whole folder of the extracts, just use WinMerge by hand and it will run in a single process.

Clarification: You can, of course, use the entire XML extracts in the "OLD" and "NEW" folder fields, just don't put hundreds or thousands of files into the "Your XML File" - each of which launches a new instance of WinMerge.
Theorist
Original Poster
#3 Old 15th Jan 2015 at 4:29 PM
Just noticed a couple of bugs with the program while checking for required updates for the Jan. 13 patch. Apparantly if you use the "Open all files in one instance of WinMerge" option when checking more than 8 or 10 (don't know the exact number) of XML files it will silently close even though some files don't match up. I suggest turning off that option before checking XML, or at least testing it yourself - perhaps it's just my version of WinMerge that does that.

Also, there's a bug in the program I wrote that isn't saving that option, so the checkmark will reappear the next time you run the utility. I've fixed the bug, so if anyone is still interested I can update the file. Let me know.
Back to top