Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Changes to our credits guidelines - posted on 12th Feb 2017 at 5:44 PM
Replies: 3 (Who?), Viewed: 166 times.
Test Subject
Original Poster
#1 Old 17th Feb 2017 at 1:55 PM
Default Trouble trying to create a new texture for CC
Hello, I'm trying to create a Shyguy mask
I've found a few decent enough mask items, but they don't really have suitable textures for it, so I've been trying to make my own!

I guess I should say up front, this is about editing someone else's custom content, but it would be for my own personal use and I wouldn't be releasing it, unless the original creators gave permission.

The CC I have found that I'm trying to use is either the mask from ArtSims or TSR.
I can do the texture creation and stuff myself, but my problem comes in when I try to put said texture on the item. I've been using the CAS Texture Unitool, which I realize is pretty outdated, but I don't really know if there are any better alternatives that allow this sort of thing.

I'm getting errors with both of the items. With the Jason mask, when I go to edit the 'design' tab, I simply get a popup that says "Key is not in the correct format!" and I can't do much of anything.
With the 'Margiela Mask' I can do whatever, edit the textures and the designs and all, but when I replace the original texture with my custom one (or even with a copy of the same original texture) it loses the texture on the 3d model and when I select 'Find' it gives me a pop up saying "Could not find an image with key:00b2d882:00000000:E6245058DE3EADB7!" The fact that I'm getting this error regardless of what I replace the texture with leads me to believe I might be exporting the file incorrectly in GIMP or something?
I'd really appreciate a hand if anybody has any advice, and thanks for reading this!
Advertisement
MakeNeedsStaticOn
staff: moderator
#2 Old 17th Feb 2017 at 8:40 PM
You could try TSRW if this is your first time texturing something. Thing is though, if you edit something n CTU (like you open the downloaded package, and change the textures) it will override the original download, and IIRC, will become a default replacement.

Anyway, There are 2 ways to approach this. 1 of them is replacing them in S3PE. If you think your textures would do fine in-game and your textures won't cause any trouble, what I would do is open the package in S3PE, right click on the IMG file (make sure they look the same, so multiplier is always grey-ish so should yours) and then right click on the IMG file and use 'replace'. NOT import. CTU can be quite confusing. I used to have that issue too, and for some reason fixed it by just either redoing/removing the preset, or somehow replace it, and then click commit (and changing the colors?) That's how I did it. It will throw the same error though, but you should be able to see the changes in the 3D window

If you wanna know why CTU is acting this way, it's very likely that those objects are created in TSRW, and TSRW seems to make their own XML file (some sort of file that keeps all your color data, texture data, etc). While EA does the same thing, it's a bit more... organised. You'll find out if you ever wanna compare an ordinary EA XML file with a TSRW. ^-~ (I know that might sound kinda confusing, but it's really hard to explain.. heh)
Top Secret Researcher
#3 Old 18th Feb 2017 at 8:40 PM
Have you tried cloning the Jason mask in S3OC, making sure to tick "Renumber/rename internally"? I recall coming across something like this ages ago and that fixed it for me. Other than that, I second @Greenplumbbob 's suggestion of replacing the textures in S3PE; I don't think CTU really replaces textures, it just imports them and modifies the links to the new ones, but leaves the old textures in.

I also have a Simblr: sweetdevil-sims, where I post downloads!
If you have concerns about my stuff, please PM me! I see PMs much faster than thread comments :)
Test Subject
Original Poster
#4 Old 19th Feb 2017 at 4:31 PM
Using a combination of S3PE and CTU worked perfectly, thanks a lot, both of you!
Back to top