PDA

View Full Version : My adventures in modding aka What am I doing wrong?


The Wild Turkey
17th Aug 2011, 12:45 PM
Hi,

I'm trying to rewrite the job descriptions and titles for the Law Enforcement career, but for the life of me I just can not get my changes to appear in game. I've used the STBLizer to compile the edited template, then created a package file with S3PE. I'm setting the Type to 0x220557DA, left Group as 0x00000000 and have tried several different values for Instance, including but not limited to 0x0022BBAA01BBAA1F, 0x000F16B000000000, 0x000F16B00BA8342F. Even tried removing all my CC in case something was conflicting, to no avail. Am I doing something wrong with the Instance?

Lois99
17th Aug 2011, 1:17 PM
I am certainly no expert but I have gone through the exact same process with the exact same career in the last couple of days. To me it does sound like an instance issue. I have checked your 'Type' and 'Group' against what I have used and they match, so I'd say no error there (my career works just fine).

As I understand it, the instance number should be lower than the original in order to replace the original text. I used the FNV Hash tool to create my instance then changed the first two digits after the 0x to 00, for me that worked, but I may just have been lucky.

I am using the Instance 0x00CA0B7C23215925 in my career, incase you want to try an instance that you know works

Is the Law Enforcement Career working alright otherwise with your mod loaded?

I don't think I've been much help but perhaps someone will come along that actually reads hex. Hope you get it working

The Wild Turkey
17th Aug 2011, 1:43 PM
Tried your Instance, that one doesn't work for me either. Thanks anyway. Law Enforcement career works normally, as if my mod isn't even there.

Lois99
17th Aug 2011, 1:54 PM
That's odd. Hmm,

I'm not sure what else to sugest, just to make sure, you are double clicking the STBL file and entering the instance into the Resource Details box? (I'm pretty sure you are from what you've said but it doesn't hurt to check).

I'll take a look at the file if you want me to? see if I can see what's gone wrong

Lois99
17th Aug 2011, 4:46 PM
On further investigation, I see that you are absolutely right and that I have managed to break my Law Enforcement career (it was working perfectly, but I've been messing around with other careers since then so who knows what I did or when!) I've got mine working again with a new instance ( 0x00AE2C93FF5925BA ). If you want to try that number.

The other thing that ocurred to me is are you sure the career is not working? It is worth noting that the description that you get when you join up is not included in the template that is included with STBLiser, I added those lines to my new STBL from the game STBL. The lines you are looking for are ( 0x16EFD7451FC24B and 0x7935D1421E9EEF72 )

The Wild Turkey
18th Aug 2011, 12:04 AM
Thanks, I'll try the new number when I get home from work tonight.

I haven't touched the initial career description, just the titles and job desciption for the first few career levels, but when my sim joins the career it still shows up with the default title and desciption.

Perhaps if I can't get it working with the new number I might forward it to check it over, thanks.

The Wild Turkey
18th Aug 2011, 9:50 AM
That new instance of yours works! Thank you very much for your assistance, it's been very helpful. :)

Lois99
18th Aug 2011, 10:07 AM
Glad to hear you got it working :)