PDA

View Full Version : Gimp and 4-color patterns


Suncat
27th Sep 2010, 1:02 AM
Has anyone been successful in creating 4-color patterns with Gimp?

I've been able to make 1, 2 and 3-color patterns using the methods posted at here at MTS. But the moment I try to use an alpha channel, something goes wrong and whatever I put into the alpha channel then masks what's on the other three channels.

Yes, I'm sure I'm doing something wrong, but for the life of me I can't see what.

I should probably put up some screencaps to show exactly what I'm talking about. Will try to do so tomorrow.

Suncat
28th Sep 2010, 12:21 AM
Okay, I found the problem. It has to do with how GIMP handles the channel data when painting on an alpha channel. This may be a bug in GIMP, I don't know; I haven't dug into their bug reports yet. Or maybe it can be changed with a setting in GIMP that I don't know about yet. I do recall when I had a chance to use Photoshop some years ago that it didn't behave like this.

This problem occurs when you paint on all four channels. That is, you have added an Alpha channel to your empty image, then done the RGBA decomposition to get the four separate layers that you can actually paint on.

It seems that if you paint black on the Alpha channel layer, any edits you make in that same place on any of the other three layers will not be saved. If you recompose then decompose, only the Alpha edits from the last decompose session will reappear.

This seems like a bug to me. But until I learn more from the makers of GIMP, I'm just caring to find easy workarounds. Like, fully create my RGB channels, save the image and then add in the Alpha channels and then create the DDS file.

Or am I doing something really stupid with GIMP? I admit that these patterns are the first work I've done with the software.

eronoel
7th Nov 2010, 2:15 PM
GIMP can be kind of tricky with the four layers. I was able to make 4 layers but the dds image you save looks nothing like the end pattern because of the way GIMP saves the alpha layer. For example, I can only see the alpha layer on my DSS file, but when I import it into the packager, they all show up like they are supposed to.

This TSR tutorial was really helpful http://www.thesimsresource.com/workshop/articles/view-post/post/11925/Gimp%20Sims%203%20Pattern%20Tutorial

I don't know if there is a MTS tutorial, but I have seen several people metion that they were (or are) going to make one (correct me if I am wrong!)

Suncat
7th Nov 2010, 7:41 PM
You're right about the alpha layer. I really had to just trust the process, save the file, and load it into Pattern Packager. Then I calmed down.

I used this one: http://www.modthesims.info/wiki.php?title=Sims_3:Custom_Patterns by HystericalParoxysm. Thanks for the other link, I'll have to check it out.

madaline_7
15th Sep 2011, 6:01 AM
Okay, I found the problem. It has to do with how GIMP handles the channel data when painting on an alpha channel.

Gimp is wonky about the "background" layer. What I normally do before I start working on any project is create a new layer and then trash the "background" layer.

CloudWalkerNZ
15th Sep 2011, 7:47 AM
GIMP can be kind of tricky with the four layers. I was able to make 4 layers but the dds image you save looks nothing like the end pattern because of the way GIMP saves the alpha layer. For example, I can only see the alpha layer on my DSS file, but when I import it into the packager, they all show up like they are supposed to.

This TSR tutorial was really helpful http://www.thesimsresource.com/workshop/articles/view-post/post/11925/Gimp%20Sims%203%20Pattern%20Tutorial

I don't know if there is a MTS tutorial, but I have seen several people metion that they were (or are) going to make one (correct me if I am wrong!)

Thank you for that link :gjob: I have been trying to use the alpha channel on Gimp for months. I manage to find a few threads on the Gimp site but never quite manage to get it to work. I will try the tutorial later today.

I hope Gimp 2.8 will solve this problem soon. :Pint: