Replies: 123 (Who?), Viewed: 70701 times.
Page 4 of 5
Lab Assistant
#76 Old 27th Mar 2011 at 9:32 PM
Quote:
Originally Posted by Varnsen
Can't enable these without a core hack.
Can someone explain what this core hack is or how to enable it? Confused.com.


Hear, hear! How about a "Sims Medieval cheatcodes and how actually be able to enable and use them for dummies (and people of non-english languages)", pretty please!

If you try to fail, and succeed, which have you done?
Lab Assistant
#77 Old 27th Mar 2011 at 9:38 PM
Quote:
Originally Posted by Rick
Yes, it goes in your game directory. I'm sure I left a directory structure in the mod zip.

Oh okay, so i did do it right!! thanks and sorry for all my questions

Perry the Platypus
Scholar
#78 Old 27th Mar 2011 at 11:12 PM
Quote:
Originally Posted by Rick
Game commands, cheats:

You can enable these by editing X:\Path\To\The Sims Medieval\GameData\Shared\NonPackaged\Ini\Commands.ini and changing TestingCheatsEnabled=0 to TestingCheatsEnabled=1


I'm sorry to be stupid, but I can't seem to edit that. When I try, emacs tells me that the buffer is read-only. If I try it with Notepad++, it says it can't save the file.

Sorry to be so stupid, but how do you make the damned thing editable?

"You must be the change you want to see in the world." -- Gandhi
Test Subject
#79 Old 27th Mar 2011 at 11:13 PM
Are there any cheats for RESOURCES? Not resource points, but like, you know, rocks for the Blacksmith etc.
Lab Assistant
#80 Old 27th Mar 2011 at 11:14 PM
need to change it so its not read only.

if your using windows, right click the file, select properties, uncheck 'read only'
Field Researcher
#81 Old 28th Mar 2011 at 12:09 AM
Quote:
Originally Posted by Corylea
I'm sorry to be stupid, but I can't seem to edit that. When I try, emacs tells me that the buffer is read-only. If I try it with Notepad++, it says it can't save the file.

Sorry to be so stupid, but how do you make the damned thing editable?



See here at post #29.
I had the same problem, but Rick helped me out!

Good Luck!

Whatever you do, do it ALL for the glory of God. 1 Corinthians 10:31
My mission: To fill the gaps!
Follow me to The Keep! The PlumbBob Keep
Creations by G-Knee
Check out my NEW LiveJournal!
Field Researcher
#82 Old 28th Mar 2011 at 12:39 AM
NONE of these cheats work for me.......
Field Researcher
#83 Old 28th Mar 2011 at 1:38 AM
Quote:
Originally Posted by henryV111
NONE of these cheats work for me.......




If you follow these steps, it should work...no probs!

Whatever you do, do it ALL for the glory of God. 1 Corinthians 10:31
My mission: To fill the gaps!
Follow me to The Keep! The PlumbBob Keep
Creations by G-Knee
Check out my NEW LiveJournal!
Eminence Grise
#84 Old 28th Mar 2011 at 2:50 AM
For those asking about where to install mods:

If you download Rick's NoIntro mod, that contains a "resource.cfg" file and a "mods" folder. Drop both of those into the folder your game is installed in (the "The Sims Medieval" folder)... the location of which depends on where you installed it... but it's probably under Program Files/Electronic Arts. Then you can add any additional mods (.package files) into the Mods folder.

There's more than one version of the "resource.cfg" file around, btw... you may prefer Winterhart's version... basically what that file does is specify exactly what folders the game should look in for mods, and in what order.

For people who weren't around when TS3 released, btw, we still have the old mod install instructions up around here: http://www.modthesims.info/wiki.php...ckage_Files/Old

It's more or less the same, except with TSM, you don't need the .dll file mentioned there. At least, until we get script mods, then maybe we'll need something like that
Test Subject
#85 Old 28th Mar 2011 at 3:37 AM
I have done all the steps to edit the file and everything but after I save the Commands file it says it has to be burned to disk. Is that okay to do? Im not sure since it hasnt been mentioned at all, or if this is just a dumb question.
Field Researcher
#86 Old 28th Mar 2011 at 4:25 AM
Quote:
Originally Posted by jbeach34
If you follow these steps, it should work...no probs!

Thank you! DisableCostumeFiler STILL doesn't work, but the rest of the one's work! Thanks again!
Test Subject
#87 Old 28th Mar 2011 at 8:47 AM
I have a major problem. So I've looked EVERYWHERE in the Sims Medieval game file (where it is located on my MAC) and I can't find the command.ini file ANYWHERE. HELP!
Field Researcher
#88 Old 28th Mar 2011 at 10:17 AM
Quote:
Originally Posted by henryV111
Thank you! DisableCostumeFiler STILL doesn't work, but the rest of the one's work! Thanks again!


The correct cheat code is "disableclothingfilter on", not disablecostumefilter - so make sure you're typing in the right one.
Lab Assistant
#89 Old 28th Mar 2011 at 1:54 PM
If you have the core hack to enable cheats, how does one use the cheats "aging" and "ageuptonpc"? Is it possible to use them to age up the unplayable characters and what do you type to specify the intended sim? "ageuptonpc FirstName LastName"? Or do you include the awarded titles? Or does this not work at all and are there another cheat with my desired effect in that case? Questions, questons - all help is heartily welcome!

If you try to fail, and succeed, which have you done?
Test Subject
#90 Old 28th Mar 2011 at 6:16 PM
How works the "ageuptonpc" cheat? E.g when I'd like to make my prince or princess adult then he/she will be NPC without any relationships and connections to her mother (queen)?

And how turn on this cheat? I've got debuger and testingcheats enabled. What should I write after this code in console? Somone's name or smth?
Lab Assistant
#91 Old 28th Mar 2011 at 6:47 PM
I made my little prince selectable and tried to write "ageuptonpc". Nothing happened, except that he got this giraffe-neck in the ínteraction-avatar picture. I shift-clicked on him and selected a hero-career and he became this deformed... Thing. So it does not seem to work the way I would have wished...

If you try to fail, and succeed, which have you done?
Test Subject
#92 Old 28th Mar 2011 at 10:11 PM
Quote:
Originally Posted by Rick
The file is marked as read-only, as the dialog says. Try opening the file properties and unchecking read-only.


I tried to uncheck read only but it said that the access was refused, what can I do?
Test Subject
#93 Old 28th Mar 2011 at 10:44 PM
Does anyone know if there's a command that lets you delete objects placed in "buydebug" mode? If you place something, like say a window, and decide you don't want it later, it says "Can't Delete" and there doesn't seem to be a way to remove the object. Is there a command that allows you to delete these items once they have been placed? I tried killobject, moveobjects, and builddebug to no avail.

Help, please!
Instructor
#94 Old 28th Mar 2011 at 11:10 PM
Quote:
Originally Posted by mira_moone
I made my little prince selectable and tried to write "ageuptonpc". Nothing happened, except that he got this giraffe-neck in the ínteraction-avatar picture. I shift-clicked on him and selected a hero-career and he became this deformed... Thing. So it does not seem to work the way I would have wished...


*giggles* That's exactly what just happened to me. Okay, okay, I brought it upon myself. :P
My kid turned into a hideous out of proportion monster. At least I was finally able to change her clothes. Of course, her head is now floating above her body and it seems my suspicion regarding generic Sim children faces is confirmed by the default face she has ....

I think this may be a clue how "aging" is supposed to work in TSM (one day). Every life stage might be connected to your profession rank. Hero children would start out as "Princess", "Lil' Troubadour" etc. as they are now and then consequently complete tasks to grow up into Squires and what have you (equalling their teenage years) until they would become adults starting at the first level of their inherited profession. Makes sense? Heh, it does to me.
But maybe I'm simply seeing things.

Either way, I need an option to reset that poor kid, and fast! *chuckles*
Test Subject
#95 Old 30th Mar 2011 at 8:08 PM
Quote:
Originally Posted by Pat40
Maybe that's because I get a french version of TSM but I can't get the additional interactions with Shift-Click. I have TCE to 1 in commands.ini and debugenabler_1.1.10.00001.package in my mod folder. I have tried some commands like ShowAllQuests, PlaceAllBuildings, SetKP and they are all working very well. I don't know why Shift-Click is not working. Please excuse my English.

I have TSM in french too and when I install the game in english I have the additional interactions.
So, play in english with this mod or without in french ^^
Lab Assistant
#96 Old 31st Mar 2011 at 7:42 AM
I have copied this commands file to my desktop and still, it wont let me save the new changes I use windows 7

Dooglebear
Scholar
#97 Old 31st Mar 2011 at 1:24 PM
Quote:
Originally Posted by Dooglebear
I have copied this commands file to my desktop and still, it wont let me save the new changes I use windows 7


Have you right-clicked on it, and unticked the Read Only box? That's what I had to do in order to edit and save the changes in Notepad...

...Titanium white...
Test Subject
#98 Old 2nd Apr 2011 at 1:00 AM
Mine wouldn't save either. Save it to My Documents folder on your computer (if using PC) and then just drag it into the same exact place the original Commands.Ini is. It'll ask you to replace it, say yes..when you go back to read it it should be the one YOU saved in your My Documents folder and then trasnfered. Its a way of getting away EA's block.

DIRECTIONS (Simplified)
Go to Program Files
Go to Electronic Arts File
Go to your Sims Medieval Folder (or just search Sims Medieval, right click and push open file location)
Go to Game Data
Go to Shared
Go to Nonpackaged
Go to Ini
Right click Commands.Ini folder
Go to properties
Uncheck "read Only"
Right click again on folder
Choose....open with "notepad"
Highlight and copy text.
Open a new notepad
Paste Text
Save text as Commands.Ini in your My Documents folder on your computer (NOT in the game!)
Go to your My Documents folder
Copy folder or click and drag into the programs\Electronic Arts\The Sims Medieval\Game Data\Shared\Nonpackaged\Ini (also known as the folder the orignal Commands.Ini is in)
Click YES if asked to replace
Check to make sure it worked....then go right click, properties and recheck read only.

(If it didn't work trying saving the file under a different name in your My Documents....when you transfer it to the Ini folder both command.ini and the one you saved with the same text (except it has testingcheatsenabeld=1) will show up. Delete EA's so yours in the only one.)
Test Subject
#99 Old 2nd Apr 2011 at 1:01 AM
Quote:
Originally Posted by Enjoji
Have you right-clicked on it, and unticked the Read Only box? That's what I had to do in order to edit and save the changes in Notepad...


Mine wouldn't save either. But I finally figuered it out! Save it to My Documents folder on your computer (if using PC) and then just drag it into the same exact place the original Commands.Ini is. It'll ask you to replace it, say yes..when you go back to read it it should be the one YOU saved in your My Documents folder and then trasnfered. Its a way of getting away EA's block.

DIRECTIONS (Simplified)
Go to Program Files
Go to Electronic Arts File
Go to your Sims Medieval Folder (or just search Sims Medieval, right click and push open file location)
Go to Game Data
Go to Shared
Go to Nonpackaged
Go to Ini
Right click Commands.Ini folder
Go to properties
Uncheck "read Only"
Right click again on folder
Choose....open with "notepad"
Highlight and copy text.
Open a new notepad
Paste Text
Save text as Commands.Ini in your My Documents folder on your computer (NOT in the game!)
Go to your My Documents folder
Copy folder or click and drag into the programs\Electronic Arts\The Sims Medieval\Game Data\Shared\Nonpackaged\Ini (also known as the folder the orignal Commands.Ini is in)
Click YES if asked to replace
Check to make sure it worked....then go right click, properties and recheck read only.

(If it didn't work trying saving the file under a different name in your My Documents....when you transfer it to the Ini folder both command.ini and the one you saved with the same text (except it has testingcheatsenabeld=1) will show up. Delete EA's so yours in the only one.)
Test Subject
#100 Old 8th Apr 2011 at 9:00 PM
Hello, MTS-community!
Firstly I was pretty disappointed that the Sims Medieval didn't appear to have a cameraman mode which is very important to make machinimas, but now I found out that you can activate it with "testingcheats" enabled and the cheat "videoMakerModeenabled true" and it works! =D
Plus I saw in the camera.ini folder that there is a value for lerpduration (the time the camera needs to move from one saved position to another) - however I just can't find out how to save the different camera positions O-O In Sims 2/3 it was always pressing ctrl + a number from 5-9 but it doesn't work this way in Medieval =( Does anybody have a clue how this works? I mean there MUST be a way, cause otherwise lerpduration wouldn't be there, would it?
Page 4 of 5
Back to top