Replies: 95 (Who?), Viewed: 97078 times.
Page 3 of 4
Site Helper
#51 Old 25th Aug 2009 at 7:46 PM Last edited by Mootilda : 25th Aug 2009 at 8:19 PM.
Quote:
Originally Posted by willow2u
I changed some values
Here's the issue: we need to determine whether your problem is with the technique described in the tutorial, in which case this is the correct place to post, or whether your problem is incorrect programming, in which case this is not the correct place to ask for assistance.

My suggestion would be to run through the steps without making any code changes.

If you continue to have problems with no code changes, then report back here.

However if the technique works with no code changes, then the problem is with your source code changes. Help with programming is outside the scope of this thread. You'll probably want to start a new thread for help with your programming issues, although you may not have much luck getting core programming help.

If you do start a new thread, you'll need to explain to people what you're trying to accomplish, and exactly what you believe that you've changed in the code, along with the actual code change. If you decompiled to C++, you might want to include both the C++ code and the assembly code.

Using the techniques in this tutorial to extract, disassmble, decompile, change, recompile, assemble and import the DLLs is the easy part of making a core mod. Getting the code right, so that the game behaves as you want it to, is the difficult part.
Lab Assistant
#52 Old 26th Aug 2009 at 7:59 PM
Hmm, nice. It's still a little intimidating for me, but I will definitely give it a shot.

I miss my risky woohoo and miscarriages from Inteenimator. I really want them in TS3.

I write Sims stories and do YouTube videos, too!

Check out my YouTube channel here.

You can read my stories here.

Oh and I have this nifty thing called a Simblr, too. Find it here.
Lab Assistant
#53 Old 27th Aug 2009 at 6:07 AM Last edited by Ashleigh825 : 27th Aug 2009 at 6:30 AM. Reason: Because posting three times in a row is idiotic.
Oh, I just noticed that your link to S3PE doesn't work. I just get a 404 error message when I click the link.

EDIT: I also seem to be having trouble opening NotePad ++ (leave it to me to get stumped on the very first step... d'ur...) I can't find the notepad++.exe file anywhere.

I write Sims stories and do YouTube videos, too!

Check out my YouTube channel here.

You can read my stories here.

Oh and I have this nifty thing called a Simblr, too. Find it here.
Field Researcher
#54 Old 27th Aug 2009 at 7:11 AM
S3PE is actually on these forums now!

http://www.modthesims.info/forumdisplay.php?f=604

Also, Notepad++ is a completely different program to Notepad. You have to download it, or you can just stick to ordinary Notepad :D
Lab Assistant
#55 Old 27th Aug 2009 at 8:08 AM Last edited by Ashleigh825 : 27th Aug 2009 at 10:09 AM.
Quote:
Originally Posted by channTL
s3pe is actually on these forums now!

http://www.modthesims.info/forumdisplay.php?f=604

Also, Notepad++ is a completely different program to Notepad. You have to download it, or you can just stick to ordinary Notepad :D


Thanks very much. I'll go download S3PE now.

I did download Notepad ++, just for some reason, I can't find how to actually install it. >.<

EDIT:

Wow... looks like someone really doesn't want me to mod this game. I get this when I try to install the .NET thingy (to get the ildasm files).



I have no idea what this means.

I write Sims stories and do YouTube videos, too!

Check out my YouTube channel here.

You can read my stories here.

Oh and I have this nifty thing called a Simblr, too. Find it here.
Test Subject
#56 Old 27th Aug 2009 at 3:02 PM
Quote:
Originally Posted by Mootilda

My suggestion would be to run through the steps without making any code changes.

If you continue to have problems with no code changes, then report back here.



Thanks for the reminder (KISS - Keep It Simple Stupid). It is something that one usually forgets.

So it's back to reading the msil manual for me...

Learing is so Fun

Thanks for the tutorial
Lab Assistant
#57 Old 21st Nov 2009 at 5:33 PM
Btw, I copied those 5 files (fusion.dll, ildasm.exe, etc.) to the windows\system32 folder, and I was able to use the command in cmd without a problem.

Regards,

Drakah
shakahr.com
Forum Resident
#58 Old 13th Dec 2009 at 7:38 AM Last edited by NekoCat : 13th Dec 2009 at 5:11 PM.
I wasn't sure whether to post this problem here or in the S3PE forum... so here it goes. The problem is that I get an error, but I don't know if it is a SimPE problem or if the directions (which are several months old) are wrong. That is, the directions for creating a package using SimPE have changed since this tutorial was written. Any ideas?

I was able to create the dll with no problems (checked it in Reflector and value looks okay), but I can't create a package file. The problem is the following instruction:

" re-open the original gameplay.package (in a new window of S3PE, for your convenience) and find the file you exported before. Now, in the other S3PE window, your new package window (DO NOT ADD ANYTHING TO THE ORIGINAL GAMEPLAY.PACKAGE FILE! Your sims will all die horrible deaths and so will your computer.) go to Resource > Add Resource, and copy in the Type and Instance from the file in gameplay.package EXACTLY. The group should simply be "0x00000000" (that's zero x and 8 zeros). After you've added the resource, select it, and Grid > Import, choose the ILASM'ed DLL and commit, then save, put the package in your mods directory, making sure there's no other core mods present (as they will almost certainly conflict) and you're done!"

As per the directions, I loaded a second instance of S3PE, File -> New and Resource -> Add, typed the values and clicked OK. However, the following error shows up (I'm using the latest SimPE -0912-10-1844 )

************** Exception Text **************
System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex
at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
at System.Convert.ToByte(String value, Int32 fromBase)
at S3PIDemoFE.ResourceDetails.get_EpFlags()
at S3PIDemoFE.MainForm.NewResource(IResourceKey rk, MemoryStream ms, Boolean replace, Boolean compress)
at S3PIDemoFE.MainForm.resourceAdd()
at S3PIDemoFE.MainForm.menuBarWidget1_MBResource_Click(Object sender, MBClickEventArgs mn)
at S3PIDemoFE.MenuBarWidget.OnMBResource_Click(Object sender, MB mn)
at S3PIDemoFE.MenuBarWidget.tsMBR_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


--- edited to correct - was calling S3PE by the wrong name

My cat taught me how to fetch. I throw the toy, she shows me where it landed, and I fetch it.
Site Helper
#59 Old 13th Dec 2009 at 5:03 PM
SimPE is a program for editing TS2 files. I assume that you are trying to edit TS3 files, so you need S3PE.

Quote:
Originally Posted by NekoCat
************** Exception Text **************
System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex
at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
Assuming that you are actually using S3PE, this is saying that a value that you are using is out of range. Check that you typed in the values correctly, especially that you included the "0x" prefix to let the program know that you are typing a hex value.
Forum Resident
#60 Old 13th Dec 2009 at 5:09 PM Last edited by NekoCat : 14th Dec 2009 at 6:00 PM.
I meant S3PE, actually. I called it SimPE out of habit, I guess.

I attached a screenshot of the values I'm entering in the Resource -> Add window. Is there something I'm missing?


Edit - Workaround

I decided to try Chikitulfo's method (post 50) and it worked. I was able to add my dll and create the package. Now all I have to do is figure out why my core mod doesn't work - but that's outside the focus of this thread :D
Screenshots

My cat taught me how to fetch. I throw the toy, she shows me where it landed, and I fetch it.
Test Subject
#61 Old 19th Dec 2009 at 3:11 AM
i have win7 x64 and net frame stuff installed but i cant find the islam stuff
Lab Assistant
#62 Old 31st Dec 2009 at 5:59 AM
Hi all

I'm glad to say I was able to follow the tutorial and edit the no shoo values, all the way till the end, but my game crashes using the edited gameplay i replaced in my game/bin folder. Would someone please help by giving me a few pointers about where I might have gone wrong and point me in the right direction please?

Btw, I used "door number 1" and just imported. I only changed the part that dealt with general privacy.

Thanks first to bailabaila for making this tutorial, and lemmy for helping. Would really love to learn how to do this myself successfully. Thanks again in advance for your time and consideration!
nb: have base game. no patches. and no WA. (yet i was hoping to get it for xmas... )
Instructor
#63 Old 31st Dec 2009 at 5:33 PM
Can anybody point me in the right direction?
I have found ildasm.exe in the correct directory, but ildasm.exe.config is not there?
Any help is appreciated!

(())Pass the ribbon around if you know someone that has
//\\survived, died, or is living with cancer.
Lab Assistant
#64 Old 31st Dec 2009 at 6:14 PM
@ Fawkes, do you have .NET Framework 2.0 Software Development Kit (SDK) (x86) installed?
Instructor
#65 Old 31st Dec 2009 at 6:13 PM
I believe i do.. Ill double check.

(())Pass the ribbon around if you know someone that has
//\\survived, died, or is living with cancer.
Lab Assistant
#66 Old 31st Dec 2009 at 6:48 PM
@ fawkes, if you do you could try Program Files\Microsoft.NET\SDK\v2.0\Bin or just do a search for SDK
Instructor
#67 Old 31st Dec 2009 at 7:00 PM
I do, but the ildasm.exe.config still doesnt show up in any folders? when i search fo it, it shows up saying its there, but when i go to the indicated folder, I cant find it, and it doesn't even showing if i view all hidden files?

EDIT: I believe i found it. Thanks babyopheilia!

(())Pass the ribbon around if you know someone that has
//\\survived, died, or is living with cancer.
Lab Assistant
#68 Old 31st Dec 2009 at 7:47 PM
alrighty! now if only someone could help me with my problem...
Instructor
#69 Old 31st Dec 2009 at 8:24 PM
I wish i could help you Opheilia, but i really am stumped after reading your signature...
I really hope you can find whats happening!

On a lighter note, thanks for this tutorial! It was absolutely great and i successfully made a facial slider mod thats compatible up to patch 1.8!

(())Pass the ribbon around if you know someone that has
//\\survived, died, or is living with cancer.
Lab Assistant
#70 Old 31st Dec 2009 at 9:02 PM
bought my copy of sims 3 from ebay from a seller shipping from thailand.... makes me sad that the wait was like 3 weeks and now it is not working as smoothly as i hoped it would. the game came in the case and shrinkwrapped and looked brand new so i'm really hoping it's a legit copy and that the reason i'm having problems is because of my incompetence. (also bought WA myself after NOT getting it for christmas from the same seller...)

i'm gonna take my mind off sims 3 now and try to learn making objects for sims 2. till someone is willing to help me find a solution that is, or till WA comes in the mail and i'll try patching up my sims 3 again... whichever is first.

edit: reason i'm trying to make my own mods is because non of the ones i tried worked or they're only compatible with patched games. I've come across different resource.cfg files and the dll files you're supposed to have for framework, and i've tried different combinations of them. I don't know much about this but from what i've gleaned after hours of reading threads of other people's problems it seems that there a small code changes in these files for different patches and that i need to find the one for un-patched basegame. I did have a combo that made the "buy-all-fish" and the skill increase books work and show up in the game but now they're gone and I will have to try to fix that later. I've reading up everyone on sims 3 for about 2 weeks now. it's time for some sims 2 again.
Instructor
#71 Old 31st Dec 2009 at 9:33 PM
I feel bad for you babyopheilia. The only thing that pops out at me is that it might not be a legitimate copy of the game. I wish i could be of more help

(())Pass the ribbon around if you know someone that has
//\\survived, died, or is living with cancer.
Lab Assistant
#72 Old 2nd Jan 2010 at 11:33 PM
waiting for my game to arrive in the mail. i've learned to do some tuning mods myself now, that was really fun. but i couldn't tweak the woohoo for teens, or maybe i haven't found the string, maybe someone who did this can tell me where to look?
Test Subject
#73 Old 9th Jan 2010 at 10:55 AM
When i try to search for
<prop name="Comment" propid="Comment" type="string" value="Muscle Blend" />
and
<prop name="Comment" propid="Comment" type="string" value="Thin/Heavy Blend" />
The button Search can't be clicked.
Test Subject
#74 Old 22nd Mar 2010 at 11:55 PM
...Wow... nice
Test Subject
#75 Old 2nd Apr 2010 at 10:05 PM Last edited by Codester : 2nd Apr 2010 at 10:27 PM.
After following the tutorial, I get a "FLAGRANT SYSTEM ERROR!". At first, I thought it was a typo in the change I made to the Sims3GameplaySystems.dll that is embedded in my package, but it happens with no changes at all as well. If I simply use ILDASM to generate the IL file, and then use ILASM to put it back, unmodified, into the dll, the error occurs. Do I need to do anything different if I'm on a Win 7 x64 system? I tried searching on the site, but everything seems to pertain to other mods, not how to correct my own. :P

EDIT: This seems to happen only when I'm using Awesome Mod as the base and trying to add my change to it. If I create a new package with just my change in it, it works fine.
Page 3 of 4
Back to top