Replies: 109 (Who?), Viewed: 247788 times.
Page 3 of 5
Test Subject
#51 Old 28th Mar 2010 at 12:24 AM
I am having the same issue as traelia. I can export the .geom files, but the CTU will only take .simgeom files. I followed the links you gave Ceixari, but those don't seem to have anything on conversion. Is is possible to change these with a third program?
#52 Old 28th Mar 2010 at 4:22 PM
I get this too, It lets you load if you rename it to a simgeom but yeah doesn't work when loading into CTU (Unless I'm doing something else wrong which is very likely)

Please help me

Hi I'm Paul!
The Attack Cat
retired moderator
#53 Old 9th Apr 2010 at 11:52 PM
I'm attempting a blender meshing tutorial. It's not really finished yet but since you sound as in need of help as I was you can view it.
Test Subject
#54 Old 22nd Jul 2010 at 1:00 PM
I dont have a scripts file in the blender folder. I tried making one but it doesnt work, what should i do?
Test Subject
23rd Jul 2010 at 9:53 PM
This message has been deleted by yk1980.
Test Subject
#55 Old 29th Jul 2010 at 7:36 PM
i keep trying to import a .geom, but it keeps telling me this in the console:

Compiled with Python version 2.6.1.
' import site' failed; use -v for traceback
Checking for installed Python... No installed Python found.
Only built-in modules are available. Some scripts may not run.
Continuing happily.
Traceback <most recent call last>:
File "<string>"', line 1, in <module>
File "C:\Users\Matt\Desktop\Blender\.blender\scripts\", line 46'
in <module>
import struct
ImportError: no module named struct

What do I do?
#56 Old 29th Jul 2010 at 10:27 PM
Looks like you don't have python installed? You need it for blender scripts.
Test Subject
#57 Old 5th Aug 2010 at 12:40 AM
Hi, I'm a mac user and I've been trying to mesh with blender. I'm having an exporting issue: I can import, create the mesh, and save just fine, but when I try to export, blender quits. I have the latest version of python and I think I installed the plugins correctly. Does anyone else have this problem? Is it a mac thing?

I would REALLY appreciate help.
Thanks in advance!
Test Subject
#58 Old 8th Aug 2010 at 11:24 PM Last edited by razz1622 : 11th Aug 2010 at 6:37 PM.
i'm still kinda new to all this, and i was wondering where the Blender/.blender/scripts folder is. I checked my whole computer but i couldn't find it. not sure if this will help, but i have v.2.53


i think i figured it out. when i downloaded Blender, the file was messed up so it didnt include everything :p

no one can be as awesome as me
Test Subject
#59 Old 10th Aug 2010 at 11:12 PM
do we have to use CTU or Simpe? can we use TSR workshop
Test Subject
#60 Old 29th Aug 2010 at 6:56 AM
Awesome May I ask, however, what is a python file?
Née whiterider
retired moderator
#61 Old 29th Aug 2010 at 11:48 AM
dede9197, TSRW doesn't include a WSO plugin for Blender, so no, you can't use TSRW with Blender.

Songbird21, python is a coding language. The files in the zips are .py files, aka python files.

What I lack in decorum, I make up for with an absence of tact.
Test Subject
#62 Old 1st Sep 2010 at 2:24 AM
Thank you so much for this. I really appreaciate it
Test Subject
#63 Old 5th Sep 2010 at 11:38 AM
thank you for this script. but i wasn't able to export my own UVs, after creating my objeckt. is there a way to export the UVs changes?
Test Subject
#64 Old 28th Sep 2010 at 2:58 AM
Default Blender 2.5 Beta
I've tried adding the plugin to the new 2.54 beta version of blender with no luck. I suspect it may have something to do with the fact that they've changed their plugin path structure. Just thought it might be nice to address this, as the new interface for blender is a lot more user friendly, and (being free) I suspect it may become more popular with modders if the learning curve is not as hard as it's been in the past.
Test Subject
#65 Old 28th Sep 2010 at 3:13 AM
one error I got in blender 2.49 (that does load the plugin) was "scene.getChildren() deprecated! use scene.objects instead". I also see no skeleton behind the glasses like I see in the milkshape tutorial.
#66 Old 28th Sep 2010 at 3:16 AM
Trust me...the learning curve on it is still nowhere near as easy as MS is so the question as to whether S3 creators are gonna go for it is an open one. It hasn't even been fully documented yet which is another thing. The new interface is nice but is more like a nod to people who want a kind of standard still seems very oriented to knowing (memorizing) all these keyboard things.

Added in to that is the problem of the plugins...neither the object or CAS stuff plugins work with it so everything made with it is gonna have to go through MS with all the problems inherent in that. Neither of the people who made the plugins seem too active right now so that's another open question.

That said, the thing is very, very attractive and not just because of the price tag
Test Subject
#67 Old 28th Sep 2010 at 3:50 AM
So in other words, I'm better of just forgetting blender for now and focusing on milkshape if I want to do Sims3 mods?
#68 Old 28th Sep 2010 at 12:03 PM
I wouldn't say that...if you're familiar with Blender there's no reason not to use it. If you want to avoid MS altogether isn't it possible to keep an older version of Blender just for the import/export process?

I know that answer isn't optimal but couldn't you get the benefit of the new Blender version while also still being able to manage all the s3 related joint assignment/importation/exportation steps in the Blender version the plugins work for that way?

This might be a necessary compromise if you want to use the new Blender seeing as the person who wrote the GEOM plugin for it appears to not be actively working on S3 projects right now.
Test Subject
#69 Old 28th Sep 2010 at 2:22 PM
Well that's what I was wondering. In the MS tutorial, when Wes exported the Sunglasses, you ended up with a package that contained the GEOM, two texture images, and the skeleton, and he had instructions for how to export those parts and rename them. When he imported it into MS, you got both the glasses mesh and the bones. When I import the GEOM into the old blender, I don't see any bones (tried seeing if they were in the hierarchy and just needed turned on to see them, but no). I'm not sure if the blender plugin ever allowed for that, and whether it's necessary -- I'm guessing it will just use the same bones as the original, but you just can't see them while editing?

Sorry if I'm making it more confusing than it needs to be -- I'm just going through the tutorials in alphabetical order, so General CAS Tutorials was first, with "Modifying a TS3 body mesh by WesHowe" as the top, and already I'm having trouble since the tutorial is all with MS and I'm trying to do the same with Blender.

Is there a better order to go for new sims modders than starting with Body Meshes?
#70 Old 28th Sep 2010 at 10:30 PM
If you're wanting to use Blender to mesh for S3 there is a Blender group here at MTS which is here:

and maybe they can answer some of your Blender-specific questions. I know there is a way of making CAS items using Blender but I'm not familiar with either well enough to help with that...sorry.

In terms of being new to S3 modding my own bias is to say that trying your hand at objects first would be easier for several reasons. First off, most objects have only one joint to assign so that's easier right away. Second, documentation on how to create objects is more complete (IMO) than documentation on how to create clothes, accessories, hair, and etc. Of course if your heart is set on creating CAS parts then nothing else will do Most people seem to learn by going through tutorials on meshing similar things for S2, HP's S3 hair tutorial and a few others. But, to my knowledge, there is no start to finish tutorial that really gets you all set like Ella's tutorial for S3 object making will if you begin with objects.
Test Subject
#71 Old 27th Oct 2010 at 8:32 PM
I can't find the .blender/scripts folders??? HELP????
#72 Old 28th Oct 2010 at 1:45 AM
I'm on Windows 7 and it's here:

C:\Users\<user name>\AppData\Roaming\Blender Foundation\Blender\.blender\scripts

If you're on Vista or XP it might be different. It might be under: C:\Documents and Settings\<user name>\Application Data\Roaming\Blender Foundation\Blender\.blender\scripts
or something like that.
Test Subject
#73 Old 24th Dec 2010 at 11:08 AM
Hi just a bit of help.
I am new to the scene and even though I've been reading and rereading all these lovely comments I am still stuck.
I extracted the .rar files to a folder I created (in an effort to keep organized :D) and now I dont know what to do, haha. Technical talk is kind of going over my head but I'm willing to learn.
Test Subject
#74 Old 28th Jan 2011 at 9:31 PM
Thank you for sharing it!
Test Subject
#75 Old 10th Apr 2011 at 5:04 AM
guys i get this error when i click the import geom thing please respond
Trackback (most recent call last):
File "<String>:, Line 1, in <module>
File "C:\Users\mehname\AppData\Roaming\Blender Foundation\Blender\.blender\scripts\, line 46, in<module>
import struct
importerror: No module named struct
Page 3 of 5
Back to top