Replies: 52 (Who?), Viewed: 5337 times.
Page 1 of 3
Scholar
Original Poster
#1 Old 14th Jan 2018 at 6:59 PM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Game won't boot up w/ NVIDIA card
Hi there! I got a new laptop in like, July, I think? I posted about this, it didn't work, I gave up. But now I'm in a mood. Sims 2 (Ultimate Collection) is really weird on this laptop, and I have no idea how to fix it. I have Intel integrated graphics and an NVIDIA 1050 Ti card. Whenever I choose Sims 2 to run with my NVIDIA card in windowed mode, the screen is entirely white, with a weirdly small window and my cursor like normal. Music plays and I can click on things. If I boot it in fullscreen, it just says that there is no DirectX compatible drivers. When I boot it with Intel, it functions fine, although obviously ugly and probably ready to explode if I did any actual gameplay. (Also, it gives me no window options and it says it's, like, 320x400 i think? Obviously, it's not, but it's still smaller than the default.)

I have...
Installed new graphics rules cards from Leefish
Used the Graphics Rules Maker to put all settings to max
Repaired my game with Origin
Uninstalled and reinstalled my NVIDIA card entirely
And nothing worked!

Angela and Lilith both deserve better, actually. | My Simblr!
Advertisement
Mad Poster
#2 Old 15th Jan 2018 at 6:23 AM
Did you try to delete the cache files before starting the game?
Scholar
Original Poster
#3 Old 17th Jan 2018 at 7:24 PM Last edited by alljoj : 17th Jan 2018 at 8:00 PM. Reason: Formatting WTF
*quiet cursing* No, I forgot to. As I am checking the forums outside of my house, I’ll try when I get home.

Angela and Lilith both deserve better, actually. | My Simblr!
Scholar
Original Poster
#4 Old 18th Jan 2018 at 1:53 AM
I'm sorry to double post, but I have a new problem and I don't wanna open a new thread. Although the game boots, it's still running in 320x200. Graphics also still look terrible.


Angela and Lilith both deserve better, actually. | My Simblr!
Needs Coffee
retired moderator
#5 Old 18th Jan 2018 at 2:15 AM
What are your computer specs?

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Scholar
Original Poster
#6 Old 18th Jan 2018 at 2:40 AM
I'm sorry if this isn't what you were looking for, but I'm tired and frustrated.

Windows 10, 16 GB RAM, Intel i7-7700Q CPU with a 2.80 GHz processor. And I'm using that graphics card I mentioned earlier. It should be well above the requirements, which is why I'm so confused.

Angela and Lilith both deserve better, actually. | My Simblr!
Turquoise Dragon
retired moderator
#7 Old 18th Jan 2018 at 2:51 AM
did you go into your device manager and make sure that is the graphics card that is chosen for default?
Scholar
Original Poster
#8 Old 18th Jan 2018 at 2:59 AM
The NVIDIA card is what I chose to run it with.

Angela and Lilith both deserve better, actually. | My Simblr!
Lab Assistant
#9 Old 18th Jan 2018 at 5:24 AM
You will need to alter the graphic rules and video card files by hand. Graphic rules doesn't completely solve the issue for higher Nvidia cards. That is why you only have the 320x200 resolution. Instructions here. http://simlili.tumblr.com/post/146373494212

I have had to do this several times, for different cards.
Mad Poster
#10 Old 18th Jan 2018 at 9:49 AM
When you've fixed graphic rules and the video card things - make sure Nvidia has the right settings, too.

I've had a related issue with Nvidia, where the game runs fine on the card, then suddenly wouldn't run on it at all, and setting the game to run on the card wouldn't work.

The solution was to go to the Nvidia panel, in the "3D settings --> Glonal settings", and set the "main graphic processor" to "Nvidia with high performance". In the other tab, "Program settings", you may have to choose Sims 2 (Whatever EXE file that's at the end of the shortcut you're using, if that makes sense), and set this to the same setting, "Nvidia with high performance".

In the "3D settings --> Adjust image settings with preview", set the game to "Use advanced 3D settings" (and set these to whatever suits you), OR "Use my prefrence on ... Balanced"

It's possible you may need different settings than I do, but this is just meant as a rough guide. Also, my Nvidia panel is not in English, so I've roughly translated above. It's possilbe some of the lines are different.
Scholar
Original Poster
#11 Old 18th Jan 2018 at 11:08 PM
I removed the Documents folder and the screen resolution went back to 800x600 or whatever, but still displaying 320x200 as the only option. And with the gross graphics. However, after doing the last step on the Tumblr link and doing the NVIDIA thing with setting the card, it's back to completely white... yay. I don't know which step caused this, but it's probably the first thing I did.

Angela and Lilith both deserve better, actually. | My Simblr!
Lab Assistant
#12 Old 19th Jan 2018 at 5:27 AM
Quote:
Originally Posted by alljoj
I removed the Documents folder and the screen resolution went back to 800x600 or whatever, but still displaying 320x200 as the only option. And with the gross graphics. However, after doing the last step on the Tumblr link and doing the NVIDIA thing with setting the card, it's back to completely white... yay. I don't know which step caused this, but it's probably the first thing I did.


The neighborhood is completely white? I didn't have that happen in 2, but that did happen to me in 3. It was a graphics issue there, I messed up adding my card to it. Did you do all the steps? You need to alter the graphic rules for the screen resolution, and the video card file for your card. You need to do this in both the Config and CSConfig files.
Not actually evil.
#13 Old 19th Jan 2018 at 6:03 AM
Quote:
Originally Posted by simmer22
When you've fixed graphic rules and the video card things - make sure Nvidia has the right settings, too.

I've had a related issue with Nvidia, where the game runs fine on the card, then suddenly wouldn't run on it at all, and setting the game to run on the card wouldn't work.

The solution was to go to the Nvidia panel, in the "3D settings --> Glonal settings", and set the "main graphic processor" to "Nvidia with high performance". In the other tab, "Program settings", you may have to choose Sims 2 (Whatever EXE file that's at the end of the shortcut you're using, if that makes sense), and set this to the same setting, "Nvidia with high performance".

In the "3D settings --> Adjust image settings with preview", set the game to "Use advanced 3D settings" (and set these to whatever suits you), OR "Use my prefrence on ... Balanced"

It's possible you may need different settings than I do, but this is just meant as a rough guide. Also, my Nvidia panel is not in English, so I've roughly translated above. It's possilbe some of the lines are different.


Where do I find the NVidia panel? Is it Start Menu, NVidia, GeForce Experience or is it somewhere else? Thank you.

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Lab Assistant
#14 Old 19th Jan 2018 at 6:33 AM
Quote:
Originally Posted by CatOfEvilGenius
Where do I find the NVidia panel? Is it Start Menu, NVidia, GeForce Experience or is it somewhere else? Thank you.


Right click on your desktop, then choose Nvidia control panel from the drop down menu.
Scholar
Original Poster
#15 Old 19th Jan 2018 at 12:38 PM
No, the neighborhood isn't completely white, the entire screen is.


Angela and Lilith both deserve better, actually. | My Simblr!
Not actually evil.
#16 Old 19th Jan 2018 at 8:11 PM
Not sure if this will help, but gwynne just posted in another thread that folks with Origin updated UC, NVidia GTX cards and Windows update versions 1700+ seem to be having similar problems. She said to keep an eye on the thread at leefish about it.

@Jules1111 - Thank you, now I know where to look! Maybe you can add that suggestion to the leefish post for folks like me who didn't know to look there and are having similar issues.

@alljoy - I didn't know where to check which Windows update I have so gwynne said Windows search box, type about, select About Your PC, then look at Windows Specifications. I have update 1709 and so does gwynne. Folks with 1700 and 1800 Windows updated and updated UC are having issues. You repaired so you have the latest updated Origin version so maybe you're in this boat?

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Scholar
Original Poster
#17 Old 19th Jan 2018 at 10:04 PM
Yes, I have Windows update 1709, but this problem was happening back in July-August when I got the computer, and it doesn't seem to be the same issue.

Angela and Lilith both deserve better, actually. | My Simblr!
Lab Assistant
#18 Old 19th Jan 2018 at 11:35 PM
Quote:
Originally Posted by alljoj
No, the neighborhood isn't completely white, the entire screen is.

**snip**


Ok, I have never seen or heard about anything like this before. That is strange to say the least. I have no idea what would cause that.
Scholar
Original Poster
#19 Old 19th Jan 2018 at 11:41 PM
After doing some googling, I found a support thread on Steam about that issue happening in Dark Souls-- so this is probably an issue with my graphics card. I reinstalled the game because I'm paranoid on another drive, ran the Graphics Rules Maker, and it now seems to be in the highest resolution. But this is progress!

ETA: I got into the game with integrated graphics and started a new neighborhood to see if it had all of the options, but it freezes when I launch a neighborhood and I have to close it.

Angela and Lilith both deserve better, actually. | My Simblr!
Lab Assistant
#20 Old 20th Jan 2018 at 12:00 AM
Quote:
Originally Posted by alljoj
After doing some googling, I found a support thread on Steam about that issue happening in Dark Souls-- so this is probably an issue with my graphics card. I reinstalled the game because I'm paranoid on another drive, ran the Graphics Rules Maker, and it now seems to be in the highest resolution. But this is progress!

ETA: I got into the game with integrated graphics and started a new neighborhood to see if it had all of the options, but it freezes when I launch a neighborhood and I have to close it.


Progress is good! You might have to alter your video card file. When you ran the graphic rules, did you do so for the intel or Nvidia card?
Scholar
Original Poster
#21 Old 20th Jan 2018 at 12:08 AM Last edited by alljoj : 20th Jan 2018 at 1:16 AM.
I added both of my video cards to the database, if that's what you mean.

Edit: After a bit of poking around, I kind of want to focus on the error that pops up in fullscreen mode. As I stated earlier, it has an error about DirectX popping up. Well, this is what the error says. I think that it may just be a lost cause, unless I want ancient drivers.


Angela and Lilith both deserve better, actually. | My Simblr!
Lab Assistant
#22 Old 20th Jan 2018 at 1:19 AM
Quote:
Originally Posted by alljoj
I added both of my video cards to the database, if that's what you mean.

Edit: After a bit of poking around, I kind of want to focus on the error that pops up in fullscreen mode. As I stated earlier, it has an error about DirectX popping up. Well, this is what the error says. I think that it may just be a lost cause, unless I want ancient drivers.



This error pops up when the game is not recognizing your graphics card. It actually has nothing to do with direct x despite what it says. The game is confused lol.
Scholar
Original Poster
#23 Old 20th Jan 2018 at 1:26 AM
Oh! Well, I already added my graphics card to the database with Graphics Rules Maker, so I don't know what to do on that front. Is there another thing I need to do?

Angela and Lilith both deserve better, actually. | My Simblr!
Not actually evil.
#24 Old 20th Jan 2018 at 1:37 AM
Quote:
Originally Posted by alljoj
Oh! Well, I already added my graphics card to the database with Graphics Rules Maker, so I don't know what to do on that front. Is there another thing I need to do?


I don't know but you might try uploading your sgr files and config log from the Logs directory. Maybe folks might find something in there?

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Lab Assistant
#25 Old 20th Jan 2018 at 1:40 AM
Quote:
Originally Posted by alljoj
Oh! Well, I already added my graphics card to the database with Graphics Rules Maker, so I don't know what to do on that front. Is there another thing I need to do?


Check that link I posted. Even with graphic rules sometimes the files have to be edited by hand. It is usually just something as simple as deleting out part of the card name. For example. You have a Nvidia Geforce GTX 1050T. If you look at the video card file, it should say exactly that, along with how many gb of memory the card has, because you used graphic rules. The problem is the game does not recognize that. So you would have to go in to the video card file and select to edit it in notebook, delete out the Nvidia at the beginning of that (leaving just the Geforce GTX 1050T and whatever memory it might say) then save it and try to run the game again. Delete caches before launching it again and see if it helps.

Yes like CatOfEvilGenious said, if you can post your sgr files video card and graphic rules here that would be useful. I would be more then happy to take a look.
Page 1 of 3
Back to top