Replies: 12 (Who?), Viewed: 845 times.
Lab Assistant
Original Poster
#1 Old 27th Oct 2019 at 12:17 AM Last edited by Hammyx : 27th Oct 2019 at 3:07 AM.

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default [SOLVED] The Application Has Crashed. It will now terminate and Pink Flashing
Hi... I know there have been several threads about this topic but I just have tried every single thing and the problem is still there! I will explain fully what is happening.

My CC folder is around 12.3 GB, but that's not the problem. How do I know? Because in my laptop (with 8 GB of RAM and NO graphics card) that has Windows 7 I never had an issue like this.
Thing is, I bought a new computer (yes, desktop) that has an NVidia Geforce 2060 Super (8 GB), 16 GB of RAM, Windows 10 Pro and Processor Ryzen 7 3700x.
The first thing I did after installing the Sims 2 was changing the Graphic Rules files as well as the Video Cards one manually and with the help of Graphic Rules Maker. My game DOES recognize the card, I have the 4GB Patch applied (logs text confirms so), I removed SecuROM (well, I tried, because it wasn't actually there, there was nothing to remove, I used the SecuROM removal tool), I already forced texture memory (it is at 8192 MB which is my GPU's amount of memory), it is at the highest resolution possible, I set the "enableDriverMemoryManager" to true -I don't remember how it was called, but it was in the graphic rules file-, I downloaded the EmptyStandByList and put it to run every 5 minutes in the Task Scheduler (as some of you may know, it kind of "empties" the Standy Memory allowing more Free Memory to be used in other programs), I created a new neighborhood and deleted the old one in case it was a problem with the installed lots and sims, I have tried deleting the Thumbnails folders, the Accesory, Groups, and cigen caché files and... Honestly, I don't know if I have tried something else, but you get the idea.

Despite EVERYTHING I have done, my game flashes pink, sometimes it's a sim, an object, sometimes it's the whole neighborhood, a family, a lot, but SOMETHING has to flash pink. Most of the time, when it does, the game crashes and "The Application has CRASHED. It will now terminate" goes afterwards. Usually, if I go out of a lot that had something flashing pink, it spread to the whole neighborhood (but I restart the game it's well again). Another solution I tried was turning shaders off, bumpmapping to false and lighting medium as well as disabling shadows. Hoping this would work (as it is a problem with texture memory and I have like 33k files of CC), I did this and even put in the startup file. But the problem keeps going on...

Recently, when trying to create a family, some families in the family bin were flashing pink and the game crashed whenever I clicked on the bin itself (you know, Families, Lots and Decor, I clicked Families and it crashed. Lots and Decor are fine even though I installed the houses again and had no custom family!).

I'm starting to think this is a problem with windows 10, which btw I have the May 2019 Update, because in my Windows 7 Laptop it runs fine (kinda laggy, but the same CC and no problems) but at the same time, I don't think it is. My game is cracked as well and is running in no compatibility mode as this would disable the 4GB patch. One time I tried running it on Compatibility Mode for Windows 7, but it was worse (probably because of the 4gb patch being disabled).
When opening makeup tabs in CAS and makeup in mirrors it takes a while to load and when it does it gets really LAGGY, really really, but it is only with makeup (and considering the amount of makeup I have downloaded, I am not worried because everything else loads fine -though I have a bunch of downloaded high-poly hairs but they load fast).

I really really don't know what else I can do, I want the pink flashing and crashing to go away but nothing works!! I have tried literally EVERYTHING! Can someone, please, lighten me up and tell me way! Thanks in advance. Also, I have it windowed mode, but the problem remains in fullscreen, so no point in trying that

EDIT: Even Decorgarl's talk hacks are pink.. Geez, someone help me please

Attachment: This is a NO CC Lot and it still flashes pink btw...
Screenshots

What's the point?
Advertisement
Mad Poster
#2 Old 27th Oct 2019 at 1:30 AM Last edited by simmer22 : 27th Oct 2019 at 1:43 AM.
Sorry, but new computer (and Win10), new rules. Anything 1000 and 2000 Nvidia series combined with Win10 seems to be a bit touch-and-go. TS2 is an old game, and works best with Win7 or below, plus older graphic cards. Possibly also due to a particular Win10 update that caused an issue with several 32-bit games, but of course not for everyone...

Fellow frustrated pink-flashing victim here. My old stationary from 2009 managed 30 GB with Vista and 4 GB ram (only very occasional pink during heavy loads - as expected), but my new gaming laptop with a 1070 Nvidia card and 32 GB ram has had all sorts of issues and so far I've gotten it to run once without any pink-flashing with less than 1 GB (took quite a while to get there, because I had to go through and fix every single issue I've never had with my previous computers ). Crashes left and right, and pink-flashes from startup at a whim. Running my old game files? No chance! Still working on it, though. When it works it loads super fast and runs smoother than ever, so I do hope to find a solution because I know there's still a chance.

Looks like you've already found the help topics, and so far that's the best solutions out there (4GB, memory allocation, GraphicRules/VideoCard edits, etc.) - I've tried them all, and they did help a little bit, but not enough.

This fix is still in the testing stage (haven't tried it), but could possibly be worth a try:
http://www.modthesims.info/showthread.php?t=633003 (scroll through - I'm not sure exactly how it works and where to find it)
Lab Assistant
Original Poster
#3 Old 27th Oct 2019 at 1:46 AM
Quote:
Originally Posted by simmer22
Sorry, but new computer (and Win10), new rules. Anything 1000 and 2000 Nvidia series combined with Win10 seems to be a bit touch-and-go. TS2 is an old game, and works best with Win7 or below, plus older graphic cards. Possibly also due to a particular Win10 update that caused an issue with several 32-bit games, but of course not for everyone...

Fellow frustrated pink-flashing victim here. My old stationary from 2009 managed 30 GB with Vista and 4 GB ram (only very occasional pink during heavy loads - as expected), but my new gaming laptop with a 1070 Nvidia card and 32 GB ram has had all sorts of issues and so far I've gotten it to run once without any pink-flashing with less than 1 GB (took quite a while to get there, because I had to go through and fix every single issue I've never had with my previous computers ). Crashes left and right, and pink-flashes from startup at a whim. Running my old game files? No chance! Still working on it, though. When it works it loads super fast and runs smoother than ever, so I do hope to find a solution because I know there's still a chance.

Looks like you've already found the help topics, and so far that's the best solutions out there (4GB, memory allocation, GraphicRules/VideoCard edits, etc.) - I've tried them all, and they did help a little bit, but not enough.

This fix is still in the testing stage (haven't tried it), but could possibly be worth a try:
http://www.modthesims.info/showthread.php?t=633003 (scroll through - I'm not sure exactly how it works and where to find it)


Hi, I just came from another "The application has crashed" experience and pink flashing... I will try the fix you are providing me with, i'll tell you how it goes, I hope it solves this

What's the point?
Lab Assistant
Original Poster
#4 Old 27th Oct 2019 at 2:43 AM
Okay this is what happened! So far, your solution (or whoever it is, thank you, thank you SO much) IT WORKED! No crash nor flashing pink, but there are exceptions. I will attach how the lot looks like now (after the fix), there's no flashing pink, the objects are fine, no crashes, no lagg, it's amazing! However, the only thing I realized is that, after going back to the neighborhood, the hood was flashing pink. So I entered the lot again, but it was fine. However, again, when i returned to the hood, it flashed pink. I moved another family to another lot, and for some reason when I went back to the hood, it wasn't flashing pink anymore. What surprised me is that this lot was custom, downloaded, but the one causing the pink flashing was Maxis, so I don't understand that... also, two families in the family bin are flashing pink, tho they are maxis ones, I don't know why either.. but right now, this has been the best I've seen and I'm glad you read me and decided to help me in any way, thank you so much!!!
Screenshots

What's the point?
Lab Assistant
Original Poster
#5 Old 27th Oct 2019 at 3:03 AM
UPDATE: I reentered the game and NO pink flashing!!!! I also tested what had made it pink flash before (going back to the hood after entering the lot I told you, and no pink flashing occurred) My god, I really hope this is a definitive solution and ANYONE out there who has the same issues HAS to try it! My game is smoother than ever! Simmer22, definitely try it, it's worth it, I hope it works for you the same way it did for me!

What's the point?
Mad Poster
#6 Old 27th Oct 2019 at 4:14 AM
Just so you know, I did have the "no flashing pink until going back to the beighborhood" issue a few times, too - and that's without the fix. Don't count on the issue being fully fixed yet.
Lab Assistant
Original Poster
#7 Old 27th Oct 2019 at 4:27 AM
Quote:
Originally Posted by simmer22
Just so you know, I did have the "no flashing pink until going back to the beighborhood" issue a few times, too - and that's without the fix. Don't count on the issue being fully fixed yet.


Till know I think it is, I entered the game again and did the same to check if it would flash pink and it didn't, but it's always nice to be prepared! Thanks again

What's the point?
Lab Assistant
#8 Old 27th Oct 2019 at 4:09 PM
Quote:
Originally Posted by Hammyx
Till know I think it is, I entered the game again and did the same to check if it would flash pink and it didn't, but it's always nice to be prepared! Thanks again


I think some of the pink flashing after installing the fix were from caches that haven't been evicted yet. I left deleting them out of the guide because it was already quite long as it is.
Lab Assistant
#9 Old 27th Oct 2019 at 4:11 PM
Quote:
Originally Posted by simmer22
This fix is still in the testing stage (haven't tried it), but could possibly be worth a try:
http://www.modthesims.info/showthread.php?t=633003 (scroll through - I'm not sure exactly how it works and where to find it)


Give it a try sometime. If you have issues, hit up the Discord link in the guide. At this point, even UrbanSims has made a video on it after it let her use her crazy-ass Nvidia Titan XP for Sims 2.
Lab Assistant
Original Poster
#10 Old 27th Oct 2019 at 5:45 PM
Quote:
Originally Posted by crazysim
I think some of the pink flashing after installing the fix were from caches that haven't been evicted yet. I left deleting them out of the guide because it was already quite long as it is.


I understand, that's most likely the reason why it did not happen again. Thank you for taking the time write it, you SAVED me!

What's the point?
Lab Assistant
Original Poster
#11 Old 27th Oct 2019 at 5:55 PM
I made a video tutorial yesterday (took time to edit :/) with the new fix you provided me with! However, it's in Spanish since I'm Ecuadorian, but maybe you can follow the steps anyways. I'll leave the link in case someone needs it; the fourth solution with D9VK starts at minute 22:30. https://www.youtube.com/watch?v=g05x9Cc0Wys&t=1402s

What's the point?
Lab Assistant
#12 Old 27th Oct 2019 at 6:56 PM
Believe me, a lot of those steps and warnings are written in blood from helping people out in the Discord. Great to see another video though!
Lab Assistant
Original Poster
#13 Old 27th Oct 2019 at 7:18 PM
Quote:
Originally Posted by crazysim
Believe me, a lot of those steps and warnings are written in blood from helping people out in the Discord. Great to see another video though!


Hahahha I can tell xDD But luckily I'm Spanish so maybe I can help someone who doesn't know English

What's the point?
Back to top